Results 1 to 3 of 3

Thread: MAJOR mouse issue...can't click anything!!!!

  1. #1
    Join Date
    Mar 2007

    MAJOR mouse issue...can't click anything!!!!

    Running on an Acer Aspire One with a USB mouse. I've been running Ubuntu variants on this machine since new, and have never had any problems until now.

    Each time I boot and get to the desktop, the mouse only works for a few minutes before it starts to ignore my clicks. It doesn't matter how many times I click something, it doesn't give a response. Mouseover doesn't cause a reaction from the buttons as it should, either. If I disconnect my USB briefly then plug it back in, it works normally for a few clicks, then right back to the same old thing.

    If I can get Firefox open, then my mouse cursor works just fine in that. But, if I try to click anywhere outside of the open window, even to hit the X button to close Firefox, I get nothing.

    Once, when the computer went into standby and I woke it back up, at XScreensaver login screen, it complained that something wasn't releasing the pointer or that it couldn't capture pointer...I can't remember exactly which, but it was one of the two.

    The touchpad reacts the same way, except that usually, once it quits working, it doesn't come back on, probably because I can't unplug it.

    Thinking that something was seriously wrong with my system, I decided to just wipe the install and start over. I installed Ubuntu 11.04, and it did the same thing. Tried Xubuntu, Lubuntu, and Kubuntu 11.04, all with the same result. Now trying Fedora, on a USB drive, with the same result! What could be holding the pointer hostage, and why would it suddenly start doing it on EVERY single OS variant that I have tried? I've run 11.04 on this computer for a few weeks now without issue; only in the last few days did the problem manifest itself.

    If I can't fix this, I have no idea what I'm going to do. I don't want to buy a new netbook, especially when it doesn't seem necessary. I can't find a distro that will run on this machine without grabbing my pointer, and I have no idea why. Some suggested disabling Compiz, but I didn't even have that on Lubuntu. Same issue. A few weeks ago, I upgraded by bios. Could it be a bios virus of some sort?

    Does anyone have any advice about where to start? Has anyone else ever had this problem before? I'm desperate for a solution or even a workaround at this point and I'll give anything a shot...

  2. #2
    Join Date
    Nov 2010

    Re: MAJOR mouse issue...can't click anything!!!!

    sounds like a hardware problem, can you post your system specs please
    If at first you don't succeed, try until you bleed

  3. #3
    Join Date
    Mar 2007


    You are correct. Hardware issue.

    I moved that mouse to my laptop and the same thing happened. I hope it's just a battery, although it is supposed to submit low battery info to the power management thingymadoo bopper in Ubuntu. Usually works spot on.

    Might just be a bad mouse.

    Still a valuable thread, because it teaches a valuable lesson:

    CHECK THE OBVIOUS FIRST. I have been tearing my hair out over this one for the past 3 days.

    Hope this takes care of it. Thanks for pre-thinking my thoughts for me.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts