Results 1 to 4 of 4

Thread: SSHFS in fstab issue

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Beans
    148
    Distro
    Ubuntu 11.04 Natty Narwhal

    Question SSHFS in fstab issue

    I have an issue with sshfs whenever it is mounted from /etc/fstab. Here is what I did:

    Code:
    $ sshfs -o port=2226 home-server:/path /media/mountpoint
    This works fine and I can read/write from the mountpoint with no issue. Now, if I add a line in /etc/fstab like this:
    Code:
    sshfs#pieroxy@home-server:/path /media/mountpoint fuse user,port=2226 0 0
    Here is the result:

    Code:
    $ sudo mount /media/mountpoint
    $ ls /media/mountpoint
    ls: cannot access /media/mountpoint: Permission denied
    $ ls -l /media/
    ls: cannot access /media/mountpoint: Permission denied
    total 76
    d?????????  ? ?       ?           ?                ? mountpoint
    (........)
    Does anyone has an idea of what is wrong here?

  2. #2
    Join Date
    Nov 2006
    Beans
    148
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: SSHFS in fstab issue

    Ok, so it has gotten worse as today I cannot mount my share even manually. When running the command line I get the same result as the fstab.

    Ont funny thing is the following:
    Code:
    $ sudo sshfs -p 2226 pieroxy@home-server:/path/ /media/mountpoint/
    $ ll /media/
    ls: cannot access /media/mountpoint: Permission denied
    (...)
    d?????????  ? ?       ?           ?                ? mountpoint/
    (...)
    $ sudo ls -l /media/
    (...)
    drwxrwxrwx  1 pieroxy pieroxy  4096 2011-07-31 22:13 mountpoint
    (...)
    $
    Does anyone has a clue?

  3. #3
    Join Date
    Feb 2008
    Beans
    1

    Re: SSHFS in fstab issue

    I ran into this as well, it is not a 'good' solution but a user by the name of 'grawity' posted the below on another site (link below as well). Hope this helps.

    sshfs is a FUSE-based filesystem, and the FUSE layer does not allow other users to access its mounts by default, for security purposes. You have allow_other in options, but it will be ignored until you also edit /etc/fuse.conf to include user_allow_other

    I found the advice here:
    http://superuser.com/questions/26277...red-with-samba

  4. #4
    Join Date
    Nov 2006
    Beans
    148
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: SSHFS in fstab issue

    Wow... I didn't expect any answer to this message this late after my posting !!! Thanks.

    I added allow_other in my fstab line and it seems to be working. Will follow up if I need to do anything else.

    Thanks again!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •