Results 1 to 4 of 4

Thread: Problem mounting windows file share

  1. #1
    Join Date
    Aug 2011

    Problem mounting windows file share

    I am trying to install matlab from a windows file share server following the instructions below:

    • su to root.
      % su
    • Make a directory for mounting the distribution# mkdir -p /mnt/licensed.dist
    • Mount the distribution with SMB:
      # mount -t smbfs -o username=PRINCETON\\<netID> // /mnt/licensed.dist
      • All one line, no line breaks
      • Replace <netID> with your Princeton netID
      • You will be prompted for a password. Please enter your Princeton Windows password.
      • If the command does not work, you might not have SMB mount support installed.
      • NOTE: As of Red Hat Enterprise Linux 5 and Fedora releases, use 'cifs' instead of 'smbfs' as the -t parameter above.

    • Run the Matlab installation
      # /mnt/licensed.dist/Products/Matlab/R2011a/Unix/

    However, when I try the mount it returns the mount usage and the return value is 1 and the mount doesn't work. Any ideas?

  2. #2
    Join Date
    Jan 2010
    Ubuntu 12.04 Precise Pangolin

    Re: Problem mounting windows file share

    I haven't done this, but was curious and googled around. Here is how it a similar situation is described by your West Coast competitor:

    The more interesting part is if you follow the link on that page back to the ubuntu forums. It appears that 'smfbs' is a package you need to install separately (it also appears it is sort of obsolete and replaced by another program, but you need to of course follow your instructions). So suggestions:

    (1) install smfbs
    (2) make sure you issue this command being in the right directory, if the dir you made isn't at root.
    (3) have a look a the articles for safety.
    (4) as -o lists options separated by comma, look closely if you're not missing one (you set UID, passwd, link - is that really not separated by commans?)


  3. #3
    Join Date
    Aug 2011

    Re: Problem mounting windows file share

    Thanks for the reply. I had already installed smbfs, but i realized that i needed to add \mnt\licensed.dist to the end, so when I do the following:

    mount -t smbfs -o username=PRINCETON\\deis // /mnt/licensed.dist

    it returns:

    mount error(20): Not a directory
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    I get the same error when I do cifs instead of smbfs.

  4. #4
    Join Date
    Aug 2011

    Re: Problem mounting windows file share

    Okay, I think I found the problem, on the website I couldn't tell that there was a space between // and /mnt/licensed.dist, now it seems to be okay, I'll try to see if the rest works. Thanks again for your help.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts