I have: WinXP (FAT32) on SDB1, Ubuntu Studio (ext4) 10.4 on SDB2, NetBSD on SDB3, and an extended partition with an NTFS partition, a Linux sap partition, and 3 FAT32 partitions. I had the GRUB loader on the boot sector of SDB2 and used a tool called BOORPART to install it onto the WinXP partition so I used the NT boot loader to link to the GRUB loader. The WinXP and Ubuntu Studio partitions were running out of space, so I used GParted to resize and move all the partitions. I made the FAT32 data partitions smaller and moved them. I deleted and re-created/re-located the Linux partition, and I relocated the NTFS partition. I deleted and re-created/re-located (but not formatted or loaded) the NetBSD partition and so it should have been seen as unallocated space. I enlarged and re-located the Ubuntu Studio partition, and I enlarged the WinXP partition. WinXP booted, but Ubuntu Studio did not. testdisk did not find the new NetBSD partition (it skipped that empty space), and it showed the NTFS data partition as a primary partition. I tried to use the Ubuntu Studio DVD to re-install GRUB, but I ended up in the dialog to re-install all of Ubuntu Studio. But that failed anyway. I tried Gparted from a live CD but it thought the ENTIRE DISK was unallocated! I tried Parted and it said a partition went outside of the disk. I used testdisk to make images of and delete all but SDB1 and SDB2 (WinXP and Ubuntu Studio). Then Gparted could find my first two partitions and WinXP could still boot. So I used Gparted to re-create all the other partitions except the first 2. I loaded the backed up images into the new partitions, and finally Gparted can see ALL my partitions just as I created them and the live CD can see all the recovered data as well. The live CD can also see all the Ubuntu Studio file system and all the files, so I know it is still there. So I tried the Ubuntu Studio install DVD again to do a repair install to re-install GRUB to the boot sector of the Ubuntu Studio partition and it fails. It says re-install grub fails with code 1. So, how do I get grub to install on that partition so I can boot my Ubuntu Studio partition? Anyone read this entire post? Anyone know how to help?