Results 1 to 3 of 3

Thread: X.org update bonked my input devices

  1. #1
    Join Date
    Sep 2007
    Location
    Belo Horizonte/Brazil
    Beans
    573
    Distro
    Ubuntu 9.10 Karmic Koala

    X.org update bonked my input devices

    Hey all,

    Last weekend I did a fresh install of Natty into my new HD following the crash of my last one (hooray for periodic backups). I had no problems at all, my mouse and keyboard were working fine. The system was running without a xorg.conf file in /etc/X11.

    Then, I installed the restricted driver for my NVidia GeForce 8600 GT and rebooted, but the driver was not being used. I ran nvidia-xconfig as root, which created a xorg.conf file telling X to use the driver. Reboot, everything is working fine.

    Now, this morning a few packages were updated, including xorg. The next time I tried to log in after this update, I found that neither my mouse nor keyboard were responding - I couldn't even switch to another tty or, indeed, do anything other than a hard reboot.

    I have a LiveUSB with natty and a partition running Sabayon Linux on another hard drive from which I can mess around in my Kubuntu partition. How do I fix this?
    Last edited by GepettoBR; August 24th, 2011 at 05:31 PM.

  2. #2
    Join Date
    Sep 2007
    Location
    Belo Horizonte/Brazil
    Beans
    573
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: X.org update bonked my input devices

    BUMP. I really need help here.

  3. #3
    Join Date
    Sep 2007
    Location
    Belo Horizonte/Brazil
    Beans
    573
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: X.org update bonked my input devices

    I fixed the issue by chrooting into my Kubuntu partition from Sabayon and running "dpkg-reconfigure xserver-xorg".

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •