Page 7 of 7 FirstFirst ... 567
Results 61 to 62 of 62

Thread: Boot-Repair-Disk : THE 'must-have' rescue CD !

  1. #61
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Boot-Repair-Disk : THE 'must-have' rescue CD !

    You show /ubuntu folder in efi partition which would not be a locked efi?

    Boot-Repair picks up on this issue.
    grub-efi fails to install with Input/output error - locked efi
    https://bugs.launchpad.net/ubuntu/+s...2/+bug/1090829
    https://bugs.launchpad.net/ubuntu/+s...2/+bug/1091477

    Boot-Repair is just a script that runs in the Ubuntu live installer or can be a full ISO bootable repair installer. If you have live installer without persistence you will have to download each time you reboot or may have to reinstall every time.

    The locked efi, is something in the FAT32 efi partition. Supposedly there is no way to lock that and it is only FAT32, so some bug in FAT32 partition?
    A few have been able to run chkdsk from Windows on the efi partition and fixed it.
    But most have just had to fully back up the entire efi partition - it is not large. Then totally delete it with gparted in live system, and then recreate it and restore data from backup.
    The efi partition is a FAT32 formatted partition with the boot flag (if using gparted). It is only on gpt partitioned drives and you can only have one efi partition per hard drive.
    Last edited by oldfred; April 10th, 2014 at 05:56 PM.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  2. #62
    Join Date
    Aug 2010
    Beans
    29
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Boot-Repair-Disk : THE 'must-have' rescue CD !

    Thanks again Oldfred.
    http://www.eightforums.com/tutorials...ndows-8-a.html told me that to run chkdsk in Windows 8.1, I had to open File Manager, right-click on C: drive, Properties, Tools tab, click on the Check button. I did this 4-5 times and each time, it said that there were no errors. Then I shut-down, booted from Boot Repair and ran it following instructions. It said it worked but that I should make sure I was booting from the file it named. I shutdown, rebooted and went into my BIOS. There seemed to be somewhere to change which file but it was greyed out. I exited the BIOS, waited and saw the beautiful sight of my GRUB menu, made my choice and saw the even more beautiful sight of my Ubuntu desktop.

    Many thanks for your help

    Your signature says to close the thread when answered. My issue is definitely answered but I think you would like me to leave the thread open for others with boot problems.

Page 7 of 7 FirstFirst ... 567

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •