Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: No Wireless - Broadcom 4311

  1. #1
    Join Date
    Jun 2008
    Beans
    47

    Question No Wireless - Broadcom 4311

    OK...over the past two days I have read through every post in the sticky thread and tried just about everything, but no luck. I hope someone can point me in the right direction.

    $ sudo lshw -C network

    *-network
    description: Network controller
    product: BCM4311 802.11b/g WLAN
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    version: 01
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: driver=b43-pci-bridge latency=0
    resources: irq:0 memory:b6000000-b6003fff
    *-network DISABLED
    description: Wireless interface
    physical id: 1
    logical name: wlan0
    serial: 00:1a:73:02:6b:bd
    capabilities: ethernet physical wireless
    configuration: broadcast=yes driver=b43 driverversion=2.6.38-8-generic firmware=410.2160 link=no multicast=yes wireless=IEEE 802.11bg

    $ dmesg |grep b43

    [ 2.795109] b43-pci-bridge 0000:03:00.0: can't find IRQ for PCI INT A; probably buggy MP table
    [ 2.795119] b43-pci-bridge 0000:03:00.0: setting latency timer to 64
    [ 88.964315] b43-phy0: Broadcom 4311 WLAN found (core revision 10)
    [ 89.042637] Registered led device: b43-phy0::tx
    [ 89.042672] Registered led device: b43-phy0::rx
    [ 89.042708] Registered led device: b43-phy0::radio
    [ 89.784042] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 89.856563] b43-phy0 ERROR: Cannot request IRQ-0
    [ 90.092046] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 90.164566] b43-phy0 ERROR: Cannot request IRQ-0

    lsmod |grep b43

    b43 296610 0
    mac80211 257001 1 b43
    cfg80211 156212 2 b43,mac80211
    ssb 45942 1 b43

    $ rfkill list

    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

    I have commented out the various entry in blacklist.conf, deactivated the STA driver, and have b43-fwcutter installed. And yeah, the wireless switch is "on" and works fine under Windows 7.

    Thanks in advance.
    Last edited by KemKev; August 11th, 2011 at 08:17 PM.

  2. #2
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No Wireless - Broadcom 4311

    Those bits in your dmesg output about failing to request an IRQ address suggest the issue is related to your BIOS, not driver. Someone here with the same problem found that disabling APIC took care of it. I'd give that a try.

    To disable APIC, open a terminal and type:

    Code:
    sudo gedit /boot/grub/grub.cfg
    A file will open. Search for the first instance of the word "menuentry" A few lines down you should have a line that looks something like this (it will not look exactly like this):
    Code:
    linux	/boot/vmlinuz-2.6.38-8-generic root=UUID=6ca6b2a3-c3a3-4ad0-81fd-1f49ab0c0dcc ro   quiet splash vt.handoff=7
    Add "noapic" to the end of that line, so it looks like this (don't change any other parts of the line):
    Code:
    linux	/boot/vmlinuz-2.6.38-8-generic root=UUID=6ca6b2a3-c3a3-4ad0-81fd-1f49ab0c0dcc ro   quiet splash vt.handoff=7 noapic
    Then save and close the file, and reboot. You should now be running without APIC. Do you still get the same message in your "dmesg | grep b43" output about IRQ issues?

  3. #3
    Join Date
    Jun 2008
    Beans
    47

    Re: No Wireless - Broadcom 4311

    Thanks for your response. I edited the suggested file as shown below:

    linux /vmlinuz-2.6.38-8-generic root=UUID=f3680e13-d156-4b1f-b38d-01c88655cb63 ro quiet splash vt.handoff=7 noapic

    When I rebooted, the orange light was still orange (still no wireless).

    dmesg | grep b43

    [ 2.715784] b43-pci-bridge 0000:03:00.0: can't find IRQ for PCI INT A; please try using pci=biosirq
    [ 2.715797] b43-pci-bridge 0000:03:00.0: setting latency timer to 64
    [ 16.515116] b43-phy0: Broadcom 4311 WLAN found (core revision 10)
    [ 16.591160] Registered led device: b43-phy0::tx
    [ 16.591198] Registered led device: b43-phy0::rx
    [ 16.591229] Registered led device: b43-phy0::radio
    [ 17.200046] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 17.272572] b43-phy0 ERROR: Cannot request IRQ-0
    [ 17.500055] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 17.576989] b43-phy0 ERROR: Cannot request IRQ-0

    $ sudo lshw -C network

    *-network
    description: Network controller
    product: BCM4311 802.11b/g WLAN
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    version: 01
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: driver=b43-pci-bridge latency=0
    resources: irq:0 memory:b6000000-b6003fff
    *-network DISABLED
    description: Wireless interface
    physical id: 1
    logical name: wlan0
    serial: 00:1a:73:02:6b:bd
    capabilities: ethernet physical wireless
    configuration: broadcast=yes driver=b43 driverversion=2.6.38-8-generic firmware=410.2160 link=no multicast=yes wireless=IEEE 802.11bg

    Any other thoughts / suggestions would be greatly appreciated.

    PS: I should point out that when I reboot the HP Pavilion dv6000 laptop, the orange light flashes blue a couple of times before becoming static on orange.
    Last edited by KemKev; August 12th, 2011 at 01:07 AM. Reason: Added PS

  4. #4
    Join Date
    Jun 2008
    Beans
    47

    Re: No Wireless - Broadcom 4311

    The situation is still the same but I found something in the dmesg log that may be useful to someone in helping me resolve the problem:

    0.147119] AppArmor: AppArmor Filesystem Enabled
    [ 0.147154] pnp: PnP ACPI: disabled
    [ 0.147159] PnPBIOS: Scanning system for PnP BIOS support...
    [ 0.147219] PnPBIOS: Found PnP BIOS installation structure at 0xc00f89c0
    [ 0.147223] PnPBIOS: PnP BIOS version 1.0, entry 0xe6e5:0x9acd, dseg 0x400
    [ 0.147230] PNPBIOS fault.. attempting recovery.
    [ 0.147233] PnPBIOS: Warning! Your PnP BIOS caused a fatal error. Attempting to continue
    [ 0.147236] PnPBIOS: You may need to reboot with the "pnpbios=off" option to operate stably
    [ 0.147238] PnPBIOS: Check with your vendor for an updated BIOS
    [ 0.147241] PnPBIOS: dev_node_info: unexpected status 0x3a
    [ 0.147244] PnPBIOS: Unable to get node info. Aborting.

    Is the "pnpbios=off" even worth trying and if so, how and where do I do that?

    All of this is weird because the previous version of Ubuntu worked just fine on my laptop

    HELP!
    Last edited by KemKev; August 12th, 2011 at 04:19 AM.

  5. #5
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No Wireless - Broadcom 4311

    hmmm, it seems the noapic option didn't change anything regarding the IRQs. That other line in your dmesg is interesting, however. I would try booting with the pnpbios=off option, as recommended. To do that, simply follow the steps above for editing your /boot/grub/grub.cfg file, but instead of adding "noapic" to the line that starts with "linux", add "pnpbios=off" (without quotes) instead, then reboot. Does this change anything?

  6. #6
    Join Date
    Jun 2008
    Beans
    47

    Re: No Wireless - Broadcom 4311

    Thanks for the follow up. I edited the line in the file to read:

    linux /vmlinuz-2.6.38-8-generic root=UUID=f3680e13-d156-4b1f-b38d-01c88655cb63 ro quiet splash vt.handoff=7 pnpbios=off

    When I rebooted, the orange light again flashed blue a number of times before finally staying orange.

    From the dmesg log file:

    0.187428] AppArmor: AppArmor Filesystem Enabled
    [ 0.187463] pnp: PnP ACPI: disabled
    [ 0.187466] PnPBIOS: Disabled
    [ 0.2

    Executing "dmesg | grep b43" produced the same output as before.

    As an aside, I also went to the HP website and flashed the BIOS with the latest revision. That didn't change anything.

    Wireless continues to work like a charm under Windows 7 (I am dual booting) so I have to assume the BIOS shouldn't be the problem.
    Last edited by KemKev; August 12th, 2011 at 05:56 AM. Reason: Added entry from log file.

  7. #7
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No Wireless - Broadcom 4311

    Does dmesg still contain the same lines complaining "Warning! Your PnP BIOS caused a fatal error. Attempting to continue" after you rebooted with the "pnpbios=off" option? It's possible the change is not actually taking effect.

    Also, to clarify, I suspect the issue is BIOS-related, but I doubt you have a "bad" BIOS in that there's something wrong with your version. It probably is just not agreeing with the Linux kernel for some reason, even though it works in Windows without issue, but making a few changes to the configuration should hopefully allow Linux to work around the bugs. So I don't think you should worry about reflashing the BIOS and all that; that's probably not the source of the problem.

  8. #8
    Join Date
    Jun 2008
    Beans
    47

    Re: No Wireless - Broadcom 4311

    Quote Originally Posted by pytheas22 View Post
    Does dmesg still contain the same lines complaining "Warning! Your PnP BIOS caused a fatal error. Attempting to continue" after you rebooted with the "pnpbios=off" option? It's possible the change is not actually taking effect.
    No, the warning wasn't there after the reboot. In my previous post, the dmesg log showed both "PnP ACPI" and "PnPBIOS" as disabled so I would imagine the off option worked. It still showed IRQ-0 could not be requested.

    As for flashing the BIOS, I did it based on the line below from the dmesg log:

    [ 0.147238] PnPBIOS: Check with your vendor for an updated BIOS
    Last edited by KemKev; August 12th, 2011 at 01:37 PM.

  9. #9
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No Wireless - Broadcom 4311

    At least the change did something, even if it didn't solve the problem. My next suggestion for you would be to try disabling ACPI instead of APIC. The post from another forum that I referenced yesterday said turning of APIC was the trick, but the poster may have confused that with ACPI. (Unfortunately these are two separate things, despite their similar names.)

    To disable APCI, add the string "noacpi acpi=off" (without quotes) to your /boot/grub/grub.cfg file as before. After doing this and rebooting, does the dmesg output change?

  10. #10
    Join Date
    Jun 2008
    Beans
    47

    Re: No Wireless - Broadcom 4311

    Thanks for dropping in again. I modified the string as per below:

    linux /vmlinuz-2.6.38-8-generic root=UUID=f3680e13-d156-4b1f-b38d-01c88655cb63 ro quiet splash vt.handoff=7 noacpi acpi=off

    Net result is a low droning sound from the laptop after rebooting with the orange light still there. The "dmesg | grep b43" produced the same message as before; still unable to request IRQ-0.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •