Results 1 to 4 of 4

Thread: Internet not working in ubuntu installed in virtual box

  1. #1
    Join Date
    Sep 2010
    Beans
    5

    Internet not working in ubuntu installed in virtual box

    Hi,

    I have Windows 7 as my host machine and I am behind a proxy for
    accessing the internet.

    I installed virtual box in windows and then ubuntu 11.04 in
    virtual box.

    I then edited the apt.conf with proxy name
    so that I could update, and and was able to do so.


    But now I am not able to connect to internet from ubuntu whereas I am able to connect from windows7.

    The error is : could not resolve proxy name.

    Did something went wrong while updating.
    What could be the reason.

  2. #2
    Join Date
    Nov 2007
    Beans
    297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Internet not working in ubuntu installed in virtual box

    You shouldn't have to worry about the proxy setting in Ubuntu unless you have virtualbox configured to bridge your network connection. By default, virtualbox uses a NAT. Did you test your connection before you made the change to apt.conf?

  3. #3
    Join Date
    Nov 2009
    Beans
    47

    Re: Internet not working in ubuntu installed in virtual box

    Beacon11, if he needs a proxy to connect to the Internet on his normal LAN wouldn't he still need that even in a NAT situation to properly get Internet? When the NAT routes traffic outside of itself it would get stuck trying to get to the Internet where it should be accessing a proxy server. Maybe I'm missing something though.

    lalit, Try adding the proxy settings to your browser.

  4. #4
    Join Date
    Nov 2007
    Beans
    297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Internet not working in ubuntu installed in virtual box

    Quote Originally Posted by idlemind324 View Post
    Beacon11, if he needs a proxy to connect to the Internet on his normal LAN wouldn't he still need that even in a NAT situation to properly get Internet? When the NAT routes traffic outside of itself it would get stuck trying to get to the Internet where it should be accessing a proxy server. Maybe I'm missing something though.

    lalit, Try adding the proxy settings to your browser.
    Now that you mention it, I'm not 100% certain. I figure there are some system-wide proxy settings you can change in Windows control panel, which would then work with virtualbox. However, you may also be able to go to the Network Proxy settings in Ubuntu and add the proxy info there.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •