Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: Thunar slow opening fix

  1. #11
    Join Date
    Feb 2009
    Location
    Hull, England
    Beans
    Hidden!
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Thunar slow opening fix

    Ernest
    Code:
    sudo leafpad /usr/share/gvfs/mounts/smb-browse.mount
    Then edit the file accordingly.

  2. #12
    Join Date
    Mar 2005
    Location
    Oregon
    Beans
    989
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Thunar slow opening fix

    Quote Originally Posted by mike555 View Post
    I think I have fixed the Thunar slow opening issue in Xubuntu , I noticed Thunar opened fast as root, but took almost 30 seconds to open normally, so I figured it was a permissions issue, so I opened Thunar, clicked on File > Properties > Permissions > then set your "group" to have read & write permissions ..... that worked good for me on two systems ...

    please let me know if this works for you ,if your having the same problem on Xubuntu 11.04.
    It worked a couple times, then went back to a long delay. Anyway other way to fix this problem?
    Last edited by geovino; January 26th, 2012 at 02:48 PM.

  3. #13
    Join Date
    Apr 2011
    Beans
    18

    Re: Thunar slow opening fix

    I think it's a better solution if you leave smb-browse.mount untouched, and edit network.mount instead. Set AutoMount to false.
    If you need network, just click on network:/// in Thunar, it will mount itself.

  4. #14
    Join Date
    Aug 2011
    Beans
    3

    Re: Thunar slow opening fix

    @mike555:
    oh thank-you sooooo much!!!!

  5. #15
    Join Date
    Feb 2012
    Beans
    1

    Salve Notizia per te

    Tra di noi dire, vi raccomando il check-out google.com

  6. #16
    Join Date
    Mar 2010
    Beans
    15

    Re: Salve Notizia per te

    still doesn't work for me. i've done every listed fix i can editing bits and pieces, still takes a good 30seconds to first open.

  7. #17
    Join Date
    Mar 2012
    Beans
    8

    Lightbulb Re: Thunar slow opening fix

    We also experienced same (bug?) Ubuntu 11.10 64bit (Thunar 1.2.3) Xfce 4.8

    after trying all of above mentioned solutions and not finding a fix that retained samba-browsing functionality. and at the request for another alternative method.. heres what we did that is working just peachy

    flying in the face of all logic and whats previously been mentioned we set
    AutoMount=true
    5th line down in file /usr/share/gvfs/mounts/smb-browse.mount
    rebooted and all is well... thunar is a little slow on first start 5-10 seconds..better than 20-30 everytime we opened it before.. Subsequent openings of thunar take around 1 sec.. also network tab on left side still allows us to browse/scan any SMB shares/mounts.
    to recap
    Code:
    nano /usr/share/gvfs/mounts/smb-browse.mount
    or if you prefer a GUI
    Code:
    leafpad /usr/share/gvfs/mounts/smb-browse.mount
    [Mount]
    Type=smb-network;smb-server
    Exec=/usr/lib/gvfs/gvfsd-smb-browse
    DBusName=org.gtk.vfs.mountpoint.smb_browse
    AutoMount=false
    Scheme=smb
    change 5th line down to true
    AutoMount=true
    hope it helps someone.. remember that to save changes to smb-browse.mount you MUST BE root in whichever text editor you opened it with.. ie leafpad, gedit, nano
    Last edited by FOSScula; March 25th, 2012 at 10:26 AM.

  8. #18
    Join Date
    Dec 2011
    Beans
    4

    Re: Thunar slow opening fix

    Though I'm on Slackware instead of Ubuntu, I got the same problem.

    I rarely use Thunar, but when I did it took approx 3 to 5 seconds to show the gui. In my case I had mounted a samba share an did not properly unmount it. So Thunar started and tried to open up that share, waiting some seconds for it to answer and finally giving up on it. Lazy unmounting the "dead" share solved the problem, the Thunar gui shows up instantly.

  9. #19
    Join Date
    Jul 2011
    Beans
    1

    Re: Thunar slow opening fix

    Thanks, I had all around issues with slowness that were resolved by manually installing amd drivers from their website and so this was the only thing that was bugging me. I'm glad it was such a simple fix

  10. #20
    Join Date
    Apr 2006
    Beans
    4

    Re: Thunar slow opening fix

    I for one don't need Samba browsing because my Samba server does NFS for Linux clients. So disabling smb-network is the correct and successful solution for me. It also resolved a side effect where once the first Thunar window opened, a duplicate would also open.

    I am not sure the cause of that, but removing 'smb-network;' fixed both.
    If the setting failed to fix and came back in the config, you may have forgotten to remove the semicolon, and Thunar would reactivate its automatic backup or a default of the config.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •