Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Cannot decrypt access-your-private-data.desktop

  1. #1
    Join Date
    Jul 2011
    Beans
    7

    Cannot decrypt access-your-private-data.desktop

    Hello!

    I've looked for a solution for this problem in several locations, but my issue is very specific and not answered, to my knowledge, anywhere in full.

    I am new to Linux, so please go step by step with me

    Backstory: Some unexplained event stopped me from booting the OS. Ends up that it was an issue with the kernel; somehow this harddrive became unaccessible. I have two identical hard drives, so I installed Ubuntu on the second one and updated the kernel to 3.0.(6?) after learning this may solve the accessibility problem.

    Now, I am able to run the OS only on the second drive, but have the first drive mounted (something like /media/drive2). Now the files are accessible, BUT I had encrypted my home folder (something I won't do in the future... didn't need to in the first place).

    The contents of /media/drive2/home/thedirkus are access-your-private-data.desktop and readme.txt, as in all other cases I've seen. So I tried the common solution:

    Code:
    thedirkus@thedirkuscomp:/media/drive2/home/thedirkus$ ecryptfs-mount-private
    ERROR: Encrypted private directory is not setup properly
    I know this has to be wrong. I probably need to put the files elsewhere or something. But, I don't want to poke randomly at the issue.

    Any help is greatly appreciated.

    --thedirkus

  2. #2
    Join Date
    Apr 2007
    Beans
    83
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Cannot decrypt access-your-private-data.desktop

    Post the result of
    Code:
    ls -a /media/drive2/home/
    so I can see what setup you have.
    This should get your files though:
    Code:
    sudo mkdir /media/ehome; sudo mount -t ecryptfs /media/drive2/home/.ecryptfs/thedirkus/.ecryptfs /media/ehome
    Your home folder should be visible now at /media/ehome. Copy the files over to your home folder if you want
    Last edited by Tea4all; July 24th, 2011 at 12:24 AM.

  3. #3
    Join Date
    Jul 2011
    Beans
    7

    Re: Cannot decrypt access-your-private-data.desktop

    Your first point:
    Code:
    ls -a /media/drive2/home
    .  ..  .ecryptfs  thedirkus
    For good measure:
    Code:
    ls -a /media/drive2/home/thedirkus
    .  Access-your-Private-Data.desktop  .ecryptfs  README.txt
    ..  .cache                                         .Private
    I tried the line of code you gave. It asked for a Passphrase, and I gave it what I assumed was the Passphrase because I only used one password for anything involving this user.

    It prompted me for a few options, and I selected all defaults. Then it gave me this error:
    Code:
    Error mounting eCryptfs: [-2] No such file or directory
    Check your system logs; visit <http://launchpad.net/ecryptfs>
    Also, I checked /media/ehome and nothing was in the folder.

    Any ideas? (sorry for slow response... having internet issues)

  4. #4
    Join Date
    Apr 2007
    Beans
    83
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Cannot decrypt access-your-private-data.desktop

    Actually, it might be easier th use a chroot.
    Code:
    sudo rm -ri /media/ehome
    Code:
    sudo su
    Code:
    D=/media/drive2
    mount -o bind /dev $D/dev
    mount -t sysfs none $D/sys
    mount -o bind /dev/shm $D/dev/shm
    mount -t proc none $D/proc
    chroot $D
    su thedirkus
    ecryptfs-mount-private
    Don't close the terminal.
    Got some help from http://www.cyberciti.biz/faq/ubuntu-...e-from-livecd/
    The files should be available at /dev/disk2/home/thedirkus.
    After copying you can type
    Code:
    umount /media/drive2/dev/shm
    umount /media/drive2/sys
    umount /media/drive2/dev
    umount /media/drive2/proc
    exit
    exit
    and unmount the drive. Hope it works.
    Last edited by Tea4all; July 24th, 2011 at 05:21 AM. Reason: mistaked -o for -t

  5. #5
    Join Date
    Jun 2010
    Location
    California
    Beans
    81
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot decrypt access-your-private-data.desktop

    Quote Originally Posted by thedirkus View Post
    It asked for a Passphrase, and I gave it what I assumed was the Passphrase because I only used one password for anything involving this user.
    This might be the problem. I've only done one install of Ubuntu with an encrypted user directory (my traveling netbook). After selecting the encrypted user directory option, I was provided with a 32 digit hexadecimal key to decrypt the directory. This key was generated by the installer, and it was not my user password or anything else familiar. If you no longer have this key, you might be out of luck.

  6. #6
    Join Date
    Jul 2011
    Beans
    7

    Re: Cannot decrypt access-your-private-data.desktop

    Quote Originally Posted by nosehat View Post
    This might be the problem. I've only done one install of Ubuntu with an encrypted user directory (my traveling netbook). After selecting the encrypted user directory option, I was provided with a 32 digit hexadecimal key to decrypt the directory. This key was generated by the installer, and it was not my user password or anything else familiar. If you no longer have this key, you might be out of luck.

    Yes, I just recalled I do in fact have that passphrase!!! One of those things I didn't think much of but recorded it just in case.

    So, I will reattempt with this passphrase. If it doesn't work, I will try Tea4all's second post.

    Will reply afterwards.

  7. #7
    Join Date
    Apr 2007
    Beans
    83
    Distro
    Ubuntu 11.04 Natty Narwhal

    Wink Re: Cannot decrypt access-your-private-data.desktop

    Quote Originally Posted by nosehat View Post
    This might be the problem. I've only done one install of Ubuntu with an encrypted user directory (my traveling netbook). After selecting the encrypted user directory option, I was provided with a 32 digit hexadecimal key to decrypt the directory. This key was generated by the installer, and it was not my user password or anything else familiar. If you no longer have this key, you might be out of luck.
    The code I gave should work with just a password. The newest post. If it doesn't, then you're not going to be able to get the data without the hexadecimal key (I think).

  8. #8
    Join Date
    Jul 2011
    Beans
    7

    Re: Cannot decrypt access-your-private-data.desktop

    I retried the first method where it is mounted to ehome. The result was that ehome contained the following files:

    Code:
    auto-mount  auto-umount  Private.mnt  Private.sig   wrapped-passphrase
    While attempting the second method, I get some errors:

    Code:
    thedirkus@thedirkuscomp:/media$ sudo su
    root@thedirkuscomp:/media# D=/media/drive2
    root@thedirkuscomp:/media# mount -o bind /dev $D/dev
    root@thedirkuscomp:/media# mount -o sysfs none $D/sys
    mount: special device none does not exist
    root@thedirkuscomp:/media# mount -o bind /dev/shm $D/dev/shm
    root@thedirkuscomp:/media# mount -o proc none $D/proc
    mount: special device none does not exist
    root@thedirkuscomp:/media# chroot $D
    root@thedirkuscomp:/# su thedirkus
    keyctl_search: Required key not available
    Perhaps try the interactive 'ecryptfs-mount-private'
    To run a command as administrator (user "root"), use "sudo <command>".
    See "man sudo_root" for details.
    Darn... really thought having the passphrase would work!

  9. #9
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Cannot decrypt access-your-private-data.desktop

    You are almost there ...

    Just run ecryptfs-mount-private and enter your log in password.

    See : http://***************/Tutorials/Ecryptfs#Live
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  10. #10
    Join Date
    Jul 2011
    Beans
    7

    Re: Cannot decrypt access-your-private-data.desktop

    I found that I was in fact in the correct home directory where the files were stored, but I am still not able to actually decrypt them:

    Code:
    thedirkus@thedirkuscomp:~$ ls
    Access-Your-Private-Data.desktop  README.txt
    thedirkus@thedirkuscomp:~$ ecryptfs-mount-private
    Enter your login passphrase:
    Inserted auth tok with sig [f89ab646d70098f5] into the user session keyring
    Cannot examine encrypted directory
    thedirkus@thedirkuscomp:~$ ls
    Access-Your-Private-Data.desktop  README.txt

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •