Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

  1. #1
    Join Date
    Jul 2011
    Beans
    5

    Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    I'm absolutely loving Ubuntu 11.04, you can read about my initial reactions to it in this thread on the unRAID forums. I'm running Ubuntu on an Acer Aspire Timeline 4810TZ laptop which boots from an SSD. I've checked out the Acer support page for my laptop, but of course there are no Linux drivers available, only Windows drivers.

    I have three small problems. First of all, I would like to completely disable workspace switcher, or at least change its behavior. I simply don't need it - I'm so used to working on a single workspace that I find workspace switcher to be more of an annoyance than anything else. However, I don't want to lose all of the other aspects of Unity that I've grown to love.

    If it is not possible for workspace switcher to be disabled, then is there any way to force all applications to automatically open in the first workspace? Specifically, LibreOffice Writer always opens in workspace 2 (top right). I never told it to do this, it just started doing it on its own one day. How do I fix this?

    I've noticed two driver-related problems with my system. First, my built-in microphone does not work (tested using Skype, gchat video, and Sound Recorder). As there's no Linux driver supplied by Acer, is there any way to get it working?

    Second, I am unable to adjust my screen brightness. My keyboard shortcuts (Fn + Arrow keys) do make the brightness gauge appear, but adjusting them does nothing to actually adjust the screen brightness, despite the gauge responding appropriately. Again, with no manufacturer-provided Linux drivers, do I have any recourse?

  2. #2
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,546
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    Quote Originally Posted by Rajahal View Post
    I have three small problems. First of all, I would like to completely disable workspace switcher, or at least change its behavior. I simply don't need it - I'm so used to working on a single workspace that I find workspace switcher to be more of an annoyance than anything else. However, I don't want to lose all of the other aspects of Unity that I've grown to love.
    Add the workspace switcher applet to your panel. Set the number of workspaces to 1.
    None but ourselves can free our minds

  3. #3
    Join Date
    Jul 2011
    Beans
    5

    Re: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    Quote Originally Posted by CatKiller View Post
    Add the workspace switcher applet to your panel. Set the number of workspaces to 1.
    Thank you for your reply. Unfortunately, I'm new enough to this that I don't know how to follow your instructions. The workspace switcher icon is already in my dock/taskbar (is that what you mean by the panel?). I've tried right clicking it and finding other means of change its settings, but haven't been successful. How do I change the number of workspaces?

  4. #4
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,546
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    Quote Originally Posted by Rajahal View Post
    How do I change the number of workspaces?
    The Panel is the bar along the top. I can't remember exactly how it looks because I only used the default Unity setup for about five minutes. Right-click on the Workspace Switcher applet and select Preferences. Change both Columns and Rows to 1.
    None but ourselves can free our minds

  5. #5
    Join Date
    Jul 2011
    Beans
    5

    Re: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    Thank you again. Workspace Switcher has no icon in the panel, only the launch icon in the dock (on the left side of the screen). I've looked through the system settings and can't figure out a way to alter any of Workspace Switcher's settings.

  6. #6
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,546
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    Quote Originally Posted by Rajahal View Post
    Thank you again. Workspace Switcher has no icon in the panel,
    Then add it

    Right-click on a blank part of the panel, select Add to Panel... and select Workspace Switcher. You can always remove it once you've changed the number of workspaces.
    None but ourselves can free our minds

  7. #7
    Join Date
    Jul 2011
    Beans
    5

    Re: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    Right-clicking the panel does nothing

    I've seen screenshots of the workspace switcher applet in the panel on older versions of Ubuntu, so I know what it is supposed to look like. I'm using the same version you are (11.04), but with all unity settings at default. Maybe I need to temporarily disable unity?

  8. #8
    Join Date
    May 2011
    Beans
    32

    Re: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    Try opening a terminal and enter this:

    Code:
    gconftool-2 --type=int --set /apps/metacity/general/num_workspaces 1
    I found it here: http://www.linuxnov.com/how-to-chang...10-10-netbook/ It's for 10.10 Netbook edition, but that used Unity as well, so it should still apply.

  9. #9
    Join Date
    Jul 2011
    Beans
    5

    Re: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    Quote Originally Posted by TerribleLIar View Post
    Try opening a terminal and enter this:

    Code:
    gconftool-2 --type=int --set /apps/metacity/general/num_workspaces 1
    I found it here: http://www.linuxnov.com/how-to-chang...10-10-netbook/ It's for 10.10 Netbook edition, but that used Unity as well, so it should still apply.
    Thank you! I think it worked? LibreOffice writer is opening in the first workspace now, so that's definitely an improvement. I can still access the other three workspaces from the icon, but I assume I can just delete the icon and be done with it. Thanks again!

  10. #10
    Join Date
    Mar 2012
    Beans
    1

    Re: Can I disable workspace switcher? Also, trouble with mic and screen brightness.

    Quote Originally Posted by Rajahal View Post
    I've noticed two driver-related problems with my system. First, my built-in microphone does not work (tested using Skype, gchat video, and Sound Recorder). As there's no Linux driver supplied by Acer, is there any way to get it working?
    Has anyone found a solution to this?

    Also the touchpad on/off button isn't working properly - the button seems to work (toggle, LED works and it turns off) but then when I try to turn the touchpad back on the mouse is frozen on the screen.

    Need microphone functionality or else this needs to go back to a simple W7x86 install.

    Thx.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •