Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Grub 1.99 problem

  1. #1
    Join Date
    Jul 2011
    Beans
    7

    Question Grub 1.99 problem

    Hello, I have grub 1.99 as it says when I switch on the computer and i wanted to set my windows os as default. However, when I ran menu.lst as it was said in many forums, i coudlnt edit anything, because there was nothing written in there. I have 64-bit computer, but 32bit ubuntu. Could that be a problem?

    Thanks forahead

  2. #2
    Join Date
    Sep 2009
    Location
    Hampshire, UK
    Beans
    375
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Grub 1.99 problem

    Install grub customiser.
    use these commands one at a time in a terminal:
    Code:
    sudo add-apt-repository ppa:danielrichter2007/grub-customizer 
    sudo apt-get update 
    sudo apt-get install grub-customizer
    you will get a gui in the applications/system tools menu to manage grub entries.


    //edit:customiser launchpad page
    Last edited by Matt__; July 19th, 2011 at 10:27 AM.
    Toshiba AMD64 2Ghz, 4Gb RAM: dual Natty/win7. Dell Mini10v: 10.04. SamsungN140:win7/11.04. NB200:10.10.
    ++ desktops P4 3Ghz ++ servers
    Full Circle Magazine | Ubuntu Pocket Guide | HantsLUG

  3. #3
    Join Date
    Aug 2007
    Location
    a puddle in Manchester
    Beans
    9,208
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grub 1.99 problem

    Grub 1.99 is grub2, which does not use the menu.lst any more.
    What method did you use to change the default OS to Windows?
    The old and trusted way is to edit the line
    Code:
    GRUB_DEFAULT=0
    in the file /etc/default/grub. The "0" refers to the first entry in the grub menu, which is normally the latest installed kernel for your Ubuntu installation.
    If Windows is the second entry in the grub menu you would change the "0" in that line to a "1", if Windows is the 4th entry in the grub menu you would change the "0" to a "3", etc, etc. You then save the file, then quit the file.
    Then you need to run
    Code:
    sudo update-grub
    MacBook Pro 10,1 retina

  4. #4
    Join Date
    Jul 2011
    Beans
    7

    Re: Grub 1.99 problem

    Well, I got to the grub file, and when I tried to edit it anyhow, I could not, because it is read-only file. I wanted to chnage these permissions, but I couldnt because it says that I am not an owner to change it. Its funny because, there is only one account on my ubuntu, and its freshly installed. Any tips?

  5. #5
    Join Date
    Mar 2008
    Location
    /home/evan
    Beans
    532
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Grub 1.99 problem

    To get permission to open a file that is owned by root, you should use sudo. So enter this command into the terminal and a password dialog will come up. Once you enter your password, the file will appear in gedit.

    Code:
    gksudo gedit /etc/default/grub
    FX-4100, GA-970A-D3, CM Hyper 212+, 8GB G.Skill Ripjaws 1333, Kingston HyperX 3K 90GB SSD, 1TB Seagate 7200.12, nVidia GTX 480
    Windows 7 Pro (Ubuntu 12.04 VM), Ubuntu Server 12.04, Ubuntu User #31355
    Dropbox!

  6. #6
    Join Date
    Oct 2009
    Location
    apt-get
    Beans
    4,274
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Grub 1.99 problem

    Quote Originally Posted by haluska538 View Post
    Hello, I have grub 1.99 as it says when I switch on the computer and i wanted to set my windows os as default. However, when I ran menu.lst as it was said in many forums, i coudlnt edit anything, because there was nothing written in there. I have 64-bit computer, but 32bit ubuntu. Could that be a problem?

    Thanks forahead
    https://help.ubuntu.com/community/StartUpManager
    This is the easiest way!


    GRUB2 is NOT using menu.lst anymore!

    https://help.ubuntu.com/community/Grub2

  7. #7
    Join Date
    Jul 2011
    Beans
    7

    Re: Grub 1.99 problem

    Thank you very much, everyone

  8. #8
    Join Date
    Oct 2009
    Location
    apt-get
    Beans
    4,274
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Grub 1.99 problem

    Quote Originally Posted by haluska538 View Post
    Thank you very much, everyone
    You most welcome

    Please let us know if you need anything else!

    Good luck may the Linux be with you

  9. #9
    Join Date
    Aug 2007
    Location
    a puddle in Manchester
    Beans
    9,208
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grub 1.99 problem

    Happy days
    MacBook Pro 10,1 retina

  10. #10
    Join Date
    Jul 2011
    Beans
    7

    Re: Grub 1.99 problem

    Just let you know: The program startup manager probably doesnt work properly, because thought I set Windows as default it made ubuntu as default - first highlighted option in grub anyway. So I had to set it through the text document grub as a default... And two additional questions:
    1.How was I supposed to know that I have grub v.2 when it says 1.99?
    2.What does (loader) means? It is written after Windows 7 in grub booting menu.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •