Results 1 to 2 of 2

Thread: Toshiba C650D - Laptop From Hell

  1. #1
    Join Date
    Jun 2006
    Ubuntu 11.10 Oneiric Ocelot

    Exclamation Toshiba C650D - Laptop From Hell

    I spent most of the day trying to get Ubuntu Natty (and several other Linux distros) to run properly a new Toshiba Satellite C650D laptop. The installations would go fine, but after using the new linux install it would inevitably freeze up so bad that even REISUB could not force the system to reboot. I even tried 'GRUB_CMDLINE_LINUX="acpi=ht"' and "acpi=copy_dsdt" fixes with no success.

    Moral of the story, steer clear of this model if you want to run Linux on it.
    Last edited by jeeves; July 12th, 2011 at 08:18 AM.

  2. #2
    Join Date
    Jul 2011

    Re: Toshiba C650D - Laptop From Hell

    hey there, I have spent the last day and a half having some fun with this laptop. I think I've got it working with Natty (after trying half a dozen kernel versions and wireless drivers).

    I installed it by booting the live CD (on a USB) with the "acpi=copy_dsdt" switch (otherwise it was flaky), and doing the normal install (took 2 or 3 tries).

    after installing it would freezing randomly after about 1/2 an hour or so, which lead to the fun with kernel versions. from what I see online, the problem is the Atheros wireless drivers (surprise!).

    I tried a bunch of stuff, but in the end what seems to have work (current uptime is at 6:00 - much longer than all previous attempts) was upgrading to the 2.6.38-11 kernel. I had to add the pre-proposed source with:
    sudo add-apt-repository ppa:kernel-ppa/pre-proposed
    and then install the updated headers and image. you can see the exact package names (after adding the above):
    apt-get update
    apt-cache showpkg linux-headers
    apt-cache showpkg linux-image
    and installing (with 'sudo apt-get install NAME') the packages with inclued '2.6.38-11' in the name.

    there's a bunch of suggestions out there to upgrade to the 2.6.39 kernel, but it's been removed from the sources as far as I can see. i'll upgrade to .39 when it's released properly.

    hope you get a chance to try it out, and that it works for you!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts