Results 1 to 7 of 7

Thread: 11.04 "Device not ready"

Threaded View

  1. #1
    Join Date
    Jul 2011

    [SOLVED] 11.04 "Device not ready"

    Hey guys,

    I have a Lenovo ThinkPad Edge E520 (1143CTO) and I'm having problems getting my wireless NIC to work, as far as I can tell the drivers and firmware are all installed and the device is working.

    I have searched around and have done all the fixes I can find online, this is my first 'real' experience with Linux, so patience is appreciated, as is any help I can get. I also had this problem with Linux Mint 11.

    It appears that the model of my card is BCM43224, but it doesn't show up anywhere in the with any commands?

    sudo lshw

    *-network DISABLED
    description: Wireless interface
    product: Broadcom Corporation
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:09:00.0
    logical name: eth2
    version: 01
    serial: ac:81:12:3e:1d:ca
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=wl0 driverversion= latency=0 multicast=yes wireless=IEEE 802.11abgn
    resources: irq:19 memory:e1d00000-e1d03fff
    sudo lspci

    09:00.0 Network controller: Broadcom Corporation Device 0576 (rev 01)
    I have tried the Broadcom STA drivers and have also tried the command:
    sudo apt-get install b43-fwcutter firmware-b43-installer
    sudo rfkill list

    0: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    Yet, sudo lshw still shows it as disabled!

    Nothing I can find just seems to work. Any help at all is appreciated and I will try any suggestions as-long as you can provide me with the command

    I have tried EVERY fix I can find!

    P.S. This is the fourth forum I am posting it on as I am in desperate need of help.

    Last edited by Bocaj1994; July 12th, 2011 at 03:49 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts