Hi. I have the following problem:

I have a new notebook, Toshiba Satelite C660D-10L and on it Ubuntu 11.4. Yesterday morning I installed a driver for HUAWEI Mobile Broadband E173. Internet worked ok, but I noticed in the evening that if I plugged out the cable, I got a notice that battery is at 0.04% charge and that I need to plug in the cable soon or else... In the same time when I clicked on the little battery icon, I got a message that the battery is fully charged. However, laptop was working.

But then when I tried to shut it down, it did not shut down fully and the screen was frozen for quite some time with lots of things written on it (that I did not understand). Then I switched it off by pressing the power button and holding it for a few seconds. And when I tried to switch it on today, I got the following message:

PXE-E61: Media test failure, check cable on Toshiba Satelite

and then:

PXE-M0F: Exiting PXE ROM
Reboot and select proper boot device or insert Boot Media in selected Boot device and press a key

From that point I could not go any further. BIOS setup is ok and I tried to boot it from HDD and from CD. In both cases I got the same message.

I would appreciate if someone can help me with this.

Warm regards,
Sasha Kosec