Results 1 to 4 of 4

Thread: setting up icecast2 permission problem

  1. #1
    Join Date
    Jan 2011
    Beans
    47

    setting up icecast2 permission problem

    I'm trying to setup icecast2 so that I can stream music from MPD to other computers in my local network. I have MPD all setup, but I'm having trouble getting icecast to work. I believe its a permission problem.

    I've been trying to follow this tutorial but I have been unable to get it to work. I've looked at numerous other tutorials and haven't been able to find different that fixed my problems.

    https://wiki.archlinux.org/index.php...g_With_Icecast

    when I run:

    Code:
    icecast2 -b -c /etc/icecast2/icecast.xml
    the result is:


    Code:
    Starting icecast2
    Detaching from the console
    I/O error : Permission denied
    I/O error : Permission denied
    I/O warning : failed to load external entity "/etc/icecast2/icecast.xml"
    FATAL: error parsing config file (/etc/icecast2/icecast.xml)
    XML config parsing error
    the icecast2 user has permissions for the following icecast.xml file. In desperation I have also added my regular user to the icecast group. I've also tried starting the server as root ( as a tutorial suggested) but it exits saying running it as root is a bad idea.


    /etc/icecast/icecast.xml:

    Code:
    <icecast>
        <limits>
            <clients>100</clients>
            <sources>2</sources>
            <threadpool>5</threadpool>
            <queue-size>524288</queue-size>
            <client-timeout>30</client-timeout>
            <header-timeout>15</header-timeout>
            <source-timeout>10</source-timeout>
            <!-- If enabled, this will provide a burst of data when a client 
                 first connects, thereby significantly reducing the startup 
                 time for listeners that do substantial buffering. However,
                 it also significantly increases latency between the source
                 client and listening client.  For low-latency setups, you
                 might want to disable this. -->
            <burst-on-connect>1</burst-on-connect>
            <!-- same as burst-on-connect, but this allows for being more
                 specific on how much to burst. Most people won't need to
                 change from the default 64k. Applies to all mountpoints  -->
            <burst-size>65535</burst-size>
        </limits>
    
        <authentication>
            <!-- Sources log in with username 'source' -->
            <source-password>hackme</source-password>
            <!-- Relays log in username 'relay' -->
            <relay-password>hackme</relay-password>
    
            <!-- Admin logs in with the username given below -->
            <admin-user>admin</admin-user>
            <admin-password>hackme</admin-password>
        </authentication>
    
        <!-- set the mountpoint for a shoutcast source to use, the default if not
             specified is /stream but you can change it here if an alternative is
             wanted or an extension is required
        <shoutcast-mount>/live.nsv</shoutcast-mount>
        -->
    
        <!-- Uncomment this if you want directory listings -->
        <!--
        <directory>
            <yp-url-timeout>15</yp-url-timeout>
            <yp-url>http://dir.xiph.org/cgi-bin/yp-cgi</yp-url>
        </directory>
         -->
    
        <!-- This is the hostname other people will use to connect to your server.
        It affects mainly the urls generated by Icecast for playlists and yp
        listings. -->
        <hostname>localhost</hostname>
    
        <!-- You may have multiple <listener> elements -->
        <listen-socket>
            <port>8000</port>
            <!-- <bind-address>127.0.0.1</bind-address> -->
            <!-- <shoutcast-mount>/stream</shoutcast-mount> -->
        </listen-socket>
        <!--
        <listen-socket>
            <port>8001</port>
        </listen-socket>
        -->
    
        <!--<master-server>127.0.0.1</master-server>-->
        <!--<master-server-port>8001</master-server-port>-->
        <!--<master-update-interval>120</master-update-interval>-->
        <!--<master-password>hackme</master-password>-->
    
        <!-- setting this makes all relays on-demand unless overridden, this is
             useful for master relays which do not have <relay> definitions here.
             The default is 0 -->
        <!--<relays-on-demand>1</relays-on-demand>-->
    
        <!--
        <relay>
            <server>127.0.0.1</server>
            <port>8001</port>
            <mount>/example.ogg</mount>
            <local-mount>/different.ogg</local-mount>
            <on-demand>0</on-demand>
    
            <relay-shoutcast-metadata>0</relay-shoutcast-metadata>
        </relay>
        -->
    
        <!-- Only define a <mount> section if you want to use advanced options,
             like alternative usernames or passwords
        <mount>
            <mount-name>/example-complex.ogg</mount-name>
    
            <username>othersource</username>
            <password>hackme</password>
    
            <max-listeners>1</max-listeners>
            <dump-file>/tmp/dump-example1.ogg</dump-file>
            <burst-size>65536</burst-size>
            <fallback-mount>/example2.ogg</fallback-mount>
            <fallback-override>1</fallback-override>
            <fallback-when-full>1</fallback-when-full>
            <intro>/example_intro.ogg</intro>
            <hidden>1</hidden>
            <no-yp>1</no-yp>
            <authentication type="htpasswd">
                    <option name="filename" value="myauth"/>
                    <option name="allow_duplicate_users" value="0"/>
            </authentication>
            <on-connect>/home/icecast/bin/stream-start</on-connect>
            <on-disconnect>/home/icecast/bin/stream-stop</on-disconnect>
        </mount>
    
        <mount>
            <mount-name>/auth_example.ogg</mount-name>
            <authentication type="url">
                <option name="mount_add"       value="http://myauthserver.net/notify_mount.php"/>
                <option name="mount_remove"    value="http://myauthserver.net/notify_mount.php"/>
                <option name="listener_add"    value="http://myauthserver.net/notify_listener.php"/>
                <option name="listener_remove" value="http://myauthserver.net/notify_listener.php"/>
            </authentication>
        </mount>
    
        -->
    
        <fileserve>1</fileserve>
    
        <paths>
         <basedir>/usr/share/icecast</basedir>
         <logdir>/log</logdir>
         <webroot>/web</webroot>
         <adminroot>/admin</adminroot>
     </paths>
    
        <logging>
            <accesslog>access.log</accesslog>
            <errorlog>error.log</errorlog>
            <!-- <playlistlog>playlist.log</playlistlog> -->
              <loglevel>3</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->
              <logsize>10000</logsize> <!-- Max size of a logfile -->
            <!-- If logarchive is enabled (1), then when logsize is reached
                 the logfile will be moved to [error|access|playlist].log.DATESTAMP,
                 otherwise it will be moved to [error|access|playlist].log.old.
                 Default is non-archive mode (i.e. overwrite)
            -->
            <!-- <logarchive>1</logarchive> -->
        </logging>
    
        <security>
            <chroot>0</chroot>
            <!--
            <changeowner>
                <user>nobody</user>
                <group>nogroup</group>
            </changeowner>
            -->
        </security>
    </icecast>

  2. #2
    Join Date
    Jan 2011
    Beans
    47

    Re: setting up icecast2 permission problem

    bump?

  3. #3
    Join Date
    Jul 2011
    Beans
    1

    Re: setting up icecast2 permission problem

    I have the same problem. If find a solution please post it. I'll do the same.

  4. #4
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: setting up icecast2 permission problem

    try sudo before of your command

    or even better:

    sudo /etc/init.d/icecast2 restart

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •