Results 1 to 4 of 4

Thread: setting up icecast2 permission problem

  1. #1
    Join Date
    Jan 2011

    setting up icecast2 permission problem

    I'm trying to setup icecast2 so that I can stream music from MPD to other computers in my local network. I have MPD all setup, but I'm having trouble getting icecast to work. I believe its a permission problem.

    I've been trying to follow this tutorial but I have been unable to get it to work. I've looked at numerous other tutorials and haven't been able to find different that fixed my problems.

    when I run:

    icecast2 -b -c /etc/icecast2/icecast.xml
    the result is:

    Starting icecast2
    Detaching from the console
    I/O error : Permission denied
    I/O error : Permission denied
    I/O warning : failed to load external entity "/etc/icecast2/icecast.xml"
    FATAL: error parsing config file (/etc/icecast2/icecast.xml)
    XML config parsing error
    the icecast2 user has permissions for the following icecast.xml file. In desperation I have also added my regular user to the icecast group. I've also tried starting the server as root ( as a tutorial suggested) but it exits saying running it as root is a bad idea.


            <!-- If enabled, this will provide a burst of data when a client 
                 first connects, thereby significantly reducing the startup 
                 time for listeners that do substantial buffering. However,
                 it also significantly increases latency between the source
                 client and listening client.  For low-latency setups, you
                 might want to disable this. -->
            <!-- same as burst-on-connect, but this allows for being more
                 specific on how much to burst. Most people won't need to
                 change from the default 64k. Applies to all mountpoints  -->
            <!-- Sources log in with username 'source' -->
            <!-- Relays log in username 'relay' -->
            <!-- Admin logs in with the username given below -->
        <!-- set the mountpoint for a shoutcast source to use, the default if not
             specified is /stream but you can change it here if an alternative is
             wanted or an extension is required
        <!-- Uncomment this if you want directory listings -->
        <!-- This is the hostname other people will use to connect to your server.
        It affects mainly the urls generated by Icecast for playlists and yp
        listings. -->
        <!-- You may have multiple <listener> elements -->
            <!-- <bind-address></bind-address> -->
            <!-- <shoutcast-mount>/stream</shoutcast-mount> -->
        <!-- setting this makes all relays on-demand unless overridden, this is
             useful for master relays which do not have <relay> definitions here.
             The default is 0 -->
        <!-- Only define a <mount> section if you want to use advanced options,
             like alternative usernames or passwords
            <authentication type="htpasswd">
                    <option name="filename" value="myauth"/>
                    <option name="allow_duplicate_users" value="0"/>
            <authentication type="url">
                <option name="mount_add"       value=""/>
                <option name="mount_remove"    value=""/>
                <option name="listener_add"    value=""/>
                <option name="listener_remove" value=""/>
            <!-- <playlistlog>playlist.log</playlistlog> -->
              <loglevel>3</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->
              <logsize>10000</logsize> <!-- Max size of a logfile -->
            <!-- If logarchive is enabled (1), then when logsize is reached
                 the logfile will be moved to [error|access|playlist].log.DATESTAMP,
                 otherwise it will be moved to [error|access|playlist].log.old.
                 Default is non-archive mode (i.e. overwrite)
            <!-- <logarchive>1</logarchive> -->

  2. #2
    Join Date
    Jan 2011

    Re: setting up icecast2 permission problem


  3. #3
    Join Date
    Jul 2011

    Re: setting up icecast2 permission problem

    I have the same problem. If find a solution please post it. I'll do the same.

  4. #4
    Join Date
    Dec 2006

    Re: setting up icecast2 permission problem

    try sudo before of your command

    or even better:

    sudo /etc/init.d/icecast2 restart

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts