Results 1 to 10 of 102

Thread: How to install power pc Lubuntu 11.04 with Firefox 5

Threaded View

  1. #1
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011

    How to install with the PowerPC mini iso and answers to other common questions

    Most of the information in this post has now been moved to the and the pages. Please refer to them for the latest information. The only section that has not been moved across is the Install Lubuntu section.

    This post has grown somewhat from it's original idea - a simple set of notes to install Lubuntu on PowerPC - to something that more likely resembles an updated PowerPC FAQ! However, it has never been by intention to replace the FAQ with this post, and in fact, I've tried not to duplicate information that is documented well elsewhere. So please do still check out the FAQ and release note links at the bottom of the post!

    A lot of the information really belongs in the PowerPC FAQ so that everybody has the opportunity to edit it and keep it up to date. If somebody would like to start updating the FAQ by cutting and pasting sections from here then please feel free to do so! I would be very pleased if you do!

    The post now also includes instructions to install Ubuntu, Xubuntu, Kubuntu, etc from the mini cd. The mini cd is a great way to install if there is not a live cd version available or if you can't get it to run correctly. There are various things you can try with the 11.10 live cd, although the severity of the symptoms change on different machines. I can highly recommend Xubuntu. It is not as light as Lubuntu, but it does have round window corners, transparency and shadows whilst still being fast!

    You can of course also install Ubuntu 11.04 or 11.10 by upgrading from a previous version of Ubuntu. It's pretty straightforward through the Update Manager, but if you require further info then there are instructions in the release notes. The 'Workarounds' section below is there if you run into any PowerPC specific problems. I should add you don't have to upgrade if you are happy with your current release and are still receiving updates for it. The current long term support (LTS) release is 10.04 and the desktop edition will continue to receive updates until April 2013. The server edition of 8.04 (LTS) will also be supported until April 2013.

    The post is not intended as a beginners guide to linux, although I think it would enable a new user to install ubuntu successfully. The post may seem long and scary, but maybe it is less so when you are actually doing it? Just take one step at a time..... I'm pretty confident most of the information you need should be here or on one of the links, so make sure you check them out first before wasting your time and effort on needless google searches. Please do tell me if you think some instructions are unclear.

    PowerPC Ubuntu is not an island and I hope that people using other distributions can also make use of some of the information here. I have learnt a lot by reading the great documentation that has been generously made openly and freely available by other distributions.

    Please feel free to add your own comments/suggestions/fixes/problems.

    1. The Base Installation
    1.1 Install the CLI
    1.2 G4 iBook and AlBook
    1.3 Other Computers

    2. Install the GUI
    2.1 Install Lubuntu
    2.2 Install Ubuntu, Xubuntu, Kubuntu, etc

    3. Workarounds
    3.1 General Workarounds
    3.2 Wifi
    3.3 CPU Frequency Scaling
    3.4 Multimedia
    3.5 Flash
    3.6 Java
    3.7 Screen Resolution/Black Screen/No GUI Problems
    _3.7a General notes on display issues
    _3.7b Yaboot parameters for screen problems
    _3.7c Configuring an xorg.conf file
    _3.7d Load kernel module
    _3.7e Test your 3D graphics acceleration and beyond
    3.8 Radeon Tweaks
    3.9 Yaboot Config/BusyBox Error
    3.10 Sound Problems
    3.11 Trackpad and Right-click
    3.12 Power Preferences/Suspend
    3.13 Software Centre
    3.14 Booting from USB
    3.15 Security

    4. How To Help PowerPC Ubuntu

    5. Useful Links

    1. The Base Installation
    1.1 Install the CLI
    Please read all of section 1 before trying to install.

    As you maybe aware there is currently no ppc Lubuntu cd, but one is in testing for 12.04 .There are also currently no ppc live cds for Ubuntu 11.04 or 11.10 (although copies were available when in testing). One solution is to install a simple command line only system and build up. You can do this via the mini iso (here, where you will find iso's for 11.04 and 11.10) or using the alternate installer (follow the links here

    You can burn these to a cd (use the lowest possible burn speed) or copy them to an unused usb flash drive and I have given instructions in section 3.14 'Booting from USB'. Instructions for net or hard disk booting, as well as, other general information about installing on PowerPC can be found here (though it is a little dated). If you are multibooting then also see, as it has some additional information on this.

    At some point (either when downloading the iso or running the cd) you'll be given a choice between the 32 bit or the 64 bit version. G3s and G4s use the 32 bit version, G5s use the 64 bit.

    You'll need an ethernet connection to install from the mini iso.

    Run the 'cd' and type "cli" or "cli64" when prompted. Most of the install questions are fairly easy and straighforward. If you don't know the answer to a question, then you can usually go with the default option. Use Tab and the arrow keys to move between options and Enter to select the option you want. At the partitioning stage, if you want to use the whole disk for Ubuntu (and erase everything currently on the drive) choose the "Guided - use entire disk" option. The only difference I have noticed between the mini and alternate installs is that the mini gives you an automatic update screen. We want the 'No automatic updates' option and I hope this is the default on the alternate install. It's all described in a little bit more detail here . Choose "cli-expert" if you want a greater level of control or can't get the "cli" option to work.

    If you are having trouble with mirror repositories then you can use the manual option for setting the mirror and change it to "" with directory "/ubuntu-ports/". If you have a classic Airport wifi card then during the install you may be told you are missing the non-free firmware file "agere_sta_fw.bin". This can be ignored at this stage. The installer does appear to hang at one point with a black screen, please give it a couple of minutes as the download should kick in. Also, the screensaver (black screen) does come on during the installation just to confuse you more!

    Following a cli installation and a reboot, if you just get a blank/black/white screen and no login prompt then see section 3.7 'Screen Resolution/Black Screen/No GUI Problems'.

    I have yet to try the 11.10 installer, but I gather there are problems with it for some computers. This is caused by developments to the ata controller drivers in the kernel: i.e. migrating to the driver pata_macio. There are numerous messages on the Debian powerpc mailing list relating to this. You may get some sort of message telling you that your hard drive has not been recognised. The appropriate module for you maybe missing from the installer, see .

    A confirmed workaround to install 11.10 is to initially install a 11.04 cli and upgrade to 11.10 cli. After installing 11.04 cli, login and then use the command "sudo do-release-upgrade -d" to upgrade (omit the -d if you are going from 8.04 LTS to 10.04 LTS). Reboot to make sure it is working correctly with the command "sudo reboot". See section 3.9 'Yaboot Config/Busybox Error' if you have a problem on reboot following an upgrade. When you have the 11.10 command line working you can then install a GUI.

    Note, it is possible to install different desktop environments alongside each other to try them out (and this would be an alternative to starting from a cli install). This is beyond the scope of this post (and you'll want to do some more research for lubuntu), but some instructions which you may find useful are here .

    1.2 G4 iBook and AlBook
    If you are using a G4 iBook or AlBook then you need to be warned that the fan may not work during the above bit of the installation (it is the same when installing debian). This shouldn't be a problem because it is fairly quick (well around 40 mins), but you could run into overheating issues if you decide to do some CPU intensive thing like shrinking a large partition that's going to take hours! So don't do it! Use a live CD or an existing linux/mac install to do this from. The command that should make sure you have a working iBook and AlBook G4 fan in linux is "sudo modprobe therm_adt746x". This is automated in the file /etc/modules when you install linux. Maverick and natty should add "therm_adt746x" to the list for you, but lucid won't. You can check what you have with the command "sudo nano /etc/modules" (when you are logged in). You'll need to reboot before any changes take effect ("sudo reboot"). It's obviously a good idea to keep a good level of circulation around the *Book, and if you are cautious (sensible?) then during the base installation only you could maybe setup an external fan to blow on the *Book or maybe sit it on something cool (e.g. the freezer things that keep your picnic cool!)?

    1.3 Other Computers
    I've only installed *ubuntu on my iBook and I know very little about other models. Please monitor your hardware (such as fans) to make sure it is working correctly.

    If you have a 'Blue&White' G3 or a 'Yikes!' G4 machine and during the installation of 10.04 or 10.10 you get a message asking you to select a disk drive driver then you may be suffering from this bug . You may have to start with an install of 8.04 and upgrade to 10.04 or 10.10. The versions 11.04 and 11.10 have the module pata_cmd64x. See section 3.9 'Yaboot Config/Busybox Error' if this causes you problems.

    2. Install the GUI
    2.1 Install Lubuntu
    So now we have the base system installed we can start turning it into lubuntu! Login and we can continue...

    Lucid (10.04) users can pretty much follow the lubuntu documentation . However, I would miss out the line "sudo add-apt-repository ppa:lubuntu-desktop/ppa" at this stage because it won't work with it in. This is because the updated package for the file manager (pcmanfm) is missing for ppc. You could compile this yourself (there are instructions in the 'Workarounds' section below) or possibly download it from elsewhere to get around this. Also, you will still have the apt-xapian-index package which you may find you want to remove (see below). You'll probably also want to install a web browser, as well as, some of the recommended packages for abiword (such as the spell checker) .

    Oneiric (11.10) users should also be able to follow the lubuntu documentation or (hopefully) use the tasksel command (see section 2.2 below) to install.

    Maverick (10.10) and Natty (11.04) users read on....

    The following is based on the lubuntu documentation, but it is a little more complicated because of the lubuntu-desktop dependency on the chromium browser. Lubuntu uses chromium as its browser, but there is no ppc chromium/chrome. In lucid and oneiric this dependency has been removed for PowerPC, but in maverick and natty it remains. lubuntu-desktop is just a meta package meaning it is just a collection of packages ( My understanding is that installing the individual packages will have the same effect as installing the one big umbrella package. So this is what we have to do minus chromium (and a few others we don't need) and is what the lubuntu developers recommend for PowerPC . The commands are long so I've written it as a script which you can save and run.

    The first thing the script does is actually remove a package! This is the apt-xapian-index package which used to cause me a lot of grief with its update-apt-xapi process (surely I am not the only one?). Lubuntu does not have this by default. See the 'Quick search Synaptic' section of .

    In the script I've done a rough split between the application packages and the other desktop environment packages. This is so that you can easily remove or replace the applications installed to your own preferences. That's not to say you can't remove packages from the other list either. For example, if you haven't got bluetooth then you can do without gnome-bluetooth. If you are unsure about all this, then just leave it as it is.

    Cut and paste the script into a text editor and save it somewhere that you will be able to access from your new lubuntu system. If you copy it to the home directory of your account and it's called "lubuntu-installer" then to make it executable type "chmod +x lubuntu-installer". Run the installer with "sudo ./lubuntu-installer". When it finishes installing type "sudo reboot". You're installed! (You can also type out the commands in the script instead of saving it and running it. The lines starting with a # can be ignored. Linux is case sensitive. Press the up key to repeat the last command typed (usefull if you get an error from a mistype))

    EDIT: If the script doesn't run (shows no output) then this is probably because some non-unix characters have crept in through the cut and paste process. You may need to use the command dos2unix to get rid of the 'MS Windows/dos' characters. Type "sudo apt-get install dos2unix" then e.g. "dos2unix lubuntu-installer".

    EDIT2: I've added a couple of lines to install the package libx264-98 which is not in natty (we get it from maverick). This allows gecko-mediaplayer and gnome-mplayer to be installed.

    # A script for installing Lubuntu Natty on PowerPC
    # ------------------------------------------------
    sudo apt-get update
    # This package shouldn't be in the default lubuntu
    sudo apt-get purge apt-xapian-index
    # Not sure if we need this or not, but it's in the lubuntu minimal documentation instructions
    sudo apt-get install python-software-properties
    # The lubuntu desktop environment packages
    sudo apt-get install --no-install-recommends alsa-base alsa-utils anacron apport-gtk cron cups-driver-gutenprint desktop-file-utils file-roller gdebi gksu gnome-bluetooth gnome-disk-utility gnome-keyring gnome-power-manager gnome-system-tools gnome-time-admin gvfs-backends gvfs-fuse hardinfo jockey-gtk language-selector-gnome logrotate lubuntu-core lxappearance lxappearance-obconf lxdm lxinput lxkeymap lxlauncher lxpanel-indicator-applet-plugin lxrandr lxsession-edit lxshortcut lxtask lxterminal lzma mobile-broadband-provider-info modemmanager network-manager-gnome ntp obconf pcmciautils pm-utils policykit-desktop-privileges ppp scrot software-properties-gtk synaptic system-config-printer-gnome transmission ttf-indic-fonts-core ttf-kacst-one ttf-khmeros-core ttf-lao ttf-liberation ttf-punjabi-fonts ttf-takao-pgothic ttf-thai-tlwg ttf-ubuntu-font-family ttf-unfonts-core ttf-wqy-microhei ubuntu-extras-keyring unzip update-notifier usb-modeswitch wireless-tools wpasupplicant wvdial x11-utils xdg-user-dirs xscreensaver zip
    # Get and install a package that is missing from Natty, but is in Maverick so that we can install gnome-mplayer 
    wget -P/tmp
    sudo dpkg -i /tmp/libx264-98_0.98.1653+git88b90d9-3ubuntu2_powerpc.deb
    # The application packages
    sudo apt-get install abiword ace-of-penguins audacious audacious-plugins evince firefox galculator gecko-mediaplayer gnome-mplayer gnumeric gnumeric-doc gpicview gucharmap guvcview leafpad mtpaint osmo pidgin pidgin-libnotify simple-scan sylpheed sylpheed-doc sylpheed-i18n sylpheed-plugins xchat xfburn xpad
    sudo apt-get dist-upgrade
    sudo apt-get autoclean
    sudo apt-get clean
    sudo apt-get autoremove
    2.2 Install Ubuntu, Xubuntu, Kubuntu, etc
    After installing the base installation and logging in enter the following simple commands:

    sudo apt-get update
    sudo tasksel
    Select the version of ubuntu you want from the list that appears.

    If for some reason the tasksel command doesn't work (you just get a black screen instead of the list), then first check you are not suffering from the udisks bug described at the top of the 'General Workarounds' section below. An alternative way to install the GUI is to install the appropriate 'meta' package. For xubuntu you would type "sudo apt-get install xubuntu-desktop" followed by the command "sudo apt-get dist-upgrade". If you are having problems with ubuntu-desktop in 11.10 then please see .

    When you have rebooted (the command is "sudo reboot") you can tidy up the installation by entering the following commands in a terminal:
    sudo apt-get autoclean
    sudo apt-get clean
    sudo apt-get autoremove
    Following a reboot, if you remain at a cli login or you have any other graphics issues then see section 3.7 'Screen Resolution/Black Screen/No GUI Problems'.

    3. Workarounds
    A lot of the following workarounds require the use of the terminal. See for a guide to this and some common commands. If you are new to linux then typing commands may seem unnatural and scary, but they allow instructions to be written with a greater level of precision and speed. Most of the commands given below can just be cut and pasted into the terminal. Press the Enter/Return key to execute the command.

    If you have installed Ubuntu you will have to replace the word "leafpad" with the word "gedit". If you have installed a version of Xubuntu before 11.10 then you will have to replace "leafpad" with "mousepad". These changes are necessary because different *ubuntus use different graphical text editors. The command line text editor used in this guide is 'nano'. For some help with this see .

    3.1 General Workarounds
    If you find things are inexplicably slow (or your fan is coming on a lot) then check your CPU usage by running the "top" command from the terminal. The command displays system resources and a list of processes currently being managed by the Linux kernel. If you see "0.0%id" (or a very low number) in the Cpu(s) line then your machine has no spare CPU time. If gvfs-gdu-volume and udisks-daemon are at the top of the processes list then you may be suffering from the udev/udisks bug described in this thread . The thread also contains some extra xubuntu related fixes. If the process update-apt-xapi is being the CPU hog then you can remove it. See the Lubuntu install section above.

    If you launch an application which requires root privileges (such as synaptic) and it keeps telling you that the password is incorrect then this is what to do: Open the terminal and type "gksu-properties". Change the authentication mode to 'sudo'. It should now work.

    If Network Manager reports that your ethernet (wired) connection is un-managed, or you don't see the Network Manager applet icon at all, or your boot time is excessively slow then use the first fix on this page .

    If the battery status is not displayed correctly then open up the terminal and type "gksudo leafpad /etc/modules". Add the line “pmu_battery”, save and it should work on reboot.

    To change what the notifications bubble looks like you can open the terminal and type "notification-properties". I suffered from this bug so I replaced notification-daemon with notify-osd (used in standard ubuntu). This should be fixed in oneiric.

    Lubuntu's default screensavers are very CPU intensive so I recommend you change them. I use the gl ant spotlight screensaver to test my xorg.conf settings, but it is very unstable so don't use that everyday if you use your computer for serious work (it almost always freezes the computer when I select the preview button).

    CD drive related fixes can be found here .

    To compile packages . You may also like to read about backporting and apt pinning .

    If you don't have a trackpad, but would like your Caps Lock light back, then remove mouseemu ("sudo apt-get remove mouseemu").

    If you need to adjust the fan limits, then this method may work (I have never tried this however). Make sure you are using the correct module for your computer first. Some modules are detailed here .

    If you want to reduce an oversized live cd . You can also try 'over-burning' if it is only just too big, or write the iso to a DVD. Remember to use the lowest burn speed for writing to cds. You can also 'burn' an iso to a USB stick see section 3.14 below.

    Upon an upgrade if you get a message such as "E: Some index files could not be downloaded, they will be ignored, or old files will be used instead." or a 404 error, then check your sources.list file .

    Resetting a computer's PRAM or PMU can fix a number of symptoms (see and If you can't boot a CD, your battery level is not correct, or you have video issues then resetting the PRAM/PMU may help. You should use this as a last resort and you may loose yaboot temporarily if you dual boot (see

    3.2 Wifi
    If you have an airport extreme card then you need to download the firmware. Natty and Oneiric users should open the terminal and type "sudo apt-get install firmware-b43-installer" (see if you are having trouble with this). You should now see your wireless networks. Maverick and Lucid users should type "sudo apt-get install b43-fwcutter" in the terminal and then go to Preferences > Additional drivers and select the Broadcom b43 driver.

    When you connect to your network you'll be asked to enter a password for the default keyring. I always seem to get in a mess with these, but I think the recommended thing is to enter your account password for this so you don't keep having to enter it. I now make the connection available to all users to get around this. Click on the network applet icon and select 'Edit Connections...'. Go to the Wireless tab and select your network from the list. Click "Edit...". Enter your Ubuntu user account password if prompted. Make sure "Connect automatically" and "Available to all users" are ticked. Click Apply and then Close. If in the future you need to delete the keyring this is how: Open File Manager, click 'View' and select 'Show Hidden'. Double-click on .gnome2 and then keyrings. Delete the appropriate file.

    If you have an airport classic card or airport extreme card and are suffering from bad password errors (or you require more troubleshooting advice) then have a look here . In lubuntu natty I've found you don't need to check the privileges so you can probably skip that part for natty.

    3.3 CPU Frequency Scaling
    CPU scaling reduces the processor speed when the computer is idle or not doing a lot. It saves battery power and reduces heat so you won't have the fan coming on so much. However, the 'ondemand' kernel governor for processor scaling does not work with G3 and G4 processors because a sensible value for the transition latency (the time taken to switch between processor speeds) has not been set in the kernel. To overcome this, I use the powernowd package to perform the same function as the ondemand governor on my G4.

    Unfortunately, powernowd has been removed from natty because somebody deemed it to be redundant. So it is another package that we have to manually download from here . Save the file and use the command "sudo dpkg -i path_to_file" to install the package (where path_to_file will be something like ~/Downloads/powernowd_1.00-1ubuntu5_powerpc.deb). Then all you have to do is disable the ondemand governor being turned on by using the command "sudo update-rc.d ondemand disable". The Power PC Known Issues pages advices you do other stuff, but I have found the extra instructions to be unnecessary. Finally, the file /etc/default/powernowd contains the startup options which you may like to adjust (if you know what you are doing because you don't want to set the polling interval too small). More information about powernowd can be found here .

    Note, processor scaling is not available in linux for all PowerPC processors. Also, you may have to reinstall powernowd after an upgrade as it is likely to be automatically uninstalled.

    3.4 Multimedia
    The script leaves you with a system as if you have installed it from an official CD. However, this is probably not the end of what you want to do because there are packages that cannot be included into the Lubuntu/Ubuntu distribution for legal reasons (copyright, license, patent, etc). It is easy to install these however, this is how:

    Open the terminal and type "sudo apt-get install ubuntu-restricted-extras". This will download a whole load of stuff (around 100MB) including codecs, Mircrosoft fonts, gnash (flash support), and openjdk (java). A license aggreement screen pops up for the MS fonts which you will need to accept (press the TAB key if you are having a hard time selecting the OK option).

    To play encrypted DVDs you need to dowload a file from Medibuntu (Multimedia, Entertainment & Distractions In Ubuntu You can nolonger add medibuntu as a repository on PowerPC, but you can still download the files individually. Click on the link and select open with GDebi to install.

    If you are still having problems with DVDs then check out the "Setting DVD Region Codes" section of . This is what I had to do to get my DVD drive to work. When I ran regionset the 'type' showed up as NONE and I had to set the region to make it show SET.

    More codecs can be downloaded from Medibuntu. The file is pretty old so I'm not sure what it adds that ubuntu-restricted-extras doesn't, but you can install it by clicking and select open with GDebi. Lucid users should follow the advice in this thread .

    I couldn't get gecko-mediaplayer in Lubuntu to work with Firefox 5 so I installed totem instead. Gecko-mediaplayer is a plugin that allows Firefox to play videos and audio using gnome-mplayer. Totem is another mediaplayer with its own firefox plugin (it is the default player on normal Ubuntu). Gnome-mplayer is the better at playing DVDs and usually has lower CPU usage when playing videos, but occasionally totem can do something that gnome-mplayer can't. It's annoying to have two applications doing the same job (it feels like a bodge to my perfectionist mindset), but I can't get around it. Totem can play YouTube videos directly and there are country specific plugins for it that allow you to watch TV shows (you will have to do a search for these and install them).

    To install totem movie player in lubuntu type at a terminal "sudo apt-get --no-install-recommends install totem gstreamer0.10-alsa totem-plugins gnome-codec-install". If you want to replace gecko-mediaplayer with the totem firefox plugin then type "sudo apt-get remove gecko-mediaplayer" followed by "sudo apt-get --no-install-recommends install totem-mozilla".

    The uber minimalist way to watch media is using the command line program mplayer. You can even use this without a GUI! See . To play music the cool people use MPD . MPC is a simple command line client for this, although you can use a web browser or mobile phone too!

    3.5 Flash
    There is no Adobe Flash for PowerPC. There are, however, two open source flash players still under development: gnash and lightspark.

    From the Software Centre/Synaptic/Terminal install "Gnash SWF viewer" and "browser-plugin-gnash" (or "mozilla-plugin-gnash" depending on your ubuntu version). Lightspark (and it's firefox plugin browser-plugin-lightspark) is the latest flash player (see and ). Lightspark uses advanced OpenGL techniques that requires good support from video drivers. It will work best in newer versions of ubuntu (and with KMS on? see section 3.7b). Lightspark also uses pulseaudio as it's default audio backend. Pulseaudio is not installed on a default Lubuntu installation, so if you want sound you will have to install it (or compile a version of lightspark with alsa as the audio backend?). You can install gnash and lightspark alongside each other since lightspark likes to 'fallback' onto gnash to play old swf files, but don't enable both the gnash firefox plugin and the lightspark plugin at the same time.

    You may want install a browser extension that blocks flash content on websites because gnash CPU usage is high even for simple adverts. I hate my laptop fan coming on so I try to run my iBook as cool as possible at all times. Even if you haven't got gnash installed you will probably benefit from faster browsing by using an extension such as Ablock Plus (see ).

    If you want to experiment with gnash in 11.10 (particularly if you are running other architectures with the adobe plugin) then you may have to run the command "sudo update-alternatives --config mozilla-flashplugin" and select the "/usr/lib/gnash/" option. Lightspark does not appear in the list because it goes under the name of "". Run "update-alternatives --query" to check. This allows you to easily switch plugins in Firefox (goto Tools > Add-ons > Plugins and enable/disable plugins as required), but it means Lightspark will not be picked up in Midori (which handles plugins in a completely random way it seems to me) . However, as far as I can tell Lightspark does not work with Midori anyway because it uses Webkit and not Gecko. Gnash works with Midori, or to put it more precisely, adverts work, but strangely videos don't work even when they work in firefox with gnash.

    If you want to do debugging run the browser from the terminal. You can set the verbosity of gnash through right clicking on a flash object in the browser and selecting the Edit > Preferences menu entry. Use "firefox -verbose" to see the messages from the lightspark plugin. See . To test the lightspark standalone player use the commands:

    lightspark 1_coordinates[1].swf
    You should see a disk spinning that you can move around with your mouse. It is the least impressive demonstration ever!

    This thread offers more advice on watching YouTube, Vimeo, etc . I like the firefox extension FlashVideoReplacer ( since it allows you to watch YouTube videos 'normally'. Others may prefer minitube or Totem.

    Another way to watch YouTube etc is by using html 5 ( This works quite well for videos coded in H.264. You'll need Midori or Epiphany browsers for H.264, but for YouTube most videos are delivered in WebM (unless you spoof it, see below). WebM can be played in Firefox 4 and beyond, Opera, Midori and Epiphany, but for me the playback is choppy (similar to gnash), although I think Firefox may improve with every new release. Vimeo uses H.264 to deliver html5 video clips.

    To download and watch BBC Iplayer programmes there is get-iplayer.

    I've also recently started watching/listening to streams by finding the rtmp address used by the flash application. This youtube video describes how to use wireshark to do this, but there are other ways which you can find by doing a search. I find wireshark quite addictive and find myself trying to crack the rtmp address even if I don't have to! You can download a stream using rtmpdump, or pipe the output to a media player, but gnome-mplayer will also accept the rtmp addresss directly in the 'Open location' menu item.

    You can also change the user agent string of your browser so that you are delivered non-flash content. There is a firefox extension to do this, but it is probably best to use Midori to spoof an iPad/iPhone since they use H.264 to play video clips and Firefox cannot play H.264. Midori works really well on some news web sites and allows you to watch video clips that would be otherwise unwatchable. In Midori goto Edit > Preferences > Identify as > Custom... Copy and paste one of the following strings in:

    Mozilla/5.0 (iPad; U; CPU OS 3_2 like Mac OS X; en-us) AppleWebKit/531.21.10 (KHTML, like Gecko) Version/4.0.4 Mobile/7B334b Safari/531.21.10
    Mozilla/5.0 (iPad; U; CPU OS 4_3_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8G4 Safari/6533.18.5
    Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1_2 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7D11 Safari/528.16
    Remember there is plenty of choice out there. Don't get hung up on the website that you can't use, but instead support the websites you can access. If you want GoogleEarth then try as a substitute. There are ways of using Google Street View on PowerPC, see .

    3.6 Java
    I don't use Java myself and even disable the plugin for security (there are firefox extensions you can use to automate this), but here is some info about Java....

    If you want faster Java than openjdk then there is IBM Java . You have to register to download, but all you have to give is an email address so nothing too taxing. There are old deb packages in medibuntu.

    You could also try Java Virtual Machines such as Cacao and JamVM. The author of JamVM says of PowerPc "for many years my main platform, so this is well tested. Built and tested on G3 and G4 systems". In Natty and Oneiric there is a package ( available for other architectures (so the source code is readily available), but I believe it doesn't exist for PowerPC (possible bug?)? See and for more information:

    The easiest way to test the port is to build JamVM, and copy the file into an existing IcedTea/OpenJDK installation.
    After cloning the git repository, do:
    ./ --with-java-runtime-library=openjdk
    This will generate the autoconf/automake files and configure JamVM to build support for OpenJDK.
    Then do make, make install as usual. This will put into /usr/local/jamvm/lib.
    This can then be copied onto an existing IcedTea installation (or a copy of one), e.g. on x86_64 (as root):
    cd /usr/lib/jvm
    cp -r java-6-openjdk jamvm-openjdk
    cp /usr/local/jamvm/lib/ jamvm-openjdk/jre/lib/amd64/server
    For Cacao see . "The package provides an alternative runtime using the Cacao VM and the Cacao Just In Time Compiler (JIT). This is a somewhat faster alternative than the Zero port on architectures like alpha, armel, m68k, mips, mipsel, powerpc and s390."

    See the file /usr/lib/jvm/java-6-openjdk/docs/README.Debian and the other documents in that directory for information about how to use the alternative virtual machines. Note, the IcedTea Firefox plugin will use the default VM (which you can set). Technical detail about the IcedTea plugin can be found here .

    Some general stuff about Java in Ubuntu . Note, there is no oracle/sun java for powerpc linux.

    3.7 Screen Resolution/Black Screen/No GUI Problems
    3.7a General notes on display issues
    This is a massively daunting problem when you are new to linux/ubuntu. The key is not to panic, but take a methodical approach. Read the information below and if necessary the links. If you don't understand it then please ask. It is silly to suffer in silence.

    Do a quick check of your hardware! Make sure that your video cables are plugged in correctly and also try them in different sockets! Ubuntu may be outputting on a different port to that which you normally use.

    If you are at a 'Busybox' prompt or don't see a yaboot prompt at all then see section 3.9 'Yaboot Config/Busybox Error' below.

    If you are trying a Lubuntu live cd then first check out the release notes which are linked at the bottom of this post.

    If you are using the 'Unity' interface in 11.04 and are seeing awful colours, then this is a known problem with the unity-2d package and is not a graphics problem. See the 'General Workarounds' section to compile a newer version of unity-2d or upgrade to 11.10. The 'Classic' session (which you can select if you log out is not affected by this problem. If you have awful colours in 11.10, then log out and try the Ubuntu 2D session!

    If you think that fonts are blurred or not being displayed correctly then your monitor may not have the standard RGB sub pixel order. There is an option to change this. In standard Ubuntu goto System > Preferences > Appearance > Fonts > Details. You can also do it via an xorg.conf (see below).

    Unfortunately, there are quite a few problems with essentially the same symptom - a blank screen. So it is a case of trial and error to see what works. There are broadly two approaches to solving the blank screen: adding a yaboot parameter and setting up an xorg.conf file. The yaboot parameter (see section 3.7b) could be seen as the "quick fix" approach, good to get something at least on the screen (e.g. a cli login or a simple graphics setup), but often you may need to make it permanent too. An xorg.conf file (see section 3.7c) gives greater control of your graphics setup and is used, for example, to adjust a bad resolution or when you can't get beyond a cli login. Increasingly, an xorg.conf file is not needed in new versions of ubuntu.

    As strange as it may seem, on some computers (not all - it could be the 'nv' driver?) if the date is set far back in the past (because of a flat internal battery) then you may get a blank screen. You can use yaboot parameters to temporarily overcome this, but the best permanent solution maybe to buy a replacement battery? More feedback is needed on this. My iBook with a radeon card has no problem with being back in the 1970s!

    Note, Ubuntu evolves with every new release and yaboot parameters you may need for one release may not be required for the next release. To take advantage of improvements you should retest your graphics setup after an upgrade.

    3.7b Yaboot parameters for screen problems
    The first two yaboot parameters to try are "video=ofonly" (use only the openfirmware framebuffer - offb) and "nosplash" (disables on *some* computers the ubuntu splash screen i.e. the word ubuntu with the four dots). You add them after whatever you normally type at the second yaboot prompt. It is best to try all yaboot parameters separately first, but if you want to try them together, and you normally type "Linux" then you would type at the second yaboot prompt:

    Linux nosplash video=ofonly
    If these don't work, you can try further boot parameters, but these will depend on what graphics card you have. If you don't know what you have, you can look up your computer here or here .

    Modern open-source radeon and nouveau (nVidia cards) video drivers rely on kernel modesetting (KMS). KMS supposedly provides an improved graphical boot with less flickering, a built-in framebuffer console, seamless switching from the console to Xorg, and other features. To achieve this, KMS moves the responsibility for selecting and setting up the graphics mode from the Xorg to the kernel. See

    KMS can be problematic, however, so you can test if your computer will boot correctly without it. For nVidia cards use the yaboot parameter "nouveau.modeset=0" to disable KMS (see Please note, PPC ubuntu does not use grub/grub2 so disregard any instructions in the links relating to grub menus. For radeon cards use "radeon.modeset=0". See section 3.8 for more information about radeon settings.

    KMS conflicts with legacy framebuffer drivers (such as, radeonfb, nvidiafb, rivafb), so you should disable these if you want to try KMS. nvidiafb and rivafb which are the old framebuffers for nvidia cards are not 'complied in' to recent ubuntu kernels (and their modules are blacklisted) so they shouldn't cause a problem. radeonfb, aty128fb, and atyfb are, however, 'compiled in' to 10.04 and 10.10 kernels. radeonfb will stop radeon KMS working so you should disable it with the yaboot parameter "video=radeonfb:off".

    To force a nouveau mode (e.g. to enable a dvi connector and disable a non-existent tv out) see the bottom of . This may solve problems with some nVidia cards? Gentoo have more on phantom outputs .

    You can force the mode of framebuffers aty128fb (ATI Rage 128 cards) and atyfb (Mach 64 and Rage cards) too, for example: "video=aty128fb:1024x768-24@75". See the bottom of . The official guide suggests a different way, see the bottom of this page . I struggled to find information on vmodes/cmodes, so I'm not sure if that is old fashioned (something to do with MacOS?), but there is quite a good guide here . You will probably have to perform extra steps to use these framebuffers in 11.04 and 11.10. See section 3.7d below.

    You can additionally try "video=offb:off". This will disable the openfirmware framebuffer and is used when offb conflicts with another framebuffer (see log files syslog/dmesg in directory /var/log/). If no other framebuffer is available at boot time then you may get a frozen or blank screen until the Xorg server starts.

    For background information on framebuffers see , but again you'll have to filter out any details relating to grub as PowerPC does not use this. It describes adding "nofb" to the kernel line and you could try this as a yaboot parameter too? It also gives some information about the command fbset. This allows you to show or change framebuffer settings from the console .

    Note, yaboot parameters don't always work with the live cds, but you will still be able to install using the alternate or mini cds. If you do install from a live cd and you've used a yaboot parameter then that parameter should be automatically passed onto the install.

    To make a yaboot parameter permanent or remove a parameter from an installation, use the command "sudo nano /etc/yaboot.conf" and change the 'append' lines in the file. Add the desired parameter into the quotes, or remove the word 'splash' if you want to disable the splash screen. Every parameter inside the quotes should be separated by a space. Save (ctrl+o) and exit (ctrl+x), then type the command "sudo ybin -v" to copy the file across to the boot partition.

    3.7c Configuring an xorg.conf file
    If you have a distorted picture, a poor resolution, poor colours or can't boot past a command line login then you may need to setup an xorg.conf file....

    The lubuntu FAQ gives some basic information on this . For a more comprehensive guide have a look here or the xorg.conf manual .

    The information below this point only applies if you have installed a GUI.

    To setup an xorg.file you may find it more convenient (for example, if your picture is bad or black) to boot into single user mode. At the second yaboot prompt type "Linux single" (if this doesn't work then you may need to combine it with one or more of the other yaboot parameters above). This will boot into a menu (or take you straight to a root prompt). Choose 'continue boot' to take you into a command line login or you can choose one of the root options at the bottom of the menu list (in which case you can remove the word 'sudo' from the commands you type).

    Sample xorg.files for various machines can be found here . These can save you reading all the documentation, but some of them are not the best setup (that's me being polite!). Download the file using the wget command at the bottom of the appropriate page. Then move it using the command "sudo mv file_name /etc/X11/xorg.conf" where file_name will be something like "ibook2.txt". Reboot using "sudo reboot".

    It is not hard though to setup your own xorg.conf file, and if you have an external monitor then I would recommend you do so. Some instructions for setting up an xorg.conf and detecting your monitor resolutions are below:

    Get to a console, for example via single user mode. Then type:

    sudo Xorg -configure
    sudo mv /etc/X11/xorg.conf
    sudo nano /etc/X11/xorg.conf
    Note the capital 'X' in "sudo Xorg -configure". Also, you can probably ignore any errors from the command, such as "number of created screens does not match number of detected devices", as it will still generate an xorg.conf file. It just means you will have to delete some sections of the xorg.conf.

    At this point you may be freaking out a bit because it does look complicated when you are new to this sort of thing! However, once you overcome your panic and approach it more with a “can do” attitude you’ll see it is not so hard.

    An xorg.conf file is composed of a number of sections which may be present in any order. Each section has the form:

    Section "SectionName"
    To solve graphics problems we are mainly interested in the "Monitor", "Device" and "Screen" sections. Assuming you have a standard single monitor setup, then you probably only want 1 of each of these sections so you may have to delete some sections if it gives you two (natty did this to me). If this is the case, examine the two “Device” sections and look at the Driver section entry. If you have an Apple computer then the section you want to keep will have radeon, ati, r128, nouveau or nv written in the Driver entry (what is written depends on your graphics card). There are no proprietary (non-free) drivers for ppc. Above the Driver entry will be the Identifier entry. This is a unique name given to the graphics device and will probably be something like “Card0”.

    (Note, if you are using the yaboot parameter "nouveau.modeset=0" then you want "nv" written in the Driver entry instead of "nouveau". Ammend the xorg.conf accordingly. "nv" is the old driver for nvidia cards.)

    The “Monitor” and “Screen” sections also have Identifier entries. The “Screen” section has entries to reference the “Monitor” and “Device” sections as it's purpose is to bind the monitor to a graphics card. You want to keep the “Screen” section that references the identifier of the “Device” section that you are keeping. It will probably work out that you are keeping the sections “Card0”, “Monitor0” and “Screen0”.

    The highest level section is the “ServerLayout” section. When you delete sections you will have to change the “ServerLayout” section to reflect any changes. A shortened xorg.conf using r128 may look something like the one below. For clarity, the font and input device sections have been deleted which you can also safely do (if you are happy with their automatic setup). Note, the lines starting # are comments and don't do anything.

    Section "ServerLayout"
         Identifier     " Configured"
         Screen         "Screen0"
    Section "Monitor"
         Identifier   "Monitor0"
         VendorName   "Monitor Vendor"
         ModelName    "Monitor Model"
    Section "Device"
         ### Available Driver options are:-
         ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
         ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
         ### <percent>: "<f>%"
         ### [arg]: arg optional
         #Option     "NoAccel"               # [<bool>]
         #Option     "SWcursor"              # [<bool>]
         #Option     "Dac6Bit"               # [<bool>]
         #Option     "Dac8Bit"               # [<bool>]
         #Option     "DMAForXv"              # [<bool>]
         #Option     "ForcePCIMode"          # [<bool>]
         #Option     "CCEPIOMode"            # [<bool>]
         #Option     "CCENoSecurity"         # [<bool>]
         #Option     "CCEusecTimeout"        # <i>
         #Option     "AGPMode"               # <i>
         #Option     "AGPSize"               # <i>
         #Option     "RingSize"              # <i>
         #Option     "BufferSize"            # <i>
         #Option     "EnablePageFlip"        # [<bool>]
         #Option     "Display"               # <str>
         #Option     "PanelWidth"            # <i>
         #Option     "PanelHeight"           # <i>
         #Option     "ProgramFPRegs"         # [<bool>]
         #Option     "UseFBDev"              # [<bool>]
         #Option     "VideoKey"              # <i>
         #Option     "ShowCache"             # [<bool>]
         #Option     "VGAAccess"             # [<bool>]
         Identifier  "Card0"
         Driver      "r128"
         BusID       "PCI:0:16:0"
    Section "Screen"
         Identifier "Screen0"
         Device     "Card0"
         Monitor    "Monitor0"
         SubSection "Display"
              Viewport   0 0
              Depth     1
         SubSection "Display"
              Viewport   0 0
              Depth     4
         SubSection "Display"
              Viewport   0 0
              Depth     8
         SubSection "Display"
              Viewport   0 0
              Depth     15
         SubSection "Display"
              Viewport   0 0
              Depth     16
         SubSection "Display"
              Viewport   0 0
              Depth     24
    Save, exit and reboot (type the command "sudo reboot") to see if it is working. You may have to do some more alterations, but these will change depending on your symptons and the xorg log (type "nano /var/log/Xorg.0.log" to look at it). Use the markers to quickly trace problems in the log:

    (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    A description of some errors can be found here . There are a lot of warning messages at the start so it may be easier to start at the bottom of the log and work up. Messages about fonts can just be ignored. Don't worry about an "Invalid ROM contents", "Failed to read PCI ROM!", or "Video BIOS not found!" message, they sound scary, but are normal (although there is probably a setting you can tweak to turn them off).

    If you get the error '(EE) Failed to load module "nv" (module does not exist, 0)', then you need to install the package xserver-xorg-video-nv. In 11.10 you may have to compile it as it is not in the repository ( Compile instructions are in this post . Please try using the newer "nouveau" driver first.

    If you see the following combination of errors

    (EE) Unable to find a valid framebuffer device
    (EE) R128(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons
    (EE) Screen(s) found, but none have a usable configuration.
    then it is likely you are using the openfirmware framebuffer with a ATI Rage 128 card. You should specify the correct framebuffer with a yaboot parameter (e.g. video=aty128fb) or disable the openfirmware framebuffer. See section 3.7b above. If you are using 11.04 or 11.10 then you will have to load the aty128fb kernel module first (see section 3.7d below). You may still have to make changes to your monitor section (see below). An alternative "fix" for the framebuffer error can be done through the xorg.conf, although it has been commented that this solution is inferior (see thread The alternate fix is to set Option "UseFBDev" "False" and possibly also Option "NoInt10" "True" :

    Section "Device"
         Identifier "Card0"
         Driver "r128"
         BusID "PCI:0:16:0"
         Option "UseFBDev" "False"
         Option "NoInt10" "True"           #you can also put this is the Screen section
    If your resolutions have been incorrectly detected (out of range message in the Xorg.0.log or displays incorrectly on the monitor), then you can use the cvt command to find your monitor setting for the resolution you want. You can then add a modeline into the "Monitor" section using the output from the cvt command. You can add as many resolutions/modelines as you like.

    e.g. typing the following command for the resolution 800x600:

    cvt 800 600
    gives the following output on my iBook:

    # 800x600 59.86 Hz (CVT 0.48M3) hsync: 37.35 kHz; pclk: 38.25 MHz
    Modeline "800x600_60.00" 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync

    Make a note of the modeline, open the xorg.conf again and copy the modeline into whatever "Monitor" section you have (add/uncomment the preferred mode bit if you want to set that): e.g.

    Section "Monitor"
         Identifier "Monitor0"
         VendorName "Monitor Vendor"
         ModelName "Monitor Model"
         Modeline "800x600_60.00" 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync
         #Option "PreferredMode" "800x600_60.00"
    You will get different numbers when you run the cvt command as modelines are monitor specific. The "800x600_60.00" is the identifier/name of the mode. You must use this exactly whenever you refer to the mode in the xorg.conf (for example in the "Screen" section). You often see people shorten the name to "800x600" in which case it overrides the built-in mode. For example:

         Modeline "1024x768"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
         Modeline "800x600"   38.25 800 832 912 1024 600 603 607 624 -hsync +vsync
         Modeline "640x480"   23.75  640 664 720 800  480 483 487 500 -hsync +vsync
         Option "PreferredMode" "1024x768"
    You may also have to adjust your "Screen" section, but hopefully the resolution(s) should be picked up automatically and you won't have to do this. An example "Screen" section where modes have been explicitly stated is below:

    Section "Screen"
         Identifier "Screen0"
         Device     "Card0"
         Monitor    "Monitor0"
         DefaultDepth 24
         # 1024x760 will be the default mode because it is first in the list. 
         # The modes will apply to all colour depths because a 'Depth' entry has not been specified. 
         SubSection "Display"
              Viewport  0 0
              Modes     "1024x760" "800x600" "640x480"
    You can also select the mode using the xrandr command (e.g. xrandr --output LVDS --mode 800x600_60.00). To find the current mode use the command "xrandr --current" and a * will indicate the current mode. If you are using KMS then you may find that your preferred mode has been ignored. For more information on how to use the xrandr command see .

    An alternative to adding modelines is to specify VertRefresh and HorizSync values for your monitor. See links at the start of this section (3.7c) for more information on these. You should find values for VertRefresh/HorizSync in the handbook that came with your monitor. You can also find them out using the ddcprobe command. To use this you will have to install a package first with the command "sudo apt-get install xresprobe". Then type "sudo ddcprobe". The monitor range is shown at the bottom of the output. For example:

    monitorrange: 58-62, 75-117

    The first pair (58-62 in this example) is your HorizSync rate and the second pair is your VertRefresh (75-117) rate. The Monitor section using these values would look like this:

    Section "Monitor" 
         Identifier "Monitor0"
         VendorName "Monitor Vendor"
         ModelName "Monitor Model"
         HorizSync 58-62 
         VertRefresh 75-117
    If you see repeated "insufficient memory for mode" messages on the resolutions you want in the Xorg.0.log then try adding a "DefaultDepth 16" line to the Screen section. This will also enable DRI on some low memory graphics cards. However, in the past DRI has caused instabilaties with some cards.

    People have previously disabled DRI with an r128 card by adding Disable "dri" to the Modules section or setting a high resolution/colour depth combination. However, without DRI, 3D effects will be software-rendered, which will be slow. An alternative maybe to disable AIGLX as outlined at the bottom of this Fedora page . Gentoo recommend setting the option ForcePCIMode if you are having freezing problems with DRI .

    If you have configured your own xorg.conf then you'll have a full list of Device options you can tweak for your card. Look at the xorg.conf files people have used in the past for ideas on what to change. Before you make any alteration to your Device section, check the relevant manual for your card because the option may not relate to your error/problem. Not all options are documented in the manuals:

    3.7d Load kernel module
    In modern versions of ubuntu, most framebuffers are blacklisted in the file /etc/modprobe/blacklist-framebuffer.conf. Therefore, if the framebuffer you want has been compiled as a module (instead of 'complied in' to the kernel) it will not be automatically loaded. To make ubuntu load the module open the file /etc/modules with the command "sudo nano /etc/modules" and add the name of your framebuffer on a new line. To make the module available early in the boot process (preferred for a framebuffer), add the name also to the file /etc/initramfs-tools/modules. Use the command "sudo nano /etc/initramfs-tools/modules" to open the file, add the name on a new line, save and then, importantly, run the command "sudo update-initramfs -u". Reboot ("sudo reboot") for the changes to take effect.

    3.7e Test your 3D graphics acceleration and beyond
    Following a reboot, you can test your graphics acceleration with the commands "glxinfo" and "glxgears -info". You'll probably have to install the mesa-utils package first "sudo apt-get install mesa-utils". See for how to interpret the results.

    If you have a multi-user setup then you may need to add the following section to your xorg.conf (use the command "LIBGL_DEBUG=verbose glxinfo" to test):

    Section "DRI"
         Mode 0666
    See for information on this, as well as, more troubleshooting tips. It has a good section on how to interpret Xorg.0.log messages.

    There is no 3D acceleration with the driver 'nv' (see and so you should try the newer 'nouveau' driver if you want this. If you can't get the version of nouveau that is in the ubuntu repositories working then there is a tutorial to compile the latest nouveau driver here . You'll have to adjust some of the instructions for PowerPC.

    If you have a radeon card then see section 3.8 below which has some more advice on improving performance.

    Note, future releases of mesa will drop support for Mach64 and r128 cards, see, although it is hoped future releases of ubuntu will contain some sort of mesa-old-drivers package .

    3.8 Radeon Tweaks
    To get the best out of my radeon card (see and I make a few alterations. With lucid (10.04) and maverick (10.10) I turn off KMS (kernel mode setting) by using the radeon.modeset=0 boot parameter (see section 3.7b above). If I don't do this then I have poor video playback (a strange vertical pixelation) and get low values in glxgears (you see "Software Rasterizer" written when running the command "glxgears -info"). In natty (11.04) I don't need this parameter because by default ppc radeon KMS is turned off in this version of ubuntu.

    You can force a radeonfb mode by using, for example, the yaboot parameters: "radeon.modeset=0 video=radeonfb:1024x768-24@60". Forcing a mode may also fix splash problems?

    If you want to experiment with KMS you should turn it on with the radeon.modeset=1 boot parameter. In lucid and maverick you will also have to disable the radeonfb framebuffer "radeon.modeset=1 radeonfb:off". Archlinux provide some more information on KMS with a radeon card . Note, the KMS radeon framebuffer will be listed in logs as radeondrmfb.

    If you experience choppy scrolling in firefox (can occur when you turn off KMS) then it is worth experimenting with the "AccelMethod" option in the device section of your xorg.conf file (see section 3.7c above). Under lucid and maverick I set this to "EXA" to fix the choppy scrolling. However, under xubuntu 11.04 I need to set it to "XAA". "EXA" uses less processor power but under natty especially there are a lot of rendering errors. It maybe worth investigating upgrading/downgrading drivers or checking out what framebuffers you have loaded (see sections 3.7b and 3.7d above) if you are bothered about this.

    I also set the "GARTSize" option to "16" (half my graphics memory) because the default 8 causes silly colours (a blue tint) with the gl screensavers.

    There are a lot of 'wonder' xorg.conf files knocking around the internet that claim to have the secret formula to fantastic 3d performance. I've only found two things that make a big difference. The first is to reduce the colour depth (for example put "DefaultDepth 16" into the screen section), but I prefer a greater colour depth so I don't do this. The second is to turn on HyperZ. This isn't done in xorg.conf, but in a ".drirc" file in your home folder. Install Driconf from the software centre/synaptic so that you can turn it on using the applet. I have no idea what this actually does, only it makes the numbers go up in glxgears!

    You may also like to enable the "ClockGating" and "DynamicPM" settings as they reduce heat output and increase battery life.

    3.9 Yaboot Config/BusyBox Error
    If you update to Oneiric (11.10) and instead of a login you face a 'BusyBox' shell then try the commands:

    modprobe pata_macio
    The boot should then hopefully resume. Once you login you can use these additional commands to make it permanent:

    echo pata_macio | sudo tee -a /etc/initramfs-tools/modules
    sudo update-initramfs -u
    The above is just a fancy way of adding the word "pata_macio" to the end of the modules file. You could alternatively type "sudo nano /etc/initramfs-tools/modules" to open the file and add the word on a new line yourself. You must always run "update-initramfs -u" for the changes to take effect. Reboot using the command "sudo reboot" to check that it is working.

    If the boot didn't resume with the 'modprobe' command then you may have to perform some additional steps as detailed here .

    Following the ubuntu base installation, if you find you suddenly can't boot existing linux distributions (such as debian), then you may have to alter
    your yaboot.conf. I had to do this as detailed in this post (although your setup/numbers will be obviously different). To open yaboot.conf type "gksudo leafpad /etc/yaboot.conf". When you've made and saved your changes use the command "sudo ybin -v" to copy it across to the boot partition. Use the command "sudo blkid" to print the details/attributes of your partitions.

    A typical yaboot.conf taken from a linux only natty installation is here .

    Info on dual booting with yaboot and what to do if you loose yaboot can be found here .

    On some installations (e.g. onto a usb drive or with the new ata controller drivers in 11.10?) you may have to use the ofboot argument to specify the openfirmware path to the boot partition. Gentoo have an excellent quick guide to manually editing the yaboot.conf file which some people may find useful: . It contains advice on the ofboot argument, as well as, adding a root delay. You can also look at the yaboot.conf manual by typing the command "man yaboot.conf". The more wordy debian guide is here . This gives instructions on how to boot the system from openfirmware.

    If something goes catastrophically wrong with your boot partition, then don't panic because you should always be able to use a ubuntu cd (mini, alternate, or live) to boot your installed system. Run the cd to the yaboot prompt. Instead of entering 'live' or whatever, use the openfirmware path to the kernel image. Some examples for the current and old kernel paths on partition 3 are below:

    hd:3,/boot/vmlinux root=/dev/sda3 initrd=hd:3,/boot/initrd.img ro
    hd:3,/boot/vmlinux.old root=/dev/hda3 initrd=hd:3,/boot/initrd.img.old ro
    The files vmlinux, vmlinux.old, initrd.img and initrd.img.old are links to other files. If you know those exact filenames (or another kernel image) you could use those too.

    If you prefer the yaboot prompts to have a white background with black text (like openfirmware) add the following lines to your yaboot.conf:
    Install grub2 if you have run out of things to play with

    3.10 Sound Problems
    To change the volume of the mac startup chime see .

    Sound should work 'out of the box' on the vast majority of machines. However, if you can't hear any sound then first check your channel volumes and mute settings. In Lubuntu, use alsamixer (from a terminal) or gnome-alsamixer to do this The letter m toggles mute in alsamixer.

    If this doesn't solve the problem then you may have to investigate the kernel modules used by your sound card. Check the various system logs or use the commands "lsmod" or "lspci -k" to see what is being loaded. Older Macs should use snd-powermac, whilst newer Macs use a combination of snd-aoa, snd-aoa-fabric-layout, snd-aoa-soundbus, snd-aoa-soundbus-i2c, snd-aoa-onyx, snd-aoa-tas and snd-aoa-toonie. See or for greater detail.

    Occasionally, the automatic setup does not work correctly and you may have to modprobe some modules. To automatically 'modprobe' a module on startup you should include it in the /etc/modules file. Open the file using the command "gksudo leafpad /etc/modules" and add either "snd-powermac" or "snd-aoa" etc on a new line (see

    To get sound working on a Powermac G4 Digital Audio (which should use snd-powermac) you may have to blacklist some modules (see and See for additional advice. Open/create the file /etc/modprobe.d/blacklist.local.conf (the command is "gksudo leafpad /etc/modprobe.d/blacklist.local.conf") and add

    blacklist snd-aoa
    blacklist snd-aoa-fabric-layout
    blacklist snd-aoa-soundbus
    blacklist snd-aoa-i2sbus
    blacklist snd-aoa-codec-tas
    3.11 Trackpad and Right-click
    To change how a trackpad behaves see . You can also use the program GSynaptics, edit your xorg.conf file (see section 3.7 above) or install powerprefs (see information about suspend in section 3.12). Another option, is to create a script which runs the commands you want at startup.

    Right-click is set to F12 by default. On some boots my 'fn' key seems to be set on, in which case I need to press 'fn' + F12. When this occurs, it also stops me switching to a console e.g. via ctrl+alt+F1 etc.

    Mouseemu is the daemon that emulates right and middle click and can also block the trackpad when typing . You must prefix the mouseemu and showkey commands with "sudo". To change the default settings you can edit the /etc/defaults/mouseemu file.

    3.12 Power Preferences/Suspend
    If you are trying to change the power preferences then open the terminal and type "gnome-power-preferences". You can change the settings so that the power icon is displayed at all times and then you can access the preferences from there.

    In lucid and maverick you may have to install powerprefs (a graphical frontend to pbbuttonsd) to enable suspend when you close the lid. It doesn't setup a menu item automatically, but you can start it from the terminal by just typing "powerprefs" (for some options you might need to load it with root privileges: "gksudo powerprefs"). You may have to adjust your gnome power preferences settings so they don't clash. There is no guarantee that suspend or hibernate will work or be reliable!

    To get suspend working with a radeon card in Natty and Oneiric you may have to compile a new kernel (see and ), although I wonder if this is actually necessary? Radeonfb should already be compiled as a module so it just needs to be loaded (see section 3.7d above)? Suspend should be available with KMS, but does it work with ppc radeon KMS??? The ArchLinux guys wrote something about suspend . How to debug suspend can be found here . See for more info on pbbuttonsd.

    Suspending may mute sound channels or disable your wifi. See relevant sections.

    To power on automatically after a power failure .

    3.13 Software Centre
    Lubuntu does not use the Ubuntu Software Centre by default. I used to think it was because the software centre was just slow on old machines, but I've found it actually works really well when the apt-xapian-index package is not installed. To install the software centre type "sudo apt-get install --no-install-recommends software-center". When using the software centre you have to be a bit careful so that you don't drag in anything that will spoil your lightweight distribution (such as pulse audio, although it is not the end of the world if you do). This is probably why the lubuntu developers try and encourage people to use Synaptic as it is easier to see exactly what is being installed.

    See the official Lubuntu FAQ for information about the Lubuntu Software Center that you can install via the lubuntu ppa.

    3.14 Booting from USB
    There is a lot of confusion about booting from a USB device on a PowerPC machine. Here is what Apple have to say . So if your model was introduced after August 1999 then there is a good chance you will be able to boot from USB.

    To copy an iso to a USB stick:

    First, find out the device name of the USB device. Look in the ubuntu disk utility program or something for this. Mine is /dev/sda

    Then use the 'dd' command to copy the iso to disk. WARNING!! This will erase your USB stick so only do this if it hasn't got anything important on it! To return the USB stick to 'normal', you'll need to repartition and reformat it at the end! Also, double check you have the device name correct as you don't want to erase a hard drive or anything like that by mistake! The 'dd' command will do its thing even if you have the device mounted. The command you want will be something like this:

    sudo dd if=~/Downloads/ubuntu.iso of=/dev/sda
    where ~/Downloads/ubuntu.iso is the path of the iso file and /dev/sda is the USB device. Please be extra careful if you have a G5 or are using 11.10 as it is likely your hard drive will be called sda.

    Contrary to what you may have read elsewhere, it is possible to copy the iso from an intel machine running Ubuntu/linux. The dd command just copies raw data afterall. However, if you are having problems you could try adjusting some of the settings of the dd command? For example, set bs=512 or bs=4096? See .

    If you want to copy the iso to USB from Mac OS X then the instructions to do so are here . These comments suggest it can be done, although it maybe a little temperamental.

    Restart the machine holding the Option key. You should be able to choose your USB device to boot from. If you don't see your USB device (or it won't boot from it) then try holding down simultaneously Command-Option-Shift-Delete during start-up. This will bypass the internal hard drive and boot from an external drive or CD. If you want to force a particular SCSI device use cmd-opt-shift-delete-# where # = SCSI ID number.

    If those don't work, restart the machine into openfirmware (hold down Command-Option-o-f while turning on). To boot the USB device type

    boot usb0/disk@1:2,\\yaboot 
    (or something similar like "boot usb1/disk@1:2,\\yaboot" or "boot usb1/disk:2,\\yaboot")
    It can be very tricky to find the openfirmware path to yaboot. On some machines you can use "boot ud:2,\\yaboot". Use the openfirmare commands "dev / ls" and "devalias" to try and help you. If you can't see your usb device/files from openfirmware then you won't be able to boot from the device.

    I have given more information about booting from USB on this page . There are some troubleshooting tips if you are trying to boot an 'alternate' iso. The first post in the thread contains a different method to create a bootable USB device and more tips on booting from openfirmware.

    If you want to install a system onto a USB device (instead of a hard drive), then you may need to specify an ofboot argument in your yaboot.conf file. See section 3.9 above for more advice on this.

    3.15 Security
    Many would consider Ubuntu to be secure ‘out of the box’ due, in part, to the often quoted (but perhaps misleading) statement “Ubuntu comes with no open ports”. This is rather a simplified view and is challenged in the evolving security wiki (aimed at people new to Linux) here , with further information in the sticky threads on the Security Discussion forum . For more information about the security design decisions made by the Ubuntu Security Team see .

    The wiki and sticky threads describe how you can enhance the security of Ubuntu above the default installation, although they take a rather paranoid view of security that I would imagine far exceeds that used everyday by most Ubuntu, Mac and Windows users. Nevertheless, it is worth reading the information as security is probably something that many Linux users can be complacent about. However, as you increase the security of your system the ease of use decreases, so you need to find a balance that you personally are happy with. For example, the idea of running NoScript may not sound appealing, but maybe there are features that you can turn on that don’t effect your web browsing experience? As I describe in section 3.6 above, I disable the icedtea Java plugin completely without any loss of function to me. Note, Java is not the same as the similarly sounding javascript.

    My own view is that if you are new to Linux then I would suggest getting to know Linux/Ubuntu before tackling any extra security features. Ubuntu can have a steep learning curve as it is. Many risks can be mitigated with common sense.

    Keep the system updated via the Update Manager. Only install/run software that you need and only install software from secure and trusted sources (e.g. the Ubuntu repositories). Whilst a person/website may provide a package or executable with good intentions, can you be sure their server has not been hacked and the binary swapped for something malicious?

    If you are running ssh or vnc, possibly as part of a server setup, then you do need to learn to secure them properly.

    One of the main reasons I am keen to stick with *ubuntu is because they provide secure repositories with full traceability. Source code and build logs for every package are available in Ubuntu through .

    4. How To Help PowerPC Ubuntu
    I 'stole' (based) most of the following from the sticky thread on the Ubuntu Studio forum!

    Hopefully you're now enjoying your new PowerPC Ubuntu system. Maybe you've stopped to think 'I wonder how all these wonderful tools came to be... ...who packaged them... ...why these ones... ...what makes ubuntu such a success?' well, the answer to all these questions is the same: the development community. Having a large group of individuals to help build Ubuntu creates a network of checks and balances, not to mention lighter work for everyone.

    GNU/Linux is a community effort, and because of this, we all hope that you too will get involved. Who me? Yes, You.
    You may hold the common misconception that because you don't know how to program, you're no good to the development community, but nothing could be further from the truth. No matter what your level of expertise with Ubuntu you can lend a hand. Furthermore, in the field of PowerPC Ubuntu, we NEED your help.

    Every level of Ubuntu user can help the communiy in some way. Here's a few examples (please don't feel limited to these suggestions) just to get you started:

    1. The Absolute Beginner (you're just finding your way around, learning, and noticing the layout):
    * Stick around these forums and answer any questions you can (just reading the posts will help educate yourself)
    * Even absolute beginners can help edit the community documentation. Many of the directions here suffer from a lack of eyes, leading to unclear instructions - if you find some please tell someone or even edit it for the better yourself. The PowerPC FAQ is at the time of writing crying out for a makeover.

    2. The Novice User (this isn't the first version of ubuntu you've used, you're able to get most work done that you need to):
    * Document, document, document; head on over to the community docs and start editing for the better (many sections of these documents need substantial work and we'd love all the help you can offer)
    * Report bugs you find (actual bugs such as missing packages, not your configuration issues) at (this is the official bug tracker and development portal for ubuntu). See .

    3. The Advanced User (given any howto and a terminal you can fix almost anything)
    * Install a copy of the development release on another partition and report bugs/issues etc...
    * Regularly test ISO builds. See .
    * Document, document, document!

    4. The Hacker (you've compiled a kernel for yourself, don't need any directions for most system modifications, and generally prefer to use the terminal)
    * See 'The Advanced User' points.
    * Join a dev mailing list and introduce yourself
    * Log into and join some development channels.
    * Learn to package software
    * Comment on bugs at

    5. Useful Links
    The official Lubuntu FAQ (including, for example, how to enable autologin) is here .

    The Lubuntu homepage is here . There are a lot of good screencasts that show you how to to customize lubuntu.

    The Ubuntu community documentation can be found here . The offical documentation is here .

    The Oneric Lubuntu release notes are here . The general Ubuntu release notes are here .

    Links to the Ubuntu PowerPC FAQ and Known Issues pages can be found here .

    The Debian PowerPC mailing list is here . This is an excellent place to look for information about new changes to the kernel.
    Last edited by rsavage; January 14th, 2012 at 01:07 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts