Page 11 of 14 FirstFirst ... 910111213 ... LastLast
Results 101 to 110 of 138

Thread: fbsplash

  1. #101
    Join Date
    Aug 2005
    Location
    Mid-Michigan
    Beans
    22
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: fbsplash -- progress bar broken

    I need help. I'm trying to build this against 2.6.18 (emission1) on Edgy. I can get the kernel compiled, splashutils installed, etc...but I'm having problems:

    If I use splash_geninitramfs, the splash will show at 1024x768, but any kernel messages over-write the splash. Also, no progress bar movement and text is always "loading kernel image". TTY1 does have the splash, however.

    If I use the generic initrd file (backed up from kernel install), I get no splash at all. No mention of fbsplash in dmesg. (Vesafb is there, though the screen res during startup is only 640x480)

    Am I missing something here? I've had the exact same problem using 2.6.17 and 2.6.18 kernels, all with various flavors of emission, beyond, hand-patching, etc. I've even tried a bootsplash splash (converted) and got the same exact problems.

    Only thing I haven't tried yet is building splashutils from source. I'm also thinking there's either a problem with /etc/init.d/splashutils script or the fact that I'm missing any splash scripts in /etc/rc2.d (save for usplash's K10usplash script for shutdown)

  2. #102
    Join Date
    Apr 2006
    Beans
    138
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: fbsplash -- progress bar broken

    If you use Ubuntu's generic initrd file, you're using Ubuntu's kernel, that's why you don't get the splash (the initrd is a ramdisk image that contains the kernel and all the modules). You also only get the old vesafb, not vesafb-tng, which uses a different syntax, that's why it's only 640x480
    I think it might be a problem with the scripts. Unfortunately I'm no longer using fbsplash (new usplash is fine), but I'll try to help. You don't need splash_geninitramfs, instead:

    4. Disable usplash:
    Since splashutils provides usplash, you can uninstall usplash (*ubuntu-desktop will not be uninstalled). If you don't want to do that, disable it manually:

    -instructions not available since the forum cut off this part of the howto and I can't remember them. Uninstall usplash instead.

    5.
    Regenerate the initrd image: If you uninstalled usplash you don't have to do this.
    Whenever you install a new theme you'll have to regenerate the initrd image to be able to use it. Just run sudo update_initramfs. It will copy all themes in /etc/splash.

    The fbsplash packages add a script that automatically adds the themes to the initrd when you run update_initramfs, so there's no need to run splash_geninitramfs. You do have to uninstall usplash, since it will also copy itself to the initrd when you run update_initramfs. Uninstalling usplash will also run update_initramfs (to remove usplash from the initrd).
    I doubt this will solve your problem tough, as it seems that the fbsplash daemon is killed too early, and that is probably caused by a script bug. Unfortunately I can't help you with that. You may want to contact the author of the scripts and the Debian howto (the link is in the first post)
    "Don't try to be a great man, just be a man and let history make its own judgments." -- Zefram Cochrane

  3. #103
    Join Date
    Aug 2005
    Location
    Mid-Michigan
    Beans
    22
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: fbsplash

    I tried using both the generic initrd and the new one. The generic gave no theme at all, though the one I generated did give the splash, there were the problems I mentioned.

    The reason I want to use fbsplash was for compatibility with suspend2, capability to switch to verbose mode, along with themed ttys.


    I'll try to contact the author, as it seems to me that the scripts are what's missing.

  4. #104
    Join Date
    Oct 2004
    Beans
    2,324

    Re: fbsplash -- progress bar broken

    Quote Originally Posted by knn View Post
    ...
    4. Disable usplash:
    Since splashutils provides usplash, you can uninstall usplash (*ubuntu-desktop will not be uninstalled). If you don't want to do that, disable it manually:

    -instructions not available since the forum cut off this part of the howto and I can't remember them. Uninstall usplash instead.
    simply backup /sbin/usplash_write and replace it for:
    #!/bin/sh
    #
    ## Wrapper usplash - fbsplash
    #
    ## Make sure we process only PROGRESS command
    ## (until /etc/init.d/rc supports more)
    #
    exit 0
    Quote Originally Posted by knn View Post
    ...
    I doubt this will solve your problem tough, as it seems that the fbsplash daemon is killed too early, and that is probably caused by a script bug...
    in my case the script was killed by a long list of "[[: wrong substitution" or something like...

    I replace the first line of /etc/init.d/splashutils from #!/bin/sh to:
    Code:
    #!/bin/bash
    and it worked again. I'm using smae splashutils package then in dapper, not much updated, but since they work.

    My only problem now is that boot messages appeared over the themed image...
    Last edited by Rui Pais; November 7th, 2006 at 12:58 AM.
    ___________________________________
    ESTRAGON: We've lost our rights?

  5. #105
    Join Date
    Apr 2006
    Beans
    138
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: fbsplash -- progress bar broken

    Quote Originally Posted by Rui Pais View Post
    simply backup /sbin/usplash_write and replace it for:




    in my case the script was killed by a long list of "[[: wrong substitution" or something like...

    I replace the first line of /etc/init.d/splashutils from #!/bin/sh to:
    Code:
    #!/bin/bash
    and it worked again. I'm using smae splashutils package then in dapper, not much updated, but since they work.
    If you're using Edgy, sh is symlinked to Dash, not Bash like in Dapper. Dash is a smaller, faster shell interpreter, but can cause problems like that
    "Don't try to be a great man, just be a man and let history make its own judgments." -- Zefram Cochrane

  6. #106
    Join Date
    Oct 2004
    Beans
    2,324

    Re: fbsplash -- progress bar broken

    Quote Originally Posted by knn View Post
    If you're using Edgy, sh is symlinked to Dash, not Bash like in Dapper. Dash is a smaller, faster shell interpreter, but can cause problems like that
    yes, i figured it was something like that...
    those kind of things don't bring any special kind of speed or improvement, and creates a lot of problems with scripts not originally from Ubuntu, reducing compatibility with non-supported software
    Thanks for the info.
    ___________________________________
    ESTRAGON: We've lost our rights?

  7. #107
    Join Date
    Jul 2005
    Beans
    20

    Re: fbsplash

    HI all,
    i just built a new kernel (2.6.18-emission1) for fbsplash, too, and i have the same problem like T-One.

    System boots, fbsplash starts (resolution is correct), but i do not have any Silent-Mode. When fbsplash gets started my startup-screen just has another background, but the silent-image is never shown.

    Another thing is, my System takes arround 50% of boottime on the Kernel (dirty black on white, just like before), 30% on init-scripts with non-silent-fbsplash and 20% on loading Xorg/kdm.
    Is it possible to start fbsplash directly with the kernel instead of the init-script? Because at the moment i do not have any splash on 70% of my bootprocess...

    btw: how do i create a initrd-file with fbsplash-stuff ONLY? Everything my system needs is hardcoded in my kernel...

  8. #108
    Join Date
    Apr 2006
    Beans
    138
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: fbsplash

    Generate the initrd with splash_geninitramfs. run zcat yourinitrd_file | cpio --list to see what the initrd contains
    "Don't try to be a great man, just be a man and let history make its own judgments." -- Zefram Cochrane

  9. #109
    Join Date
    Jul 2005
    Beans
    20

    Arrow Re: fbsplash

    ok, had a nearly empty initrd
    Built a new one, now splash starts very early.

    Found another thing:
    When i started the slashutils-initsctipt after booting i got that:
    Code:
    mount: mount point /lib/splash/tmp does not exist
    /etc/init.d/splashutils: line 143: eerror: command not found
    /sbin/splash: line 172: splash_get_mode: command not found
    /etc/init.d/splashutils: line 145: return: can only `return' from a function or sourced script
    mount: special device /lib/splash/tmp does not exist
    mount: mount point /lib/splash/tmp does not exist
    umount: /lib/splash/tmp: not found
    
    The filesystem mounted on / doesn't contain the /dev/tty1 device
    which is required for the silent splash to function properly.
    Silent splash will not be enabled. Please create the appropriate
    device file to avoid this message.
    So i added a directory /lib/splash/tmp and on next reboot my silent splash-process-bar startet moving (and stays silent).

    The only Problem i have now is that boot-messages of some init-scripts get printed over the silent-splash
    That doesnt look very nice, any idea? The messages do not appear on verbose-fb-console when switching back to tty1 (from my X-Terminal), i do not even find them in any logfiles, too.

    BTW: I use kUbuntu 6.10... anybody here without problems on ubuntu edgy with fbsplash/splashutils?

  10. #110
    Join Date
    Apr 2006
    Beans
    138
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: fbsplash

    Ubuntu's init outputs to tty8, not tty1. Check if the messages are there
    "Don't try to be a great man, just be a man and let history make its own judgments." -- Zefram Cochrane

Page 11 of 14 FirstFirst ... 910111213 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •