Page 53 of 56 FirstFirst ... 3435152535455 ... LastLast
Results 521 to 530 of 560

Thread: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

  1. #521
    Join Date
    Nov 2008
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    He has a link to his e-mail on his page. Tokenrove's e-mail address.

  2. #522
    Join Date
    Mar 2013

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    I have e-mailed tokenrove, hopefully with his help all this will work out.
    Thanks for all the help Favux.

  3. #523
    Join Date
    Apr 2013

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    1 Download wacom_serial-120327-1.tar.bz2

    2 Change 0x3d to 0x3e (wacom_serial.c, serio-ids.h)

    3 make all
    sudo cp inputattach /usr/bin
    sudo cp wacom_serial.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet
    sudo depmod -a
    sudo inputattach --wacom_iv /dev/ttyS0

    However, can't move mouse cursor with touch pen.

    it was works on UbuntuStudio13.04 until yesterday.

    Tablet Wacom PL-550
    OS UbuntuStudio13.04

  4. #524
    Join Date
    Nov 2008
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    Hi sino1992,

    Welcome to Ubuntu forums!

    Hard to believe you had a hardware failure just then. I assume you reinstalled wacom_serial.ko because Update Manager installed a new kernel? So reinstalling it should have worked which means something else changed. Do you remember what else it installed? Anything to do with the X Server or xf86-input-wacom? If you don't remember you can check Update Manger's log at /var/log/apt/history.log.

  5. #525
    Join Date
    Jul 2011
    Ubuntu 10.04 Lucid Lynx

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    Information that might be of some use to some of you i’d like to share.

    sometime ago i got a digitizer ii ud-1218-r but it did not have the wall wart or serial cable with it, in my quest for a serial cable i came across one man that had used a serial cable to usb hack and one drawing of the original serial cable used. and at that time no serial driver in Linux.

    so getting this ud-1218-r working was looking pretty thin, until i came across a forum where they are using a teency 2.0 to complicate with the tablet over usb, you do need to take the tablet apart and do some soldering and some programing . but in the end if all goes well your tablet works and all you have is a usb cable coming out of it. the tablet will get it’s power from the teency through usb connection.

    i did everything from xubuntu 12.04 64bit and i have tested it on ubuntu 10.04 64bit and xubuntu 12.04 64bit the kernel drivers were already installed.

    Bus 005 Device 003: ID 056a:0045 Wacom Co., Ltd Intuos2 12x18

    so now ubuntu or xubuntu See’s my digitizer ii ud-1218-r as a ID 056a:0045 Wacom Co., Ltd Intuos2 12x18.

    link below for forum doing the hack

  6. #526
    Join Date
    Jun 2011

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    Quote Originally Posted by Cognuss View Post
    I have e-mailed tokenrove, hopefully with his help all this will work out. Thanks for all the help Favux. Cognuss
    Hi everyone.

    I just wanted to make a public statement about the status of the driver; here seems to be the best place as most of the users looking for support come through this thread. Everyone who has emailed me knows I haven't had much time to troubleshoot issues with the driver, and I apologize for that. I think many of these problems come from the driver not being integrated in the kernel.

    In February, I submitted a patch to the linux-input maintainer, which was said to be acceptable, but I was asked to look into unifying my driver with the USB wacom drivers instead. There are two reasons why this hasn't happened yet, and may not happen:

    1. I haven't had much time to work on the driver in general, let alone try to merge it with other code (which I do not expect to be a fruitful effort given the significant differences between the drivers).
    2. This will require significant cooperation from the "modern" Wacom driver maintainers, who history has shown would be happy to see Wacom serial devices disappear from the face of the Earth. I hate to put this so antagonistically, but I can't help seeing it this way after the reaction to my kernel submission.

    I wanted to let everyone know that there is a good chance I will work on this again in the next couple of months (perhaps an intermediary solution would at least be to get a serio ID reserved for the driver in future kernels), but overall, I don't have a lot of time to work on it, and if someone else wants to step up and maintain the code (which probably actually mostly means more politicking and less coding), the opportunity is there. The code's all GPL, you'd have my blessing, et cetera.

    Thanks to everyone using the driver, and let's hope there's a brighter future for these excellent devices than tossing them in the garbage.

  7. #527
    Join Date
    Mar 2013

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    Hello I'm back again. It turns out that last time I didn't have the driver correctly installed.
    Now that I have it installed properly, can we try this again?
    Xorg shows this about it:
    [ 12639.137] (II) config/udev: Adding input device Wacom protocol 4 serial tablet (/dev/input/event13)
    [ 12639.137] (**) Wacom protocol 4 serial tablet: Applying InputClass "evdev tablet catchall"
    [ 12639.137] (**) Wacom protocol 4 serial tablet: Applying InputClass "Wacom class"
    [ 12639.137] (II) Using input driver 'wacom' for 'Wacom protocol 4 serial tablet'
    [ 12639.137] (**) Wacom protocol 4 serial tablet: always reports core events
    [ 12639.137] (**) Option "Device" "/dev/input/event13"
    [ 12639.137] (II) Wacom protocol 4 serial tablet: type not specified, assuming 'stylus'.
    [ 12639.137] (II) Wacom protocol 4 serial tablet: other types will be automatically added.
    [ 12639.137] (EE) Wacom protocol 4 serial tablet stylus: unable to ioctl xmax value.
    [ 12639.208] (EE) PreInit returned 8 for "Wacom protocol 4 serial tablet stylus"
    [ 12639.208] (II) UnloadModule: "wacom"
    My 50-wacom.conf contains this:
    Section "InputClass"
        Identifier "Wacom class"
        MatchProduct "Wacom|WACOM|Hanwang|PTK-540WL"
        MatchDevicePath "/dev/input/event*"
        Driver "wacom"
    Section "InputClass"
        Identifier "Wacom serial class"
        MatchProduct "Serial Wacom Tablet"
        Driver "wacom"
    Section "InputClass"
            Identifier "Wacom serial class identifiers"
            MatchProduct "WACf|FUJ02e5|FUJ02e7|FUJ02e9"
            Driver "wacom"
    # Waltop tablets
    Section "InputClass"
        Identifier "Waltop class"
        MatchProduct "WALTOP"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "wacom"
    # N-Trig Duosense Electromagnetic Digitizer
    Section "InputClass"
        Identifier "Wacom N-Trig class"
        MatchProduct "HID 1b96:0001|N-Trig Pen"
        MatchDevicePath "/dev/input/event*"
        Driver "wacom"
        Option "Button2" "3"
    and my xorg.conf file has this:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 310.44  (buildmeister@swio-display-x86-rhel47-07)  Wed Mar 27 15:56:20 PDT 2013
    #Section "Files"
    Section "ServerLayout"
        Identifier    " Configured"
        InputDevice   "stylus"
    Section "InputDevice"
        Driver        "wacom"
        Identifier    "stylus"
        Option        "Device"         "/dev/ttyUSB0"
        Option        "Type"           "stylus"
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    Section "Monitor"
        Identifier     "Monitor0"
        Gamma          0.5
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        Option         "RegistryDwords" "EnableBrightnessControl=1"
        Option         "NoLogo" "true"
        VendorName     "NVIDIA Corporation"
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
            Modes      "1920x1080"
    Any help you can give would greatly be appreciated.

  8. #528
    Join Date
    Aug 2013

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    Oh boy, sorry to bump this thread with nothing useful, but I felt I needed to register to the forums to express my gratitude.
    I got my stupid Graphire2 working thanks to the gathered knowledge in this thread!

    One line should be bolded though ... or written in 50pt
    When you run the make all command both the compiled inputattach.ko along with wacom_serial.ko will now no longer conflict with tsc40.ko.

    I usually don't believe in magic, but I spent hours wondering why an installed driver would work perfectly, and completely disappear after a reboot.

    To everyone involved!

  9. #529
    Join Date
    Nov 2008
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    @ Cognuss,

    Inspiration is not jumping out at me. Have you tried commenting out the xorg.conf Wacom stylus stuff and checked if there is any difference with just xorg.conf.d? Did we establish what version of xf86-input-wacom you are using?
    xsetwacom -V
    What are you seeing in lsmod? Did you specify what serial to usb converter you are using? We may have to check its kernel driver to see if it has the support for the Wacom X driver ioctl. But as I mentioned that was dropped a while ago so I'm a bit puzzled by that error message. Maybe we should be going the other way and be specifying the ioctl option in xorg.conf or xorg.conf.d? Somehow your converter's kernel driver requires that? Never needed to do that before. Might be a pain to figure out the details because I sure don't remember. If we're lucky maybe there was a wiki entry somewhere.

    I gather no help from tokenrove?

    @ computer2,

    Glad you got set up. Nice job.

    Unfortunately I can't update the HOW TO in this thread. They locked us out in May of 2012. All HOW TOs were suppose to be transformed into wiki pages and transferred to the community wiki. The up-datable version of this HOW TO is here.

  10. #530
    Join Date
    Mar 2013

    Re: HOW TO Set Up a Wacom Serial Tablet in Ubuntu

    I tried commenting out the Wacom stylus stuff in xorg.conf but it didn't make a difference.
    The version of xf86-input-wacom that I am using is 0.22.1
    Here is what lsmod shows:
    Module                  Size  Used by
    wacom_serial            5786  0 
    serport                 2767  1 
    usbmon                 20019  0 
    nfnetlink_queue        11322  0 
    nfnetlink_log           8313  0 
    nfnetlink               4301  2 nfnetlink_log,nfnetlink_queue
    nls_utf8                1320  1 
    udf                    78961  1 
    crc_itu_t               1363  1 udf
    fuse                   74541  5 
    ath3k                   7557  0 
    btusb                  18496  0 
    bluetooth             308366  3 ath3k,btusb
    uvcvideo               72761  0 
    pl2303                 12414  1 
    videobuf2_vmalloc       3272  1 uvcvideo
    videobuf2_memops        2335  1 videobuf2_vmalloc
    videobuf2_core         27797  1 uvcvideo
    videodev              105373  2 uvcvideo,videobuf2_core
    usbserial              32697  3 pl2303
    crc16                   1359  1 bluetooth
    arc4                    2000  2 
    nvidia              11246640  52 
    media                  10916  2 uvcvideo,videodev
    ath9k                  88768  0 
    ath9k_common            1991  1 ath9k
    intel_powerclamp        8802  0 
    ath9k_hw              370370  2 ath9k_common,ath9k
    coretemp                6038  0 
    ath                    15681  3 ath9k_common,ath9k,ath9k_hw
    mac80211              455011  1 ath9k
    joydev                  9663  0 
    cfg80211              406112  3 ath,ath9k,mac80211
    kvm_intel             128977  0 
    kvm                   376394  1 kvm_intel
    snd_hda_codec_hdmi     29701  1 
    iTCO_wdt                5407  0 
    iTCO_vendor_support     1929  1 iTCO_wdt
    crc32_pclmul            3019  0 
    asus_nb_wmi             6600  0 
    atl1c                  36674  0 
    snd_hda_codec_via      19814  1 
    ghash_clmulni_intel     4501  0 
    psmouse                85132  0 
    snd_hda_intel          35309  4 
    evdev                   9880  13 
    shpchp                 25489  0 
    i2c_i801               11237  0 
    aesni_intel            46124  0 
    serio_raw               5041  0 
    aes_x86_64              7399  1 aesni_intel
    snd_hda_codec         147506  3 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_intel
    lrw                     3565  1 aesni_intel
    i2c_core               23720  3 i2c_i801,nvidia,videodev
    snd_hwdep               6332  1 snd_hda_codec
    snd_pcm                77765  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
    snd_page_alloc          7234  2 snd_pcm,snd_hda_intel
    snd_timer              18718  1 snd_pcm
    snd                    58950  15 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_via,snd_pcm,snd_hda_codec,snd_hda_intel
    mei_me                  9688  0 
    soundcore               5418  1 snd
    gf128mul                5858  1 lrw
    mei                    61444  1 mei_me
    glue_helper             4609  1 aesni_intel
    ac                      3324  0 
    thermal                 8620  0 
    lpc_ich                12849  0 
    ablk_helper             1972  1 aesni_intel
    cryptd                  8473  3 ghash_clmulni_intel,aesni_intel,ablk_helper
    button                  4669  0 
    battery                 6925  0 
    mperf                   1267  0 
    pcspkr                  2027  0 
    microcode              13172  0 
    processor              27755  0
    vboxnetflt             17612  0
    vboxdrv              1823264  1 vboxnetflt
    nfs                   145074  0
    lockd                  76773  1 nfs
    sunrpc                220799  2 nfs,lockd
    fscache                44575  1 nfs
    asus_wmi               16242  1 asus_nb_wmi
    sparse_keymap           3114  1 asus_wmi
    rfkill                 15666  4 cfg80211,bluetooth,asus_wmi
    wmi                     8283  1 asus_wmi
    video                  11328  1 asus_wmi
    xfs                   784867  1
    libcrc32c               1002  1 xfs
    sr_mod                 14898  1
    sd_mod                 30730  3
    cdrom                  34848  1 sr_mod
    hid_generic             1153  0
    usbhid                 41466  0
    hid                    88502  2 hid_generic,usbhid
    ahci                   22792  3
    libahci                21169  1 ahci
    crc32c_intel           14249  1
    libata                171016  2 ahci,libahci
    ehci_pci                4120  0
    xhci_hcd               89455  0
    scsi_mod              127772  3 libata,sd_mod,sr_mod
    ehci_hcd               47640  1 ehci_pci
    usbcore               177151  10 ath3k,btusb,uvcvideo,usbserial,ehci_hcd,ehci_pci,pl2303,usbhid,usbmon,xhci_hcd
    usb_common              1648  1 usbcore
    The serial to usb converter I am using is a pl2303, and I believe the pl2303 driver
    has support for the Wacom X driver ioctl.
    I don't think xorg or ioctl is the problem. As far as I can tell the driver is requesting
    information from the tablet, but the tablet isn't responding. And since the tablet
    isn't responding xorg can't get the information it needs.
    No I haven't heard anything else from tokenrove, but I might send him another email
    now that I have had a look at the driver.

Page 53 of 56 FirstFirst ... 3435152535455 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts