Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Mobile Broadband not showing in Network Manager...Help needed!!!

  1. #1
    Join Date
    Feb 2009
    Location
    India
    Beans
    13
    Distro
    Ubuntu Studio 11.04 Natty Narwhal

    Angry Mobile Broadband not showing in Network Manager...Help needed!!!

    Hi all!
    I have u usb 3G stick and I configured a mobile broadband connection to connect to the internet.I filled all details and saved the connection.Now I clicked on the network manager icon in top right corner, but there was no connection with the name I just created.Again I checked in edit connections dialog box and found the connection there.Now how do I connect to this newly created connection while there is no option in network manager???
    Please help'
    Thanks in advance.

  2. #2
    Join Date
    May 2011
    Location
    UK
    Beans
    24

    Re: Mobile Broadband not showing in Network Manager...Help needed!!!

    Same problem here but i'm running xubuntu 10.10.

  3. #3
    Join Date
    Dec 2006
    Beans
    124
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Mobile Broadband not showing in Network Manager...Help needed!!!

    I have the exact same problem with a Telia dongle. It worked flawless in 10.10, but not 11.04 :S

    Help very much appreciated
    OpenDungeons a open source game in the style of Dungeon Keeper

  4. #4
    Join Date
    Feb 2009
    Location
    India
    Beans
    13
    Distro
    Ubuntu Studio 11.04 Natty Narwhal

    Re: Mobile Broadband not showing in Network Manager...Help needed!!!

    I have found the reason and a possible solution too.The reason behind is that Ubuntu is unable to recognize your modem and thats why it cant load it.You have noticed it when creating new mobile broadband connection that the option to select device is grayed out, thats cuz ubuntu havent drivers for your modem.Ok now the solution.The solution is for my usb stick which is Micromax mmx350g.Try it with yours:


    I tried my best for not being a die-hard & ardent fan (which I am not certainly) of linux and found a layman's quick-fix solution for this. Sakis-3g is cute little tool that anyone can use on linux. Here are a few steps for installing Sakis-3g.

    Download Sakis-3g from Sakis-3g website directly (thanks to google for providing its kind helping hand).
    I extracted it to my home folder.
    Enter “$ sudo chmod +x sakis3g”
    Enter “$ sudo .//sakis3g helper balloons &”

    Then I connected my Micromax usb modem to my laptop and waited patiently for a miracle to happen. Well nothing strange happened but this brought up a linux trademark holding usb removable disk on the upper panel of my desktop (which I wasnt very happy to see it untill i got really connected). Now sakis3g was working as it popped up message detecting my modem. On clicking the icon it brought up a menu driven tool. Hastily I clicked on “Connect with 3G”
    Voila!!! And I did it. Pretty easy stuff.

    Though I can get connected to internet with good speeds, but still I am too lazy to type that command (which is not always so user-friendly) each and every time I want to access www. I had to get a permanent fix on this problem. With some help from google, I managed figure out some driver fixes that could fix this issue permanently (i.e. Due to my little liking to linux/unix).
    Well, I have worked out few easy steps to get connected to internet (its pretty hard to survive without it). 'Copy-paste' can make things (like shell commands) look bit less creepy.

    I made sure if I have got usb-modeswitch & wvdial packages installed on my system in the 'synaptic pakage manager' from System > Administration drop down menu in the menu bar.

    Still I checked if there was any latest update available for the above listed packages by typing below mentioned commands in my not-so-friendly gnome terminal.
    Enter “$ sudo apt-get install usb-modeswitch”
    Enter “$ sudo apt-get install wvdial”
    Enter “$ watch lsusb”
    And the output showed some crap that resembled something like this
    Bus 002 Device 006: ID 1c9e:f000
    After few seconds it showed
    Bus 002 Device 007: ID 1c9e:9605
    Where, 1c9e is the vendor id and f000 & 9605 are the product ids of the usb modem before and after switching. That is f000 is the default product id & 9605 is the target product id.
    After confirming the outputs, I made some tweaks in usb-modeswitch configuration files as below
    Enter “$ sudo gedit /lib/udev/rules.d/40-usb_modeswitch.rules”
    The file opened in gedit. There I had to enter some text below the line that said
    LABEL="modeswitch_rules_begin"
    It looks something like this :-
    LABEL="modeswitch_rules_begin"
    #Micromax MMX352G USB 3G MODEM
    ATTRS{idVendor}=="1c9e", ATTRS{idProduct}=="9605", RUN+="usb_modeswitch '%b/%k'"
    Had to save and then exit the editor.
    Then I copied the default configuration file to a new configuration file that would help our modem to switch and act like a true modem.
    Enter “$ sudo cp /etc/usb_modeswitch.d/1c9e\:9200 /etc/usb_modeswitch.d/1c9e\:9605”
    Editing one more usb_modeswitch configuration file brought me one step closer to the edge.

    Enter “$ sudo gedit /etc/usb_modeswitch.d/1c9e\:9605”
    Here's the ouput of the file.





    ################################################## ######
    # Micromax MMX 352G USB 3G Modem
    DefaultVendor= 0x1c9e
    DefaultProduct=0x9605
    TargetVendor= 0x1c9e
    TargetProduct= 0x9605
    CheckSuccess=20
    MessageContent="55534243123456780000000000000606f5 0402527000000000000000000000"

    Now finally we have to work out with usbserial module (that is what drivers are referred to in UNIX)

    Enter “$ sudo gedit /etc/modules”
    Add the below mentioned line at the end of the file.
    #MICROMAX 352G 3G USB MODEM
    usbserial vendor=0x1c9e product=0x9605
    Rebooted the machine curiously.


    That is all. Configuration of devices was complete.

    Now, after the machine rebooted, I plugged in the usb modem and waited for around half a minute.

    Back to GUI by clicking on the Network Manager Applet on the top panel, a list of available connections came through a drop down menu.
    Among these I clicked on New Mobile Broadband (GSM) Connection.
    The New Broadband Connection Wizard popped up. Clicked on the “Forward” button.
    I had to select India (Wonderful place where I live). Clicked on “Forward” (Pretty easy).
    Selected “BSNL/Cellone” from the list of service providers. Again a click happened.
    Selected “BSNL/CellOne Old East Zone Prepaid (Jharkhand, Bihar, Kolkata, West Bengal, Orissa, Assam, North East, Adman Nicobar)” from the list of plans that were available and clicked on “Forward” & then “Apply”.
    Connection Configuration window will appear where I selected “Connect Automatically” under Connection Name. Entered “*99#” in front of number and entered “bsnlnet” in front of APN. Finally “Save”.


    Finally, done with all clicking which quite effortless. Nothing seemed to appear for some time, but then automatically the Network Manager Applet selected my configured connection. That is all I had to do. Time to have the sweet fruit of my tireless effort.

    See if this helps!
    Have a nice day

  5. #5
    Join Date
    Dec 2009
    Beans
    4

    Re: Mobile Broadband not showing in Network Manager...Help needed!!!

    I was quite happy with Ubuntu 10 & being a trusting soul I 'upgraded' to 11.04 (after all Ubuntu is now promoted as being so much more user friendly).
    Result? B'all - No internet! My 3G dongle is no longer recognised.
    So back to Win7. I've had enough!
    Ubuntu? It's still for geeks & looks like it always will be.
    What a shame.

    (I note many of the 'experts' that tell you the easy bit 'how to set up a network connection' have just changed their titles from Ubuntu 10 to 11 assuming that plugging in a modem to a usb port will work as before)
    Last edited by AcerLaura; June 5th, 2011 at 12:21 AM.

  6. #6
    Join Date
    Dec 2006
    Beans
    124
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Mobile Broadband not showing in Network Manager...Help needed!!!

    Ok I got it to work I followed this bug-report on Launchpad.

    You just have to plug in the dongle, then run this command
    Code:
    sudo modprobe usbserial vendor=0x12d1 product=0x1506
    then wait about 5-10 seconds until the mobile broadband profile show up in the network connections manager in the top right corner. I can now select it and use the 3G internet

    Only downside is that you have to do this every time you plug in the dongle. Hopefully the ubuntu team will fix this soon, so this is not necessary anymore

    My dongle is a Huawei E367.
    OpenDungeons a open source game in the style of Dungeon Keeper

  7. #7
    Join Date
    Feb 2009
    Location
    India
    Beans
    13
    Distro
    Ubuntu Studio 11.04 Natty Narwhal

    Re: Mobile Broadband not showing in Network Manager...Help needed!!!

    Quote Originally Posted by AcerLaura View Post
    I was quite happy with Ubuntu 10 & being a trusting soul I 'upgraded' to 11.04 (after all Ubuntu is now promoted as being so much more user friendly).
    Result? B'all - No internet! My 3G dongle is no longer recognised.
    So back to Win7. I've had enough!
    Ubuntu? It's still for geeks & looks like it always will be.
    What a shame.

    (I note many of the 'experts' that tell you the easy bit 'how to set up a network connection' have just changed their titles from Ubuntu 10 to 11 assuming that plugging in a modem to a usb port will work as before)
    yeas Ubuntu 10.10 was better than the new one.So I am thinking of downgrading....lol
    This is really a bad thing for ubuntu that the previous version id better than the current one.11.04 also have some booting problems and driver related isssues.Hope all this fixes in Ubuntu 11.10
    Ubuntu team pls do something about this.

  8. #8
    Join Date
    May 2011
    Beans
    10

    Re: Mobile Broadband not showing in Network Manager...Help needed!!!

    just follow the below mentioned link

    http://hashprompt.blogspot.com

  9. #9
    Join Date
    Apr 2011
    Location
    Sweden
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Talking Re: Mobile Broadband not showing in Network Manager...Help needed!!!

    Hi

    Had the same problem on my laptop with 11.04 and E367 Huawei modem

    I solved it this way:

    Wrote a simple script called "huawei":

    #!/bin/sh

    # Script to enable Huawei E367 HDSPA modem i Ubuntu Natty 11.04
    # modem detected as Vendor = 1201 Product = 1506 running DMESG after boot.

    modprobe -r usb_storage
    modprobe -r usbserial
    wait 5
    modprobe usbserial vendor=0x12d1 product=0x1506


    To install your own script, copy it to /etc/init.d, and make it executable.

    sudo cp huawei /etc/init.d
    sudo chmod +x /etc/init.d/huawei


    To make the script run with the*start*argument at the end of the start sequence, and run with the*stop*argument at the beginning of the shutdown sequence:

    sudo update-rc.d huawei defaults 98 02

    98 and 02 are the start and stop sequence numbers respectively. Both are numbers between 00 and 99 and specify how early or late a service is started or killed. If a service is started late, it should be killed early and vice-versa. A good rule of thumb is to make the stop sequence number equal to 100 minus the start sequence number.

    Cold boot, plug the modem after boot will work
    reboot with the modem inserted will work !

    /Mats

  10. #10
    Join Date
    Jun 2011
    Beans
    2

    Re: Mobile Broadband not showing in Network Manager...Help needed!!!

    Hi Mats,
    I have same problem, you know I am also newbie in Ubuntu . I tried to solve it as you did,wrote this script, loaded in terminal and received following message.

    dar@ubuntu:~$ sudo cp /home/dar/Dokumenty/huawei /etc/init.d
    dar@ubuntu:~$ sudo chmod +x /etc/init.d/huawei
    dar@ubuntu:~$ sudo update-rc.d huawei defaults 98 02
    update-rc.d: warning: /etc/init.d/huawei missing LSB information
    update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
    Adding system startup for /etc/init.d/huawei ...
    /etc/rc0.d/K02huawei -> ../init.d/huawei
    /etc/rc1.d/K02huawei -> ../init.d/huawei
    /etc/rc6.d/K02huawei -> ../init.d/huawei
    /etc/rc2.d/S98huawei -> ../init.d/huawei
    /etc/rc3.d/S98huawei -> ../init.d/huawei
    /etc/rc4.d/S98huawei -> ../init.d/huawei
    /etc/rc5.d/S98huawei -> ../init.d/huawei

    Any ideas what to do please?
    i would appreciate any help. Thank you

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •