Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Lucid 10.04.02 Grub no longer discovers DOS partition

  1. #11
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Lucid 10.04.02 Grub no longer discovers DOS partition

    No you do not want to install to sector 0 unless you have just an old DOS drive. Sector 0 is the MBR or Master Boot Record, it is not part of the first partition. And part of that sector is the partition table.

    Too many other bits of software now use the space between sector 1 and the start of the first partition so the start of the first partition can be relocated.

    Windows, I know had to have fixboot run when every you move the start so the boot sector does not match the partition. Simple repairs to your DOS PBR should solve the problem.

    The drive configuration has been the same since DOS thru XP. Only with Vista & Windows 7, did Microsoft redefine the partition boot sector.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  2. #12
    Join Date
    May 2007
    Location
    S. E. Arizona, USA
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Lucid 10.04.02 Grub no longer discovers DOS partition

    Hi oldfred,
    You are correct, and I misspoke. I had in mind the floppy disk format. But my point was that clonezilla should have restored it to the sector from which it came, and it did not do so for some reason. So still, it is a clonezilla problem.
    // Don
    ---------------------------------------------------
    Toshiba P755-S5390 / Core I7 / 8 gigs

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •