Page 5 of 15 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 146

Thread: How to play openGL based games with full 3D acceleration on XGL/compiz

  1. #41
    Join Date
    Jun 2006
    Beans
    10

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    Ok, thanks a lot, i'ts working.
    But now, I don't have sound...

    Any workaround for that ?

  2. #42
    Join Date
    Jun 2006
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    Quote Originally Posted by wakady
    Wooow ATI XGL ON DISPLAY :0
    I tried it yesterday & its amazing i also thought to run XGL on DISPLAY :0 & see if ATI fixed there issue & use tried
    instead of
    & guess what
    IT WORKED as well as the script arnieboy made *thx man great work*
    So the full line i used is


    But still wondering what is -xorgAc do???

    Thanks jakster for the tip

    BTW i'm using ATI RADEON 9600 XT 256

    **PS ONLY WORKS WITH ATI 8.25.18 DRIVER**
    can u explain it in more details how did u manage to work it thanks i also have the latest drivers for ATI
    Laptop:
    Acer Aspire 5672WLMi
    Intel Core Duo T2600 (2.16), 15.4" WXGA, ATI MOBILITY Radeon x1400 128M, RAM 4GB DDR II, 250G SATA Windows 7 + Ubuntu 10.04

  3. #43
    Join Date
    Jun 2006
    Beans
    2

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    Hi,
    the script works fine on radeon 9700 mobile with latest ati driver.

    However, after about 15-20min it seems to crash and I am sended back to gdm to login.
    I am playing WarcraftIII via wine. When I start Warcraft with the script on normal gnome this problem does not ocure.
    I heard that someone from the German forum has a similar porblem. In his case he is sended back to gdm when his screensaver (opengl) starts.

    Any suggestions?

    moi moi
    Last edited by maschbaer; June 25th, 2006 at 12:29 PM.

  4. #44
    Join Date
    Jun 2006
    Location
    ~Rome, Italy
    Beans
    76
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    Hello I just want to say that this script works with me.
    I used it to run powerpointviewer through CrossOver. It has issues with XGL, but I just manages to resolve them:

    Code:
    nano ~/bin/pptviewer
    and then just add the following line:
    Code:
    nonXgl /opt/cxoffice/bin/pptview $1
    (Save it!)

    and then associated pptviewer to the .pps and .ppt extension.

    It works

  5. #45
    Join Date
    Jun 2006
    Beans
    48

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    I don't really understand what I did whilst following the directions given here.. but, Wolf ET launched for the first time since I've had it installed, so I'm happy..

    Also, I just went to Applications > other > wolf et and it works. I didn't launch it with terminal..

    I may or may not be getting 3d acceleration but, at least it runs !! Finally!

  6. #46
    Join Date
    Jun 2006
    Location
    Vienna, Austria
    Beans
    6
    Distro
    Ubuntu 6.06

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    I have just tried it in UT2004, it works but the fps is really, really slow and i have a little graphic error. (Look at the minigun.)


    Screenshot:
    http://img297.imageshack.us/img297/7...ot000039fi.png

  7. #47
    Join Date
    Jun 2006
    Beans
    20

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    Quote Originally Posted by FallenWizard
    I have just tried it in UT2004, it works but the fps is really, really slow and i have a little graphic error. (Look at the minigun.)

    Screenshot:
    http://img297.imageshack.us/img297/7...ot000039fi.png
    How did you install ut2004 so it runs? i have installed it and followed this guide, but the game will not load..

    Code:
    colzybub@colzybub-desktop:~$ nonXgl /vFATPartition/ut2004/ut2004
    non-network local connections being added to access control list
    /usr/bin/nonXgl: /vFATPartition/ut2004/ut2004: /bin/sh: bad interpreter: Permission denied
    /usr/bin/nonXgl: line 15: /vFATPartition/ut2004/ut2004: Success
    im guessing ive installed it wrong, or got permissions messed up? should it work with just "nonXgl ut2004" ?

    the opengl script works anyway, as i can load little opengl games such as some breakout clone (incidentally i had to change the "screen number" to 0 as mentioned earlier in this thread)

    can anyone steer me right ? thanks !

    edit-
    Ive just installed UT (as in the original) as well, but ive got the same problem.
    Code:
    colzybub@colzybub-desktop:~$ nonXgl ut
    non-network local connections being added to access control list
    /usr/bin/nonXgl: /usr/local/bin/ut: /bin/sh: bad interpreter: Permission denied
    /usr/bin/nonXgl: line 15: /usr/local/bin/ut: Success
    but the program does not run, i cant find what to do. help me out please !
    Last edited by Grimmeehh; June 29th, 2006 at 09:39 PM.

  8. #48
    Join Date
    Apr 2006
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    Great guide. Worked perfectly. ut2k4 runs flawlessly with all video options maxed out.

    Thanks,

    gschoper

  9. #49
    Join Date
    Apr 2006
    Beans
    18

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    Work fine for me, but just one problem.

    Is there any way to switch desktop while playing ? ALT+Left/Right Arrow don't seem to work.

  10. #50
    Join Date
    Apr 2006
    Location
    Red Stick, LA
    Beans
    48
    Distro
    Ubuntu 6.06

    Re: How to play openGL based games with full 3D acceleration on XGL/compiz

    This howto was excellent. It got me started on my path to successfully playing Quake on top of XGL without having to log out into a normal GNOME default session each time.

    However, I must point out that this howto did not completely work for me. In order to successfully laun Quake without it shutting down due to segmentation fault, I had to initiate the command
    Code:
    DISPLAY=:0 sudo quake4
    If i am not mistaken, the created scripts should have taken care of that when I typed 'nonXgl quake4' however they did not.

    Also, notice that my XGL uses DISPLAY=:1 .. therefore my games must NOT use display 1.

Page 5 of 15 FirstFirst ... 34567 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •