Results 1 to 10 of 10

Thread: 11.04 2Ghz CPU blocked to 1Ghz

  1. #1
    Join Date
    Sep 2008
    Beans
    10

    11.04 2Ghz CPU blocked to 1Ghz

    Hello,

    I upgraded from 10.10 to 11.04, and noticed that my 2 CPUs, 2Ghz are blocked to 1Ghz :
    cat /proc/cpuinfo :
    model name : Genuine Intel(R) CPU T2500 @ 2.00GHz
    stepping : 8
    cpu MHz : 1000.000
    I tried a /usr/bin/cpufreq-set -c 0 -g performance -u 2000000 (and also with 1670000), but it didn't change anything.

    On 10.10, the two processors were always between 1.67 and 2.00 Ghz.

    Do you have an idea on what could prevent the CPUs from running over 1Ghz?

  2. #2

    Re: 11.04 2Ghz CPU blocked to 1Ghz

    Well that command is just showing the current state
    The name is cpufreq-selector, maybe try
    Code:
    cpufreq-selector -c 0 -g performance

  3. #3
    Join Date
    Sep 2008
    Beans
    10

    Re: 11.04 2Ghz CPU blocked to 1Ghz

    Quote Originally Posted by mc4man View Post
    Code:
    cpufreq-selector -c 0 -g performance
    Thank you, but it didn't change anything :
    Still the same
    model name : Genuine Intel(R) CPU T2500 @ 2.00GHz
    stepping : 8
    cpu MHz : 1000.000

  4. #4
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    20,237
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: 11.04 2Ghz CPU blocked to 1Ghz

    Quote Originally Posted by tof233 View Post
    Thank you, but it didn't change anything :
    Still the same
    model name : Genuine Intel(R) CPU T2500 @ 2.00GHz
    stepping : 8
    cpu MHz : 1000.000
    Hi, it is set so the cpu only shows the max when it is under a load,other wise it stays powered down and saves energy and reduces heat, also the same way windows 7 does it, you can change your power settings but there is no need, it will be there when your system needs it.

  5. #5

    Re: 11.04 2Ghz CPU blocked to 1Ghz

    If you set to performance then /proc/cpuinfo should reflect that.

    One way it won't allow scaling up is if you've hit the scale down threshold, (probably around 99c), then you'll be locked at the min. frequency no matter what the current temp is.

    Have you checked right after boot? The default is to use performance at boot, ondemand kicks in a little bit more than 60 secs after starting the boot.

    (This laptop I'm on last year was hitting scale down during boot so never ran more than min. and never appeared to be overheating, took me a bit to figure out.

    Maybe log in to Classic and set a couple of those panel applets for cpu scaling - see if you can adjust
    Last edited by mc4man; May 24th, 2011 at 12:15 PM.

  6. #6
    Join Date
    Sep 2008
    Beans
    10

    Re: 11.04 2Ghz CPU blocked to 1Ghz

    Quote Originally Posted by wildmanne39 View Post
    Hi, it is set so the cpu only shows the max when it is under a load,other wise it stays powered down and saves energy and reduces heat, also the same way windows 7 does it, you can change your power settings but there is no need, it will be there when your system needs it.
    Thank you Wildmanne39, but isn't it the Ondemand mode?

    Because, for me, the performance mode means that the CPU should stay at full power (unless overheating) http://manpages.ubuntu.com/manpages/...wersave.8.html . Did it changed on 11.04?

    Moreover, I don't believe my processor is so powerful that it never needs to go over 1Ghz : (cpufreq-info)
    Code:
    driver: acpi-cpufreq
      CPUs which run at the same hardware frequency: 1
      CPUs which need to have their frequency coordinated by software: 1
      maximum transition latency: 10.0 us.
      hardware limits: 1000 MHz - 2.00 GHz
      available frequency steps: 2.00 GHz, 1.67 GHz, 1.33 GHz, 1000 MHz
      available cpufreq governors: conservative, ondemand, userspace, powersave, performance
      current policy: frequency should be within 1000 MHz and 1000 MHz.
                      The governor "performance" may decide which speed to use
                      within this range.
      current CPU frequency is 1000 MHz (asserted by call to hardware).
      cpufreq stats: 2.00 GHz:0.00%, 1.67 GHz:0.00%, 1.33 GHz:0.00%, 1000 MHz:100.00%

  7. #7

    Re: 11.04 2Ghz CPU blocked to 1Ghz

    Did you ever to the bottom of this ? It's intriguing !

  8. #8

    Re: 11.04 2Ghz CPU blocked to 1Ghz

    Did it changed on 11.04?
    Not that I see - on 11.04/unity
    Ex.
    cat /proc/cpuinfo
    processor : 0
    vendor_id : GenuineIntel
    cpu family : 6
    model : 15
    model name : Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz
    stepping : 11
    cpu MHz : 800.000
    cache size : 4096 KB

    cpufreq-selector -c 0 -g performance

    cat /proc/cpuinfo
    processor : 0
    vendor_id : GenuineIntel
    cpu family : 6
    model : 15
    model name : Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz
    stepping : 11
    cpu MHz : 2201.000

  9. #9
    Join Date
    Sep 2008
    Beans
    10

    Re: 11.04 2Ghz CPU blocked to 1Ghz

    mc4man : It's also what I had when I was running on Ubuntu 10.10 , and also on an other laptop on 11.04 .

    I will try with a 11.04 LiveCD to see if it's an upgrade problem.

  10. #10
    Join Date
    Sep 2008
    Beans
    10

    Re: 11.04 2Ghz CPU blocked to 1Ghz

    I restart my Laptop and it seems that it fixed the problem.
    Code:
    analyzing CPU 0:
      driver: acpi-cpufreq
      CPUs which run at the same hardware frequency: 0
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency: 10.0 us.
      hardware limits: 1000 MHz - 2.00 GHz
      available frequency steps: 2.00 GHz, 1.67 GHz, 1.33 GHz, 1000 MHz
      available cpufreq governors: conservative, ondemand, userspace, powersave, performance
      current policy: frequency should be within 1000 MHz and 1.67 GHz.
                      The governor "performance" may decide which speed to use
                      within this range.
      current CPU frequency is 1.67 GHz (asserted by call to hardware).
      cpufreq stats: 2.00 GHz:28.24%, 1.67 GHz:3.67%, 1.33 GHz:0.10%, 1000 MHz:67.98%  (495)
    analyzing CPU 1:
      driver: acpi-cpufreq
      CPUs which run at the same hardware frequency: 1
      CPUs which need to have their frequency coordinated by software: 1
      maximum transition latency: 10.0 us.
      hardware limits: 1000 MHz - 2.00 GHz
      available frequency steps: 2.00 GHz, 1.67 GHz, 1.33 GHz, 1000 MHz
      available cpufreq governors: conservative, ondemand, userspace, powersave, performance
      current policy: frequency should be within 1000 MHz and 1.67 GHz.
                      The governor "performance" may decide which speed to use
                      within this range.
      current CPU frequency is 1.67 GHz (asserted by call to hardware).
      cpufreq stats: 2.00 GHz:25.38%, 1.67 GHz:3.61%, 1.33 GHz:0.22%, 1000 MHz:70.78%  (321)
    It's only at 1.67GHz because at 2GHz it overheats.

    I'm sorry. I should have try this f**cking reboot before reporting this problem.
    (I thought I already did it)
    As Dogbert would say : http://www.youtube.com/watch?v=K0RCZBeZQI4 (Shut up and reboot)
    Last edited by tof233; May 24th, 2011 at 01:54 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •