Results 1 to 5 of 5

Thread: Subclipse Integration for Mylyn 3.x (Optional) requires

  1. #1
    Join Date
    Apr 2011
    Beans
    32

    Subclipse Integration for Mylyn 3.x (Optional) requires

    Hi All,
    I had installed eclipse in my ubuntu server 10.10 and it is working fine but while trying to install eclipse subversion, i got a error that can't complete the install.
    I clicked the menu HELP > Install new software and added the link Subclipse_1.6.x - http://subclipse.tigris.org/update_1.6.x then i got core SVNkit library, Optional JNA library and subclipse to install, then i marked all the three items and proceed to NEXT, after that it shows error like this.....

    Cannot complete the install because one or more required items could not be found.
    Software being installed: Subclipse Integration for Mylyn 3.x (Optional) 3.0.0 (org.tigris.subversion.subclipse.mylyn.feature.gro up 3.0.0)
    Missing requirement: Subclipse Integration for Mylyn 3.x (Optional) 3.0.0 (org.tigris.subversion.subclipse.mylyn.feature.gro up 3.0.0) requires 'org.eclipse.mylyn.tasks.core [3.0.0,4.0.0)' but it could not be found
    Anyone help me to fix this issue..


    Thanks

  2. #2
    Join Date
    Apr 2011
    Beans
    32

    Re: Subclipse Integration for Mylyn 3.x (Optional) requires

    I un-marked the Mylyn and installed other components but after installing subversion, svn perspective is not present in the WINDOW > Show view > other and also in WINDOW > Open perspective > other. I think plugins are not installed but i dont know the actual cause for this issue.

    Anybody suggest me to fix this issue.



    Thanks
    Last edited by thoufiq; May 24th, 2011 at 09:53 AM.

  3. #3
    Join Date
    Apr 2011
    Beans
    32

    Re: Subclipse Integration for Mylyn 3.x (Optional) requires

    Anybody help me........



    Thanks

  4. #4
    Join Date
    Nov 2011
    Beans
    1

    Re: Subclipse Integration for Mylyn 3.x (Optional) requires

    Hi,

    i know its an old thread, but i think there are many others who are searching for a solution to this problem:
    First of all the following line shows that there is a dependency which has to be fulfilled:
    requires 'org.eclipse.mylyn.tasks.core [3.0.0,4.0.0)' but it could not be found
    In order to get the required packages you have to enable the Mylyn update site by simply adding it in the "Install New Software" dialogue and select "Contact all update sites..." while installing Subclipse.
    The Mylyn update site is located here:
    http://download.eclipse.org/mylyn/releases/latest

    After that a new dependency occurs:
    requires 'org.eclipse.draw2d 3.2.0' but it could not be found
    Same solution as above: Add the following update site: http://download.eclipse.org/tools/gef/updates/releases/

    Best Regards

    subclipse

    Links to the sites that helped me solve this problem:
    http://www.eclipse.org/forums/index.php/m/752575/
    https://aptanastudio.tenderapp.com/d...lation-problem
    Last edited by subclipse; November 15th, 2011 at 07:25 PM.

  5. #5
    Join Date
    Feb 2007
    Location
    Portugal
    Beans
    216
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Subclipse Integration for Mylyn 3.x (Optional) requires

    Quote Originally Posted by subclipse View Post
    Hi,

    i know its an old thread, but i think there are many others who are searching for a solution to this problem:
    First of all the following line shows that there is a dependency which has to be fulfilled:
    In order to get the required packages you have to enable the Mylyn update site by simply adding it in the "Install New Software" dialogue and select "Contact all update sites..." while installing Subclipse.
    The Mylyn update site is located here:
    http://download.eclipse.org/mylyn/releases/latest

    After that a new dependency occurs:
    Same solution as above: Add the following update site: http://download.eclipse.org/tools/gef/updates/releases/

    Best Regards

    subclipse

    Links to the sites that helped me solve this problem:
    http://www.eclipse.org/forums/index.php/m/752575/
    https://aptanastudio.tenderapp.com/d...lation-problem
    thanks... it worked for me

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •