Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 44

Thread: Dell XPS15 L502X - Noob's way for Optimus issue

  1. #11
    Join Date
    Jun 2006
    Location
    netherlands
    Beans
    198
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Dell XPS15 L502X - Noob's way for Optimus issue

    Quote Originally Posted by pszafer View Post
    @bro
    About battery life I cannot save as much as You need, but I got 9-cell battery and XPS15 is working about 5 hours on Ubuntu.
    On Windows I've almost not working but battery indicator shows 7 hours.
    In my case main problem and probably main place to find most power consumption is hard drive.
    It got 46 degrees (Celcius), but case is really hot in left hand area.
    If I have only integrated graphics enabled it estimates my battery time serveral hours longer then with optimus/bumblebee. This made me believe that it is not properly shutting down the nvidia card. Ideally the battery time should be the same (unless I start an application as optirun64)

    I'm a bit disappointed/curious about the fact that nobody seems able to explain the workings and configurations of the bumblebee-disablecard file. Also it seems impossible to just 'check' if the card is shutdown. Or, for example, to give command to shut it down.
    We seek to resolve frustration and abide in a comfortable, relaxed mind. We call that 'happiness'. And still I believe in that next upgrade...
    --dell xps m1330 t9300 2.5ghz 4gb 320Gb Nvidia 8400m gs--
    --lenovo w520 2720QM 8Gb Nvidia Quadro 1000

  2. #12
    Join Date
    Apr 2011
    Beans
    17

    Re: Dell XPS15 L502X - Noob's way for Optimus issue

    Quote Originally Posted by bro View Post
    If I have only integrated graphics enabled it estimates my battery time serveral hours longer then with optimus/bumblebee. This made me believe that it is not properly shutting down the nvidia card. Ideally the battery time should be the same (unless I start an application as optirun64)

    I'm a bit disappointed/curious about the fact that nobody seems able to explain the workings and configurations of the bumblebee-disablecard file. Also it seems impossible to just 'check' if the card is shutdown. Or, for example, to give command to shut it down.
    You talking about bumblebee only, not acpi_call, am I right?

    If yes tomorrow I will install bumblebee again and write enablecard/disablecard scripts here and whole instruction to got it working. Of course if everything will be working

  3. #13
    Join Date
    Jun 2006
    Location
    netherlands
    Beans
    198
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Dell XPS15 L502X - Noob's way for Optimus issue

    That would be grand

    I got acpi_call installed. This seemed needed to configure the enable/disable stuff.
    We seek to resolve frustration and abide in a comfortable, relaxed mind. We call that 'happiness'. And still I believe in that next upgrade...
    --dell xps m1330 t9300 2.5ghz 4gb 320Gb Nvidia 8400m gs--
    --lenovo w520 2720QM 8Gb Nvidia Quadro 1000

  4. #14
    Join Date
    Jan 2010
    Location
    India
    Beans
    42
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Talking Re: Dell XPS15 L502X - Noob's way for Optimus issue

    @pszafer : You are an angel!!!!!!! Thanks a million, bro!

    Meanwhile, I'll mark this thread solved. Do post(or link to) updates...Thanks again!

    PS : @bro Pls do continue the discussion. I too am checking workarounds.

  5. #15
    Join Date
    Mar 2010
    Location
    Ohio
    Beans
    465
    Distro
    Kubuntu

    Re: Dell XPS15 L502X - Noob's way for Optimus issue

    Quote Originally Posted by pszafer View Post
    @Ranko Kohime
    give me output of:
    lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA

    and do You have windows installed on Your laptop?
    Following is the output of the command, though I should mention that several reboots later, the Nvidia card is now back in "lspci", and so I'm good again. It seems like, if I enable the acpi_call bit, after a reboot the card disappears from "lscpi", but going by the lights on the laptop, the card turns back on at reboot time. After the second, or perhaps third reboot, the card reappears.

    It doesn't seem to disappear after running the test_off.sh script, only after rebooting. My next test will involve switching the OFF to ON in a new script, and running that prior to reboot.

    Code:
    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 07) (prog-if 00 [VGA controller])
    01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:0df4] (rev ff) (prog-if ff)
    As for Windows, no. I bought it as a barebones, and assembled myself, if it could called assembly. (Just hard drives, processor and RAM, really).

  6. #16
    Join Date
    Apr 2011
    Beans
    17

    Re: Dell XPS15 L502X - Noob's way for Optimus issue

    @asn_knight
    Sorry, I forgot to call switching off acpi:
    So You got this test_off.sh in acpi_call dir.
    Add it to startup programs:
    Go to:
    Code:
    System -> Preferences -> Startup/Autostart programs (I don't use English language in Ubuntu so it translations, could be little different).
    Click Add:
    Code:
    Name - ACPI OFF
    Command - ~/acpi_call/test_off.sh
    Add and now everything is ok.

    @bro

    Do everything from my last instruction:
    http://ubuntuforums.org/showpost.php...2&postcount=10

    Don't add this to startup programs.

    Do this (in terminal):
    0. We had to have Intel graphic card working (my first post in this thread)
    1. We need root right so:
    Code:
    sudo -s, enter password
    2. To be sure copy xorg.conf:
    Code:
    cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old
    3. Download bumblebee:
    Code:
    cd ~
    git clone https://github.com/MrMEEE/bumblebee.git
    4. Install it
    Code:
    cd bumblebee
    ./install.sh
    5. Go to /usr/local/bin/
    Code:
    cd /usr/local/bin/
    6. Edit bumblebee-enablecard and disablecard (based on http://ubuntuforums.org/showpost.php...4&postcount=66)
    Code:
    nano bumblebee-enablecard

    #!/bin/bash
    modprobe acpi_call

    if ! lsmod | grep -q acpi_call; then
    echo "Error: acpi_call module not loaded"
    exit
    fi

    acpi_call () {
    echo "\_SB.PCI0.PEG0.PEGP._ON" > /proc/acpi/call
    result=$(cat /proc/acpi/call)
    case "$result" in
    Error*)
    echo "Enabling nVidia Card failed ($result)."
    ;;
    *)
    echo "Enabling nVidia Card Succeded."
    ;;
    esac
    }

    acpi_call
    modprobe nvidia-current
    7. Time for bumblebee-disablecard:
    Code:
    nano bumblebee-disablecard

    modprobe acpi_call
    rmmod nvidia
    if ! lsmod | grep -q acpi_call; then
    echo "Error: acpi_call module not loaded"
    exit
    fi

    acpi_call () {
    echo "\_SB.PCI0.PEG0.PEGP._OFF" > /proc/acpi/call

    result=$(cat /proc/acpi/call)
    case "$result" in
    Error*)
    echo "Disabling nVidia Card failed ($result)."
    ;;
    *)
    echo "Disabling nVidia Card Succeded."
    ;;
    esac
    }

    acpi_call
    Hope everything will be great.
    Now add bumblebee-disablecard to startup programs (similar as test_off.sh)

    And now if You run command with optirun/optirun64 application it would enable nvidia, after proper close application it should disable nvidia card.
    Everything for now!

  7. #17
    Join Date
    Jun 2006
    Location
    netherlands
    Beans
    198
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Dell XPS15 L502X - Noob's way for Optimus issue

    Thanks,

    My bumblebee-disablecard file now looks like this:

    Code:
    #!/bin/bash
    rmmod nvidia
    modprobe acpi_call
    
    if ! lsmod | grep -q acpi_call; then
        echo "Error: acpi_call module not loaded"
        exit
    fi
    
    acpi_call () {
        echo "$*" > /proc/acpi/call
        cat /proc/acpi/call
    }
    
    echo NVOP $(acpi_call "\_SB.PCI0.LPC.EC.PUBS._OFF 0 0x100 0x1A {255,255,255,255}")
    echo _PS3 $(acpi_call "\_SB.PCI0.LPC.EC.PUBS._OFF")
    I could change it to your version, but I doubt that makes a difference, unless you mean for me not to use \_SB.PCI0.LPC.EC.PUBS._OFF but your code instead.

    Right now it seems to work, but safes nothing on the battery.
    We seek to resolve frustration and abide in a comfortable, relaxed mind. We call that 'happiness'. And still I believe in that next upgrade...
    --dell xps m1330 t9300 2.5ghz 4gb 320Gb Nvidia 8400m gs--
    --lenovo w520 2720QM 8Gb Nvidia Quadro 1000

  8. #18
    Join Date
    Apr 2011
    Beans
    17

    Re: Dell XPS15 L502X - Noob's way for Optimus issue

    Yes, of course You call wrong acpi method

    For L502X You have to call \_SB.PCI0.PEG0.PEGP ON/OFF method.

  9. #19
    Join Date
    Jun 2006
    Location
    netherlands
    Beans
    198
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Dell XPS15 L502X - Noob's way for Optimus issue

    Did I mention I have a --lenovo w520 2720QM 8Gb Nvidia Quadro 1000
    We seek to resolve frustration and abide in a comfortable, relaxed mind. We call that 'happiness'. And still I believe in that next upgrade...
    --dell xps m1330 t9300 2.5ghz 4gb 320Gb Nvidia 8400m gs--
    --lenovo w520 2720QM 8Gb Nvidia Quadro 1000

  10. #20
    Join Date
    Apr 2011
    Beans
    17

    Re: Dell XPS15 L502X - Noob's way for Optimus issue

    not at all ,

    If You don't know if this command is working with Your laptop:
    1. I assume You have loaded acpi_call module (sudo insmod acpi_call).
    2. Now do it from terminal:
    Code:
    echo "\_SB.PCI0.LPC.EC.PUBS._OFF" > /proc/acpi/call
    cat /proc/acpi/call
    And result of cat is answer if this method is working for your model.

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •