Results 1 to 3 of 3

Thread: Wamp server 1045 error can't login into phpmyadmin

  1. #1
    Join Date
    Apr 2011
    Beans
    35

    Wamp server 1045 error can't login into phpmyadmin

    Hello everyone


    My wamp server is working fine, i can access everything on it. However, the people working in the network, then they type their username and password at the phpmyadmin page, they can't acess it.

    The error is the infamous #1045 error can't login into phpMYadmin#(it doesn't say anything about passwords or denied accesses, just what i wrote)


    I already configured the phpmyadmin.conf alias to allow the ip of the person that i'm testing this with, and still nothing.


    Alias /phpmyadmin "c:/wamp/apps/phpmyadmin3.3.9/"

    # to give access to phpmyadmin from outside
    # replace the lines
    #
    # Order Deny,Allow
    # Deny from all
    # Allow from 127.0.0.1
    #
    # by
    #
    # Order Allow,Deny
    # Allow from all
    #

    <Directory "c:/wamp/apps/phpmyadmin3.3.9/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1
    Allow from 10.64.46.20 ---------------------> Mine
    Allow from 10.64.46.29 --------------------> My colleague's IP address.
    </Directory>



    I've search all over the internet and nothing. There are many solutions(even if in practice only 2 or 3 work) when the error is:

    1045 error - access denied for user@blabla


    But it's not the case here, and i can login just fine.


    Any ideas guys?

  2. #2
    Join Date
    Apr 2011
    Beans
    35

    Re: Wamp server 1045 error can't login into phpmyadmin

    Actually, the error is #1045 Cannot log in to the MySQL server



    I can login just fine but not my colleague

  3. #3
    Join Date
    Jul 2006
    Location
    USA
    Beans
    277
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wamp server 1045 error can't login into phpmyadmin

    Change the file content of c:\wamp\alias\phpmyadmin.conf to the following:

    Code:
    <Directory "c:/wamp/apps/phpmyadmin3.4.5/">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride all
            Order Deny,Allow
            Allow from all
    </Directory>
    You most likely have
    Code:
    Deny from all
        Allow from 127.0.0.1
    , which was most likely caused when you made your WAMP server go online.
    Yeah I know pirated copy of XP is free, but so is Ubuntu and it's LEGAL!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •