Results 1 to 5 of 5

Thread: nvidia-xconfig not found?

  1. #1
    Join Date
    Apr 2008

    Question nvidia-xconfig not found?

    I'm running 10.04 .

    I was having issues with the nvidia driver, and in the process
    of adding/removing packages, I seem to have lost the binary "nvidia-xconfig".
    Every set of instructions out there says "run nvidia-xconfig",
    but I can't seem to find the dang binary! I've searched
    synaptic, etc. to no avail.

    Which package provides "nvidia-xconfig" ?? Can somebody please
    point me to it??

    This is very frustrating.

  2. #2
    Join Date
    Aug 2006
    Ubuntu 14.04 Trusty Tahr

    Re: nvidia-xconfig not found?

    There is no such package in the repositories. I believe it's part of the proprietary driver, so install the driver first, then run nvidia-xconfig.

  3. #3
    Join Date
    Apr 2008

    Re: nvidia-xconfig not found?

    But I have "nvidia-current" and "nvidia-settings" installed.

    From what I have read, I just need to do the following
    to get the nvidia driver working:

    sudo apt-get update
    sudo apt-get install nvidia-current nvidia-settings
    sudo nvidia-xconfig
    sudo reboot
    I have tried the above, and I keep getting the error:
    Failed to load module "nvidia": module does not exist

  4. #4
    Join Date
    Apr 2008

    Re: nvidia-xconfig not found?

    After trying every combination of nvidia packages around, I gave up and downloaded the driver from NVidia directly.

    One command, "./", and I was all set.

  5. #5
    Join Date
    Jan 2009
    Kubuntu 10.04 Lucid Lynx

    Re: nvidia-xconfig not found?

    The same happened to me... while trying to uninstall the nvidia drivers, I inadvertadly uninstalled more than I should, and lost the "nvidia-xconfig" command...

    After searching like a crazy, it got fixed, although I don't know exactly what was the package that got it back.

    What I did in the process was:
     sudo apt-get install nvidia-va-driver
     sudo apt-get install libva-glx1
     sudo jockey-gtk
     # and installed the proprietary nvidia drivers
     # reboot
     # and I then noticed that I got back nvidia-xconfig
    so some of these must have fixed it... libva-glx1 is not probably the one, so that leaves nvidia-va-driver as the main suspect

    Hope it helps someone who falls into such a deep hole as I was

    NOTE: this gets cloudier, but an explanation surely exists
    I found this article explaining how to discover which deb-package contains a specific file.
    So I used it, and found that "nvidia-xconfig" comes inside the package "nvidia-current"
    The thing is that I already had that package installed and even so "nvidia-xconfig" was not available... maybe "nvidia-xconfig" is only installed if some conditions are met,don't know...
    Although I apport no clarity to the solution of the question, I hope someone can unriddle all this, for the benefit of others

    The correct way to install nvidia drivers in ubuntu is explained here: So if you don't mess around before reading this (as I did) you will probably be just fine, and everything will work out nicely



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts