Results 1 to 10 of 10

Thread: Help editing /etc/default/grub/

  1. #1
    Join Date
    Apr 2011
    Beans
    22

    Help editing /etc/default/grub/

    Hello all,

    I am trying to get my newly installed 11.04 to boot past an issue with a black screen and I am unable to follow some instructions, please could some one show me how.

    The instructions are "Finally, it looks like acpi is mucking things up with the latest kernel for me: The options "ro acpi=off nosplash text" can consistently get me booted to a terminal. Then from the terminal "sudo service start gdm" gets to the gdm logon screen. On the logon screen I must choose "classic (no effects)" and then I can get to gnome." (http://ubuntuforums.org/showpost.php...9&postcount=23)

    I am able to get to a tty terminal and the grub command line but that is it. Can you advice on how I can edit the /etc/default/grub which is aparenltly what I need to do.

    Thanks in advanced.

  2. #2
    Join Date
    Jan 2008
    Location
    Manchester UK
    Beans
    13,657
    Distro
    Ubuntu

    Re: Help editing /etc/default/grub/

    Code:
    sudo nano /etc/default/grub
    When you are done press Ctrl-O to save then Ctrl-X to exit.

    Then
    Code:
    sudo update-grub

  3. #3
    Join Date
    Apr 2011
    Beans
    22

    Re: Help editing /etc/default/grub/

    Quote Originally Posted by nothingspecial View Post
    Code:
    sudo nano /etc/default/grub
    When you are done press Ctrl-O to save then Ctrl-X to exit.

    Then
    Code:
    sudo update-grub
    Thank you for the help but this has not seemed to fix my issue. If you could help me follow the specific instructions id apriceate it. Basicly I have added to the bottom of the grub file "ro acpi=off nosplash text" but nothing seems to have changed. Do you understand the instructions better than I do?

  4. #4
    Join Date
    Apr 2005
    Beans
    603
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Help editing /etc/default/grub/

    My /etc/default/grub file has this line in it:

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    Look for that line. It may not have "quiet splash" in it. But either way replace "quiet splash" (or whatever yours says) with "ro acpi=off nosplash text"

  5. #5
    Join Date
    Apr 2011
    Beans
    22

    Re: Help editing /etc/default/grub/

    Quote Originally Posted by compmodder26 View Post
    My /etc/default/grub file has this line in it:

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    Look for that line. It may not have "quiet splash" in it. But either way replace "quiet splash" (or whatever yours says) with "ro acpi=off nosplash text"
    Thanks for the help I made the changes above but get no diffrence when I boot. Should I expect to now boot into a terminal? I can access the recovery mode from the GRUB menu and can get into the option "root - Drop to a root shell prompt" is that what I need to be in to follow these instructions?

    Would this be better asked in the above thread? That thread seems far too advanced for my level of linux expirence.

  6. #6
    Join Date
    Apr 2005
    Beans
    603
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Help editing /etc/default/grub/

    After editing the file did you run the following?

    Code:
    sudo update-grub

  7. #7
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Help editing /etc/default/grub/

    In your case, the line should look as follows after editing:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="acpi=off nosplash text"
    Don't forget to save and exit with ctrl-o and ctrl-x.

    When done, run sudo update-grub, and then sudo reboot.

  8. #8
    Join Date
    Apr 2011
    Beans
    22

    Re: Help editing /etc/default/grub/

    Quote Originally Posted by compmodder26 View Post
    After editing the file did you run the following?

    Code:
    sudo update-grub
    The following comes up when I try to run the above command: "/etc/default/grub : 36: nosplash: not found"

  9. #9
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Help editing /etc/default/grub/

    Have you tried omitting nosplash?

  10. #10
    Join Date
    Apr 2011
    Beans
    22

    Re: Help editing /etc/default/grub/

    Quote Originally Posted by mikewhatever View Post
    Have you tried omitting nosplash?
    Yes with no luck. Seeing as how my latest error seems to be having little replys I have chossen to compleatly downgrade to 10.04 untill I can find a solution. Thank you for you help though.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •