Results 1 to 3 of 3

Thread: Clang and Clang++

  1. #1
    Join Date
    May 2011
    Beans
    5

    Clang and Clang++

    Wasn't sure who to address, clang or Ubuntu. I figured to address Ubuntu since it works on my other Operating Systems. Since 11.04 Natty, the current clang package that Ubuntu packaged is outdated.

    There is C++ 4.5.2 and the current version cannot find the header files


    End of search list.
    Hello.cpp:2:10: fatal error: 'iostream' file not found
    #include <iostream>
    ^
    1 error generated.

    if you run clang++ -v filename.cpp it will show you where its trying to find the header files... and they dont exist on my machine since my machine only has 4.5 and 4.5.2


    This has nothing to do with system specs or configurations because I've tried it with different machines, and Ive installed the package the debian packaged version on my other machine and that works fine. It worked fine in 10.10.

  2. #2
    Join Date
    May 2008
    Beans
    15

    Re: Clang and Clang++

    I did a new installation of Ubuntu 11.04 and have the same problem. Clang and not found header files.

    I think there is clang community is aware of this issue an there is a patch:

    http://comments.gmane.org/gmane.comp...ng.devel/14609

    but it's not in Ubuntu yet.

  3. #3
    Join Date
    Oct 2009
    Beans
    1

    Re: Clang and Clang++

    As a workaround you can fix this by creating a symbolic link:

    Code:
    sudo ln -s /usr/include/c++/4.5 /usr/include/c++/4.4
    This will allow clang to find the headers.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •