Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Could not Initialize package information

  1. #1
    Join Date
    Jun 2010
    Beans
    17
    Distro
    Ubuntu 11.04 Natty Narwhal

    Could not Initialize package information

    Greetings.

    Today, on Ubuntu 11.04, when attempting to update, this error message appeared in update-manager:


    Code:
    An unresolvable problem occurred while initializing the package information.
    
    Please report this bug against the 'update-manager' package and include the following error message:
    
    'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages, E:The package lists or status file could not be parsed or opened.

    The same appears in Terminal upon sudo apt-get update/upgrade:

    Code:
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
    E: The package lists or status file could not be parsed or opened.

    Would anyone please suggest what the solution to this issue may be?
    Last edited by pavlovgg; May 11th, 2011 at 06:11 AM.

  2. #2
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    11,601
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: Could not Initialize package information

    What exactly did you enter into the terminal? Have you tried booting the machine and running

    Code:
    sudo apt-get clean
    sudo apt-get update
    sudo apt-get upgrade
    ?
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  3. #3
    Join Date
    Jun 2010
    Beans
    17
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Could not Initialize package information

    Quote Originally Posted by mrgs View Post
    What exactly did you enter into the terminal? Have you tried booting the machine and running

    Code:
    sudo apt-get clean
    sudo apt-get update
    sudo apt-get upgrade
    ?

    Greetings. Thank you for the reply. Here is what I get

    Code:
    georgi@Georgi:~$ sudo apt-get clean
    [sudo] password for georgi: 
    georgi@Georgi:~$ sudo apt-get update
    Ign http://extras.ubuntu.com natty InRelease
    Ign http://archive.ubuntu.com natty InRelease
    Ign http://archive.ubuntu.com natty-security InRelease
    Ign http://archive.ubuntu.com natty-updates InRelease
    Get:1 http://extras.ubuntu.com natty Release.gpg [72 B]
    Ign http://archive.ubuntu.com natty-proposed InRelease
    Hit http://archive.ubuntu.com natty Release.gpg
    Hit http://extras.ubuntu.com natty Release
    Hit http://archive.ubuntu.com natty-security Release.gpg
    Get:2 http://archive.ubuntu.com natty-updates Release.gpg [198 B]
    Get:3 http://archive.ubuntu.com natty-proposed Release.gpg [198 B]
    Hit http://extras.ubuntu.com natty/main Sources
    Hit http://archive.ubuntu.com natty Release    
    Hit http://archive.ubuntu.com natty-security Release
    Hit http://extras.ubuntu.com natty/main i386 Packages                 
    Ign http://extras.ubuntu.com natty/main TranslationIndex
    Get:4 http://archive.ubuntu.com natty-updates Release [27.2 kB]
    Get:5 http://archive.ubuntu.com natty-proposed Release [27.2 kB]
    Hit http://archive.ubuntu.com natty/main Sources                               
    Hit http://archive.ubuntu.com natty/restricted Sources
    Hit http://archive.ubuntu.com natty/universe Sources
    Hit http://archive.ubuntu.com natty/multiverse Sources
    Hit http://archive.ubuntu.com natty/main i386 Packages
    Hit http://archive.ubuntu.com natty/restricted i386 Packages
    Hit http://archive.ubuntu.com natty/universe i386 Packages
    Hit http://archive.ubuntu.com natty/multiverse i386 Packages
    Ign http://extras.ubuntu.com natty/main Translation-en_US
    Ign http://extras.ubuntu.com natty/main Translation-en
    Ign http://archive.ubuntu.com natty/main TranslationIndex
    Ign http://archive.ubuntu.com natty/multiverse TranslationIndex
    Ign http://archive.ubuntu.com natty/restricted TranslationIndex
    Ign http://archive.ubuntu.com natty/universe TranslationIndex
    Hit http://archive.ubuntu.com natty-security/main Sources
    Hit http://archive.ubuntu.com natty-security/restricted Sources
    Hit http://archive.ubuntu.com natty-security/universe Sources
    Hit http://archive.ubuntu.com natty-security/multiverse Sources
    Hit http://archive.ubuntu.com natty-security/main i386 Packages
    Hit http://archive.ubuntu.com natty-security/restricted i386 Packages
    Hit http://archive.ubuntu.com natty-security/universe i386 Packages
    Hit http://archive.ubuntu.com natty-security/multiverse i386 Packages
    Ign http://archive.ubuntu.com natty-security/main TranslationIndex
    Ign http://archive.ubuntu.com natty-security/multiverse TranslationIndex
    Ign http://archive.ubuntu.com natty-security/restricted TranslationIndex
    Ign http://archive.ubuntu.com natty-security/universe TranslationIndex
    Get:6 http://archive.ubuntu.com natty-updates/restricted i386 Packages [14 B]
    Get:7 http://archive.ubuntu.com natty-updates/main i386 Packages [73.5 kB]
    Get:8 http://archive.ubuntu.com natty-updates/multiverse i386 Packages [14 B]
    Get:9 http://archive.ubuntu.com natty-updates/universe i386 Packages [26.9 kB]
    Ign http://archive.ubuntu.com natty-updates/main TranslationIndex
    Ign http://archive.ubuntu.com natty-updates/multiverse TranslationIndex
    Ign http://archive.ubuntu.com natty-updates/restricted TranslationIndex
    Ign http://archive.ubuntu.com natty-updates/universe TranslationIndex
    Get:10 http://archive.ubuntu.com natty-proposed/restricted i386 Packages [14 B]
    Get:11 http://archive.ubuntu.com natty-proposed/main i386 Packages [60.3 kB]
    Get:12 http://archive.ubuntu.com natty-proposed/multiverse i386 Packages [2,217 B]
    Get:13 http://archive.ubuntu.com natty-proposed/universe i386 Packages [22.0 kB]
    Ign http://archive.ubuntu.com natty-proposed/main TranslationIndex
    Ign http://archive.ubuntu.com natty-proposed/multiverse TranslationIndex
    Ign http://archive.ubuntu.com natty-proposed/restricted TranslationIndex
    Ign http://archive.ubuntu.com natty-proposed/universe TranslationIndex
    Ign http://archive.ubuntu.com natty/main Translation-en_US
    Ign http://archive.ubuntu.com natty/main Translation-en
    Ign http://archive.ubuntu.com natty/multiverse Translation-en_US
    Ign http://archive.ubuntu.com natty/multiverse Translation-en
    Ign http://archive.ubuntu.com natty/restricted Translation-en_US
    Ign http://archive.ubuntu.com natty/restricted Translation-en
    Ign http://archive.ubuntu.com natty/universe Translation-en_US
    Ign http://archive.ubuntu.com natty/universe Translation-en
    Ign http://archive.ubuntu.com natty-security/main Translation-en_US
    Ign http://archive.ubuntu.com natty-security/main Translation-en
    Ign http://archive.ubuntu.com natty-security/multiverse Translation-en_US
    Ign http://archive.ubuntu.com natty-security/multiverse Translation-en
    Ign http://archive.ubuntu.com natty-security/restricted Translation-en_US
    Ign http://archive.ubuntu.com natty-security/restricted Translation-en
    Ign http://archive.ubuntu.com natty-security/universe Translation-en_US
    Ign http://archive.ubuntu.com natty-security/universe Translation-en
    Ign http://archive.ubuntu.com natty-updates/main Translation-en_US
    Ign http://archive.ubuntu.com natty-updates/main Translation-en
    Ign http://archive.ubuntu.com natty-updates/multiverse Translation-en_US
    Ign http://archive.ubuntu.com natty-updates/multiverse Translation-en
    Ign http://archive.ubuntu.com natty-updates/restricted Translation-en_US
    Ign http://archive.ubuntu.com natty-updates/restricted Translation-en
    Ign http://archive.ubuntu.com natty-updates/universe Translation-en_US
    Ign http://archive.ubuntu.com natty-updates/universe Translation-en
    Ign http://archive.ubuntu.com natty-proposed/main Translation-en_US
    Ign http://archive.ubuntu.com natty-proposed/main Translation-en
    Ign http://archive.ubuntu.com natty-proposed/multiverse Translation-en_US
    Ign http://archive.ubuntu.com natty-proposed/multiverse Translation-en
    Ign http://archive.ubuntu.com natty-proposed/restricted Translation-en_US
    Ign http://archive.ubuntu.com natty-proposed/restricted Translation-en
    Ign http://archive.ubuntu.com natty-proposed/universe Translation-en_US
    Ign http://archive.ubuntu.com natty-proposed/universe Translation-en
    Fetched 240 kB in 5s (44.1 kB/s)
    Reading package lists... Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
    E: The package lists or status file could not be parsed or opened.
    georgi@Georgi:~$ sudo apt-get upgrade
    Reading package lists... Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
    E: The package lists or status file could not be parsed or opened.
    georgi@Georgi:~$

  4. #4
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    11,601
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: Could not Initialize package information

    Try this:

    Code:
    sudo rm /var/lib/apt/lists/* -vf
    followed by the three commands above.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  5. #5
    Join Date
    Jun 2010
    Beans
    17
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Could not Initialize package information

    Thank you sir. It all seems to be working now.
    Thank you.

  6. #6
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    11,601
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: Could not Initialize package information

    You are welcome. Please mark the thread 'solved'.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  7. #7
    Join Date
    Mar 2010
    Beans
    5

    Re: Could not Initialize package information

    I love the forums thank you!

  8. #8
    Join Date
    Jun 2011
    Beans
    1

    Re: Could not Initialize package information

    I only needed to run sudo rm /var/lib/apt/lists/* -vf in the terminal to get updates working, thanks heaps

  9. #9
    Join Date
    Nov 2008
    Location
    Jharkhand (India)
    Beans
    3
    Distro
    Xubuntu 8.04 Hardy Heron

    Thumbs down Re: Could not Initialize package information

    Quote Originally Posted by kiwibunt View Post
    I only needed to run sudo rm /var/lib/apt/lists/* -vf in the terminal to get updates working, thanks heaps
    thanks man it worked for me too......

  10. #10
    Join Date
    Aug 2011
    Beans
    8

    Re: Could not Initialize package information

    Does not work for me...I get
    rm: cannot remove `/var/lib/apt/lists/partial': Is a directory

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •