Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Chromium wont become default browser

  1. #1
    Join Date
    May 2011
    Beans
    17
    Distro
    Ubuntu 11.04 Natty Narwhal

    Chromium wont become default browser

    I installed chromium through the software center but every time I open it up it reminds me that it is not the default browser. I click "make default" every time but my computer still makes firefox the default browser. How do I change this??

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    389
    Distro
    Ubuntu

    Re: Chromium wont become default browser

    Changing the setting in System Settings>Preferred Applications may work.

  3. #3
    Join Date
    Oct 2009
    Location
    Upminster, Essex, UK
    Beans
    544

    Thumbs down Re: Chromium wont become default browser

    If you have both firefox and Chromium to "check whether X is default" you will keep yo-yo-ing between the 2 and the ubuntu "set default app" will not be able to override either as far as I can tell.

    Make sure the tick boxes are not filled as you will go round in circles forever.
    Code:
    cd /fridge/beer | drink && fallover

  4. #4
    Join Date
    May 2011
    Beans
    2

    Re: Chromium wont become default browser

    There are two options:

    One, you can uninstall Firefox through the Ubuntu Software Center. This should force Ubuntu to set Chromium as your default browser.

    Two, you can go to the "System" drop down menu in the upper left corner of your desktop. Here, choose Preferences, then choose Preferred Applications. Choose the "Internet" tab and choose Chromium for your default browser. If it doesn't work right away, try rebooting.

    There might be a way to do it via command-line, but I'm not very good with that yet. Hope I helped.

  5. #5
    Join Date
    Jul 2009
    Location
    Glasgow
    Beans
    5
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Chromium wont become default browser

    Quote Originally Posted by MolsterS013 View Post

    Two, you can go to the "System" drop down menu in the upper left corner of your desktop. Here, choose Preferences, then choose Preferred Applications. Choose the "Internet" tab and choose Chromium for your default browser. If it doesn't work right away, try rebooting.
    I've installed Natty twice in the last week and this has not worked on its own.

    However, if you do the above, leave that window open, then open Chromium and select "Set as default" again it should remember your preference this time. A little inelegant, but worked for me both times.

  6. #6
    Join Date
    May 2011
    Beans
    17
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Chromium wont become default browser

    Works fine for me now. Thanks!

  7. #7
    Join Date
    May 2011
    Beans
    2

    Re: Chromium wont become default browser

    Well, I have the same problem, the only difference is no fix helps. Every time I start Chromium it gives the message that it isn't my default browser, though if I look in the system settings it is. Besides that it's the only installed browser (Firefox removed).

    Any Ideas? Also tried Yasawas's fix.

  8. #8
    Join Date
    Dec 2007
    Beans
    2

    Re: Chromium wont become default browser

    Make sure ~/.local/share/applications/mimeapps.list exist.
    If the file is not there chromium will fail to set it self as default browser.

    Code:
    mkdir -p ~/.local/share/applications
    touch ~/.local/share/applications/mimeapps.list

  9. #9
    Join Date
    May 2007
    Beans
    68

    Re: Chromium wont become default browser

    Quote Originally Posted by pcastell View Post
    Make sure ~/.local/share/applications/mimeapps.list exist.
    If the file is not there chromium will fail to set it self as default browser.

    Code:
    mkdir -p ~/.local/share/applications
    touch ~/.local/share/applications/mimeapps.list
    This worked for me! thanks a lot
    And God said "sudo apt-get install light firmament land light_dark_seperation creatures man_woman; sleep 24"

  10. #10
    Join Date
    Jul 2011
    Beans
    1

    Talking Re: Chromium wont become default browser

    Quote Originally Posted by edm1 View Post
    Changing the setting in System Settings>Preferred Applications may work.
    Did pretty good job for me,thanks dude

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •