Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: natty 11.04 keeps asking for plug-in driver installation hp 1018

  1. #1
    Join Date
    Aug 2010
    Location
    Netherlands
    Beans
    40
    Distro
    Ubuntu 11.04 Natty Narwhal

    natty 11.04 keeps asking for plug-in driver installation hp 1018

    os: ubuntu 11.04 natty
    printer: laserjet 1018, usb connected to laptop

    problem: natty keeps asking for plug-in driver installation

    problem description: each time i startup my laptop or each time i plug in the usb cable of the printer the following procedure starts: hp printer driver plug-in installation > download > plug-in installation succesful. the printer works after downloading and installing the plug-in, but why do i need to keep installing the driver over and over again?

    did not have this problem in 10.10 or 10.04.

    thanks, stijn
    Last edited by stijnblommerde; May 7th, 2011 at 10:58 AM.

  2. #2
    Join Date
    Apr 2011
    Location
    India
    Beans
    15
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: natty 11.04 keeps asking for plug-in driver installation hp 1018

    I am having the same issue with my laserjet 1018. The printer fails to print the document even after the re-installation of driver/plugin, which i have done every time i connected my printer to my pc.

    never faced such a problem on 10.10 .

    the hplip version installed is 3.11.1
    Please anyone?

  3. #3
    Join Date
    Nov 2007
    Beans
    3

    Re: natty 11.04 keeps asking for plug-in driver installation hp 1018

    I am having the self same problem with my HP LaserJet 1018. I have to download the plug-in every morning,then the printer works fine for the rest of the day.

    There must surely be a cure for this, but can anyone tell me what it is?

  4. #4
    Join Date
    Aug 2008
    Beans
    53

    Re: natty 11.04 keeps asking for plug-in driver installation hp 1018

    I have this (HP 1018 laser jet) printer and the same problem, i have no idea how to debug this. Can somebody help?

    Best regards, Otto

  5. #5
    Join Date
    Aug 2010
    Location
    Netherlands
    Beans
    40
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: natty 11.04 keeps asking for plug-in driver installation hp 1018

    1. terminal: sudo apt-get remove hp*
    2. system settings - hardware - printer - delete hp printer (if installed)
    3. restart your computer (maybe not necessary, but i did)
    4. system settings - hardware - printer - add printer
    5. terminal: sudo hp-plugin

    update: i have to repeat step 5, each time i start my computer.
    Last edited by stijnblommerde; May 24th, 2011 at 09:24 AM. Reason: procedure did not work

  6. #6
    Join Date
    Aug 2008
    Beans
    53

    Re: natty 11.04 keeps asking for plug-in driver installation hp 1018

    The only thing that worked for my was installing the foo2zjs package from the lucid repository,

    Otto

  7. #7
    Join Date
    Aug 2010
    Location
    Netherlands
    Beans
    40
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: natty 11.04 keeps asking for plug-in driver installation hp 1018

    Quote Originally Posted by meijer.o View Post
    The only thing that worked for my was installing the foo2zjs package from the lucid repository,

    Otto
    hi meijer.o,

    i would like to try your solution. following questions arise: within ubuntu natty 11.04: how to add the lucid repository? how to add the package foo2zjs?

    thanks, s

  8. #8
    Join Date
    Jul 2010
    Location
    Kerala, India
    Beans
    7
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: natty 11.04 keeps asking for plug-in driver installation hp 1018

    I am also having same problem on HP Laserjet 1018 Printer, please provide us a solution asap.

  9. #9
    Join Date
    May 2006
    Beans
    19

    Re: natty 11.04 keeps asking for plug-in driver installation hp 1018

    Same thing here, LaserJet 1018. Here's a solution I found at the Russian forum. I'll give it a try tomorrow at the office:

    Code:
    sudo getweb 1018
    sudo hplj1018

  10. #10
    Join Date
    May 2010
    Beans
    10

    Re: natty 11.04 keeps asking for plug-in driver installation hp 1018

    Also had this problem for some time now: https://bugs.launchpad.net/ubuntu/+s...ip/+bug/780983

    Tried the above fixes but no change. Running sudo hplj1018 throws an error, so I am guessing that I'm stuck with the default hplip-drivers.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •