Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 50

Thread: unable to change screen brightness in ubuntu 11.04

  1. #11
    Join Date
    Dec 2004
    Location
    Linkoping, Sweden
    Beans
    19
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: unable to change screen brightness in ubuntu 11.04

    Same problem here with an FujitsuSiemens U9200. Previously using Gnome's brightness applet has been the solution but in Unity(-2D) I've resorted to using the Power management tab of UbuntuTweak (http://ubuntu-tweak.com/), not exactly the perfect solution.

    I can use fn+F8 to lower the brightness but fn+F9 only make the screen flicker.

    Do you know about any open bugs regarding the problems with the fn-keys?

  2. #12
    Join Date
    May 2011
    Beans
    3

    Re: unable to change screen brightness in ubuntu 11.04

    For those who has MB with the nvidia 9400m I found the solution!

    You just have to add a line in the xorg.conf

    sudo gedit /etc/X11/xorg.conf

    And then find the Section "Device" and add the bold line.

    Section "Device"
    Identifier "Default Device"
    Option "NoLogo" "True"
    Option "RegistryDwords" "EnableBrightnessControl=1"
    EndSection

    And now your brightness control is working!

    But maybe you have the same graphic card and then the problem is the keyboard or something like that.

  3. #13
    Join Date
    Jun 2009
    Location
    Barcelona
    Beans
    4
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: unable to change screen brightness in ubuntu 11.04

    Had the same problem on a MacBook (6,1) after activating the NVIDIA accelerated graphics driver.
    Adding a line in the xorg.conf solved the problem:

    Quote Originally Posted by Guskuma View Post
    sudo gedit /etc/X11/xorg.conf

    And then find the Section "Device" and add the bold line.

    Section "Device"
    Identifier "Default Device"
    Option "NoLogo" "True"
    Option "RegistryDwords" "EnableBrightnessControl=1"
    EndSection
    Thank you Guskuma
    Last edited by Lablasco; May 24th, 2011 at 09:12 AM.

  4. #14
    Join Date
    Jul 2007
    Beans
    2

    Re: unable to change screen brightness in ubuntu 11.04

    Will this work on a Samsung R780 running 10.10?

    Sam

  5. #15
    Join Date
    May 2008
    Location
    Germany
    Beans
    16
    Distro
    Ubuntu

    Re: unable to change screen brightness in ubuntu 11.04

    For HP 6735s, please refer also to this thread: http://ubuntuforums.org/showthread.php?t=1748468

  6. #16
    Join Date
    Jul 2010
    Beans
    3

    Re: unable to change screen brightness in ubuntu 11.04

    I have a Samsung MP-Q430.

    When I try to change the brightness (FN + L or R arrow key), the brightness meter (for lack of a better term) comes up and changes, but the brightness itself does not change.

    Also, if I start the computer unplugged, the brightness is intolerably low, and does not change even when I plug it in.

    I tried Lablasco's hack, but I haven't rebooted my computer yet. I doubt that it will work, since my computer thinks it is letting me change the brightness already, but I'll edit this post as soon as it reboots.

    Edit: No change. Still doesn't work.

    I have subscribed to this thread.
    Last edited by SirVenom; July 6th, 2011 at 06:42 PM.

  7. #17
    Join Date
    Nov 2008
    Beans
    10

    Re: unable to change screen brightness in ubuntu 11.04

    Hi everyone,

    I'm having similar problems as described by SirVenom and others. I can't adjust the screen brightness - using the function keys brings up the popup bar which (supposedly) indicates the screen brightness going up or down. However, the actual screen brightness doesn't change. If I use the sliders in Gnome Power Manager, or Ubuntu Tweak to adjust the brightness, again...the brightness doesn't change.

    It's as if Ubuntu reads my instructions to change the brightness, but doesn't pass the message onto the screen.

    I should also add that if I boot up when on battery power, the brightness is reduced compared to when I'm running on AC power. However, connecting/disconnecting the AC supply after booting up doesn't change the brightness.

    The other function keys on my laptop work fine - e.g. for controlling the sound and turning wi-fi on/off.

    I'm running Ubuntu Natty, on a Packard Bell EasyNote Tj68. Graphics card Intel GMA 4500M integrated graphics processor.

    Any help would be appreciated!
    Last edited by Col Matrix; July 6th, 2011 at 09:46 PM.

  8. #18
    Join Date
    Jul 2010
    Beans
    3

    Re: unable to change screen brightness in ubuntu 11.04

    I don't know the rules about bumping, despite my attempts to find them. If I am breaking a rule, can someone direct me to the relevant (and probably incredibly obvious and impossible to miss) thread to find it?

    I still have this problem. Does anyone have any suggestions for fixing it?

  9. #19
    Join Date
    Jul 2011
    Beans
    1

    Re: unable to change screen brightness in ubuntu 11.04

    I Just installed Ubuntu 11.04 Natty on a White Macbook Core Duo and experienced the same brightness issues. Here was my fix for the Macbook 3,1.

    You can check your Macbook version with:

    sudo dmidecode -s system-product-name

    And in Synaptic Package Manager , System Settings->Synaptic Package Manager

    Search for "pommed" and install (I installed the additional packages as well)

    Enjoy

    "pommed handles the hotkeys found on the Apple MacBook Pro, MacBook Air,
    MacBook, PowerBook and iBook laptops and adjusts the LCD backlight, sound
    volume, keyboard backlight or ejects the CD-ROM drive accordingly.

    pommed also monitors the ambient light sensors to automatically
    light up the keyboard backlight on machines that support it."

  10. #20
    Join Date
    Apr 2011
    Beans
    6
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: unable to change screen brightness in ubuntu 11.04

    I'm experiencing the same issue on a Toshiba Satellite. Reading around, I discovered a thread that stated that one should modify part of the /etc/default/grub file and insert 'nomodeset acpi_backlight=vendor' to the 'GRUB_CMDLINE_LINUX_DEFAULT' line. It seems to have worked for several people, however it hasn't worked for me yet, and has only crashed unity once I rebooted.

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •