Results 1 to 5 of 5

Thread: tv tuner not working

  1. #1
    Join Date
    Jul 2008
    Beans
    110
    Distro
    Ubuntu 10.04 Lucid Lynx

    tv tuner not working

    I have compro videomate m330f tv card recognised as Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)
    Code:
    konsta@konsta-MS-7592:~$ lspci
    00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
    00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
    00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
    00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
    00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 01)
    00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
    00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
    00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
    00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
    00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
    00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
    00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
    00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
    00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
    01:00.0 VGA compatible controller: ATI Technologies Inc Redwood PRO [Radeon HD 5500 Series]
    01:00.1 Audio device: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series]
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
    05:00.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)
    card list says it is number 49,but tvtime tells me NO SIGNAL every time.
    To make things worse.rmmod is making me problems even after it is blacklisted.
    Code:
    konsta@konsta-MS-7592:~$ sudo rmmod saa7134_alsa
    [sudo] password for konsta: 
    ERROR: Module saa7134_alsa is in use
    konsta@konsta-MS-7592:~$ sudo rmmod saa7134
    ERROR: Module saa7134 is in use by saa7134_alsa
    I'm using fresh installed natty.
    Any ideas what to do ???

  2. #2
    Join Date
    Feb 2009
    Location
    /earth/india/mumbai
    Beans
    599
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: tv tuner not working

    you should run foll command first
    Code:
    tvtime-scanner
    It should scan all the channels and save them in a file,then try tvtime..

    Vote for my Idea
    ~~~Open-source Software and Patience go hand in hand~~~

  3. #3
    Join Date
    Jul 2008
    Beans
    110
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: tv tuner not working

    this command is searching ,but says no signal so it can't find anything

  4. #4
    Join Date
    May 2011
    Beans
    3

    Re: tv tuner not working

    my hardware first: saa7134 / alsa650
    to run it with tvtime (with sound, etc.)

    don't forget to "reboot" when you're told so.

    (1)
    insert
    "saa7134" at the end of file "/etc/modules"

    (2)
    insert
    "options saa7134 i2c_scan=1 card=81 tuner=54" into "/etc/modprobe.d/options" file

    reboot

    (3)
    $ sudo apt-get install sox libsox-fmt-all tvtime xmltv-util

    (4)
    $ sudo apt-get install tvtime
    tv standart > PAL
    sound standart > PAL-BG
    frequency table > europe

    (5)
    $ lspci | grep SAA
    will give output like as follows:
    02:03.0 Multimedia controller: Philips Semiconductors SAA7131/SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
    "02:03.0" is the address of the sound system (select yours from your output)

    (6)
    $ LANG=C pactl list | grep -A2 alsa
    note all output lines like "alsa_input.pciXXXXXXXXXXXXXXX"
    for example:
    alsa_input.pci-0000_02_03.0.analog-stereo
    alsa_output.pci-0000_00_10.1.analog-stereo.monitor
    alsa_input.pci-0000_00_10.1.analog-stereo
    select the one with the matching numbers noted in step 5
    for example, my selection would be: "alsa_input.pci-0000_02_03.0.analog-stereo"

    (7)
    insert the line
    "load-module module-loopback source=alsa_input.pci-0000_02_03.0.analog-stereo"
    at the end of file
    "/etc/pulse/default.pa"

    (8)
    restart pulse audio
    $ pulseaudio -k

    or better reboot

    (9)
    now correct the line
    <option name="MixerDevice" value="default/Line"/>
    in the file "/etc/tvtime/tvtime.xml"
    like:
    <option name="MixerDevice" value="hw:0/PCM"/>

    reboot.

    start tvtime (no need to use "sudo", use the gui menu)

    search the channels and you're done.

    any questions? merkez3110@gmail.com


  5. #5
    Join Date
    Jul 2008
    Beans
    110
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: tv tuner not working

    working options for this card are
    card=49 tuner=69 (37 or 40 also works fine)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •