Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 34

Thread: Current theme defaults to silver theme for no reason randomly on login

  1. #21
    Join Date
    Nov 2009
    Beans
    1,203

    Re: Current theme defaults to silver theme for no reason randomly on login

    I too recall this issue having prior to Natty, but extremely rarely. Maybe just a few times ever, and the same solution (a restart) fixed it just fine. It is just in Natty it happens more often. Using Ubuntu Classic (No Effects) has lowered the frequency of the problem, but not entirely.

  2. #22
    Join Date
    Apr 2011
    Beans
    8

    Re: Current theme defaults to silver theme for no reason randomly on login

    Just happened again, again randomly after several reboots.

    For clarity for the post, I will presume these images are what is being seen.

    In my case, this is what it should be - Normal:



    And this is the Silver issue:


  3. #23
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,224
    Distro
    Ubuntu Development Release

    Re: Current theme defaults to silver theme for no reason randomly on login

    As already posted here...
    http://ubuntuforums.org/showpost.php...7&postcount=17

    Post #20 in the link given..
    https://bugs.launchpad.net/ubuntu/+s...on/+bug/574296

    Contains a workaround.
    Tested here and appears to work.

  4. #24
    Join Date
    Nov 2009
    Beans
    1,203

    Re: Current theme defaults to silver theme for no reason randomly on login

    Thanks for that Robert. I will test it and see if it completely fixes the problem.

    For those interested, that workaround is this:

    Code:
    sudo gedit /etc/xdg/autostart/gnome-settings-daemon.desktop 
    
    Change line 4 to:
    Exec= bash -c "sleep 2; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"

  5. #25
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,224
    Distro
    Ubuntu Development Release

    Re: Current theme defaults to silver theme for no reason randomly on login

    Quote Originally Posted by inameiname View Post
    Thanks for that Robert. I will test it and see if it completely fixes the problem.

    For those interested, that workaround is this:

    Code:
    sudo gedit /etc/xdg/autostart/gnome-settings-daemon.desktop 
    
    Change line 4 to:
    Exec= bash -c "sleep 2; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"
    Just for clarity for new users, please use gksudo
    (graphical sudo for GUI applications, standard sudo for terminal)

    so..
    Code:
    gksudo gedit /etc/xdg/autostart/gnome-settings-daemon.desktop
    Then the line that reads...
    Code:
    Exec=/usr/lib/gnome-settings-daemon/gnome-settings-daemon
    can be commented thus...
    Code:
    #Exec=/usr/lib/gnome-settings-daemon/gnome-settings-daemon
    and a new line added below it ....
    Code:
    Exec= bash -c "sleep 2; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"
    save and close.

    Now if you ever need to revert you can simply remove the last/new line shown above and remove the comment # from the line we commented out.

  6. #26
    Join Date
    Nov 2009
    Beans
    1,203

    Re: Current theme defaults to silver theme for no reason randomly on login

    Thanks Robert.

    So far so good for me after using this. Although, I have only restarted my computer twice, so more testing is needed to conclude the issue has been fixed.

  7. #27
    Join Date
    Mar 2008
    Beans
    98
    Distro
    Ubuntu Development Release

    Re: Current theme defaults to silver theme for no reason randomly on login

    I just noticed this started happening with me 2 days ago. I've never had it happen before. I have an Nvidia 7600GS and other than the nonactivated driver thing, its been ok. I'm using Unity on a amd64 system

  8. #28
    Join Date
    Nov 2009
    Beans
    1,203

    Re: Current theme defaults to silver theme for no reason randomly on login

    I think help is heading our way! Well, at least confirmation and acknowledgment of this bug.

    I checked out Linux Mint's (which was released today) and saw this very bug as one of them on there. they even mention the same 'fix' we have here, and a link to the bug report specifically about this one.

    Mint's showing of the bug:
    http://www.linuxmint.com/rel_katya.php

    Gnome theme failing to load Because of a race condition between the GDM and session calls to gnome-settings-daemon, Gnome can load without a theme.
    For more information you can follow this bug report.
    As a workaround, you can modify /etc/xdg/autostart/gnome-settings-daemon.desktop and replace 'Exec=/usr/lib/gnome-settings-daemon/gnome-settings-daemon' with 'Exec=bash -c "sleep 20; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"'.
    Note that "20" is an arbitrary value. You might have to fine tune this value and find the one that's right for you. If the session call is too soon it will fail because the GDM one is still alive. If it occurs too late it will only theme your panel but fail to theme your desktop and nautilus. In Virtualbox we found "20" to work quite well. On real hardware this value is likely to be smaller. The slower your computer is, the higher this value is likely to be.
    As such, I think this problem is almost solved! I just wonder if the original '2' or '20' is better or worse. As mentioned, fine tuning seems to be the thing.
    Last edited by inameiname; May 27th, 2011 at 03:28 AM.

  9. #29
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,224
    Distro
    Ubuntu Development Release

    Re: Current theme defaults to silver theme for no reason randomly on login

    Since I originally applied the workaround I have had the theme fail to load only once. (20 boots)
    This is much improved as before it would fail 50% of the time

    Thanks for the link.
    I have changed the value from 2 to 5 and will monitor.

    Cheers, Bob

  10. #30
    Join Date
    Nov 2009
    Beans
    1,203

    Re: Current theme defaults to silver theme for no reason randomly on login

    No problem, Robert. If I may ask, why 5? I am using 2, as that was what was mentioned previously in this thread, and looking at the link I just gave, they have 20. They mentioned slower computers requires more of a wait time, and faster ones can use a lower number.

    I guess let me know if you can if 5 is better for you than 2. Ooh, and maybe what are the specs to your computer.

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •