Results 1 to 10 of 76

Thread: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

Hybrid View

  1. #1
    Join Date
    Dec 2008
    Beans
    16

    Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Hi,

    I got my Thinkpad T420 with Nvidia Optimus T420 4180W1H and without an OS a few days ago. In the BIOS I selected the integrated graphics adapter and then I installed Ubuntu 11.04. It looks like almost every driver got installed automatically. However, I have the problem that the fan runs all the time. Is that always the case?

    I updated the BIOS from 1.16 to 1.23 but no change.
    I found thinkfan, which seems to be a program to control the fan of Thinkpad Laptops, but iam not able to controle the Fanspeed with it.

    Can anyone help ?
    Thanks

  2. #2
    Join Date
    Apr 2010
    Beans
    65

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Same problem here for an x220 running 11.04 ubuntu natty

  3. #3
    Join Date
    May 2011
    Beans
    4

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    I have a switchable gpu - in the bios I choose to use only the dedicated gpu...My fan ran constantly until I installed the ATI gpu drivers. Then silence.

  4. #4
    Join Date
    Dec 2008
    Beans
    16

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    What do you mean with
    until I installed the ATI gpu drivers
    Waht did you installed and what do you use now ?
    cause i would love to get my machine silent.

  5. #5
    Join Date
    Dec 2008
    Beans
    16

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    I found out that thinkfan is not working, because the Packet /proc/acpi/ibm/thermal isnt existing anymore for newer thinkpad models. So we need to wait for an update for this (but its not shure if there will be one)

    Alternate you can try to install (patch) Thinkpad Fan Control on your system.
    http://thinkpad-wiki.org/Thinkpad_Fan_Control

    I didnt managed to do so sucesfully but iam stil working on it.
    Tell me if you guys gonna make it.

  6. #6
    Join Date
    May 2009
    Location
    Hong Kong
    Beans
    70
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    im planning to get a T420 soon, is the fan really noisy when its on all the time?

    Also, just wondering, does everything else work nicely out of the box with natty?

  7. #7
    Join Date
    May 2011
    Beans
    4

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by robin.nightingale View Post
    What do you mean with
    Waht did you installed and what do you use now ?
    cause i would love to get my machine silent.
    I just installed the proprietary ATI FGLRX graphics driver through "additional drivers" in system settings/control centre.

    Everything (except my Epson scanner - need to look into that) worked just great right out of the box. But adding "additional drivers" in ubuntu software centre provides a heap of basic software that most people will want.
    Last edited by antskip; May 8th, 2011 at 12:11 AM. Reason: clarify further

  8. #8
    Join Date
    Nov 2006
    Beans
    Hidden!

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    Quote Originally Posted by antskip View Post
    I just installed the proprietary ATI FGLRX graphics driver through "additional drivers" in system settings/control centre.
    This does not apply to the Thinkpad T420, there is no ATI card in it.
    There can be a Nvidia Optimus NVS 4200M.

  9. #9
    Join Date
    May 2011
    Beans
    80
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Thinkpad T420, Ubuntu 11.04 Fan running all the Time

    i got thinkfan working on my t420:

    1. install thinkfan package
    2. add kernel module 'coretemp' to /etc/modules
    3. load kernel module 'coretemp'
    4. add the following three sensor entries to /etc/thinkfan.conf just before the temperature levels:

    sensor /sys/devices/platform/coretemp.0/temp1_input
    sensor /sys/devices/platform/coretemp.2/temp1_input
    sensor /sys/devices/virtual/hwmon/hwmon0/temp1_input

    5. add the following to /etc/modprobe.d/thinkfan.conf:

    options thinkpad_acpi fan_control=1

    6. reload kernel module 'thinkpad_acpi'
    7. set START="yes" in /etc/default/thinkfan
    8. start thinkfan: /etc/init.d/thinkfan start

    9. check whether it works: cat /proc/acpi/ibm/fan

    if level has a value between 0 and 7, and changes by times, your thinkfan daemon works.

    I found the solution in the thinkpad wiki (only german) at http://thinkpad-wiki.org/Thinkfan#Ke..._Kernel_2.6.38

    greetings,
    jonas

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •