Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Gapless playback seems to have gone away

  1. #1
    Join Date
    Feb 2005
    Beans
    8

    Gapless playback seems to have gone away

    I've discovered that flac files which played gaplessly in Rhythmbox on Maverick won't do so on Natty. There is now a dropout when transitioning from one to the next. Why might that be?

  2. #2
    Join Date
    Aug 2007
    Beans
    53

    Re: Gapless playback seems to have gone away

    I have the same problem here. Both Rhythmbox and Banshee refuses to give gapless playback even when enabling the crossfading feature in Rhythmbox. Worked fine in Maverick.

  3. #3
    Join Date
    Jan 2008
    Location
    Melbourne, Australia.
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Gapless playback seems to have gone away

    Yes, me too. This certainly blows.

    EDIT: I found this but report: https://bugs.launchpad.net/ubuntu/+s...10/+bug/774417
    Last edited by powerpleb; May 8th, 2011 at 01:27 PM.

  4. #4
    Join Date
    Aug 2007
    Beans
    53

    Re: Gapless playback seems to have gone away

    Is there any player for Natty where this currently works? I'd rather change media player than live without gapless playback.

  5. #5
    Join Date
    Apr 2007
    Beans
    2,604
    Distro
    Ubuntu

    Re: Gapless playback seems to have gone away

    Somewhat tedious to install and configure, but mpd (music player daemon) combined with a frontend such as sonata was for a long time the only decent gapless playback solution in linux (so I am still using it). It is low on resources and handles large libraries extremely well.

  6. #6
    Join Date
    Apr 2008
    Location
    The Universe
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Gapless playback seems to have gone away

    Unfortunately for me mpd was no dice. Same problem. In fact, I can't remember ever getting gapless to work on Ubuntu in Rhythmbox or Banshee, though until Natty the last time I spent a lot of time with an Ubuntu distro was Karmic so maybe I missed the "window of perfection." I seem to recall gapless worked in Songbird, but of course they dropped Linux support so that's no longer an option.

    I'm stuck using Wine to run Foobar2000, which is neither optimal nor likely to rub committed open source users the right way. Not a single player I've tried in 11.04 (Exaile, Rhythmbox, Banshee, mpd, Amarok) has had gapless working (actually I can't say whether Exaile worked because it crashed before I could get it to play anything; Aqualung was the same).

    EDIT: Exaile doesn't crash anymore (they must have fixed that), but it has the same nasty gap as all the others. Aqualung actually played something this time (last time it sat silently then hung), but the gap was there, too. I think this has to be something with audio in general rather than a player-specific issue.
    Last edited by Squonk07; May 15th, 2011 at 07:36 AM.
    Drifting back and forth between Windows and Linux--I'm in it for the technology, not the philosophy!

  7. #7
    Join Date
    Apr 2007
    Beans
    2,604
    Distro
    Ubuntu

    Re: Gapless playback seems to have gone away

    Quote Originally Posted by Squonk07 View Post
    Unfortunately for me mpd was no dice.
    It should work out of the box for audio formats that are natively gapless such as ogg and flac. For lame-encoded mp3 files, you need to "activate" the option "gapless_mp3_playback" in the mpd config file.

    You probably are aware that before mp3s can be played back without gaps, they must be properly encoded with lame, and must be played with software that understands the specific lame tags allowing this.

  8. #8
    Join Date
    Apr 2010
    Beans
    17

    Re: Gapless playback seems to have gone away

    native gapless playback has been something I've been looking for for years on linux and it has never worked properly.

    After trying every single music player for linux, the only way I could manage to get REAL gapless playback, not only with FLAC but also with mp3, has been using wine+foobar2000. it works flawlessly, the only thing broken is the equalizer. everything else (including a lot of 3rd party components) work perfectly.

  9. #9
    Join Date
    Aug 2007
    Beans
    53

    Re: Gapless playback seems to have gone away

    I managed to fix gapless in Rhythmbox on my system by simply increasing the network buffer slider under playback options!
    I have no idea how to fix it in Banshee though.

  10. #10
    Join Date
    Aug 2007
    Beans
    53

    Re: Gapless playback seems to have gone away

    Also make sure the crossfade option is checked.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •