Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: 11.04 Natty wireless issue - Acer - Device not ready

  1. #11
    Join Date
    Jun 2011
    Beans
    9

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Quote Originally Posted by shokalabutcha View Post
    I had a similar problem: Whenever I did "rfkill unblock all", my wireless would go from
    Soft blocked: Yes
    Hard blocked: No

    to

    Soft blocked: No
    Hard blocked: Yes

    Tantalizing, isn't it? In the end, I created the following script as a (barely acceptable) solution:

    sudo rmmod -f ath5k
    sudo rfkill unblock all
    sudo odprobe ath5k

    I hope this script helps someone. In the time being, if anybody knows how to make this permanent, that will be much appreciated.

    I am using a Natty Narwhal, (Ubuntu 11.04) running on Fujitsu Siemens Amilo PA3515 with an Atheros AR5001 wireless module.

    Hope this helps,
    Shoka
    I have almost the same problem, but your script doesn't help me... It happened to me whenever I disabled/enabled wireless again. Thank you anyway.

    More info: http://ubuntuforums.org/showthread.php?t=1781350

  2. #12
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,623
    Distro
    Ubuntu Development Release

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    It's not tantalizing; it's maddening! However, it is wonderful that you found a fix. I think you will help a lot of searchers.
    In the time being, if anybody knows how to make this permanent, that will be much appreciated.
    Please do:
    Code:
    sudo gedit /etc/rc.local
    Add your three lines above exit 0 without sudo:
    Code:
    rmmod -f ath5k
    rfkill unblock all
    modprobe ath5k
    Proofread carefully, save and close gedit. Reboot and tell us if it's working as expected.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #13
    Join Date
    Jun 2011
    Beans
    6

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Thanks Chili, just added those to rc.local, and it works perfectly.

    I had thought that rc.local wasn't supposed to be used, that we all should use update-rc.d, but I guess whatever works, works.

  4. #14
    Join Date
    Apr 2007
    Beans
    9

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    This has worked like a charm for me too!

    Thanks so much for your help shokalabutcha and chili555!
    Wifi missing was a real nightmare

  5. #15
    Join Date
    Aug 2005
    Location
    East London, South Africa
    Beans
    38
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Finally... thanks for the fix chili555. My acer tm8372t now has wifi.
    vijay

  6. #16
    Join Date
    Sep 2011
    Beans
    12

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Quote Originally Posted by chili555 View Post
    Please let us see:
    Code:
    sudo rmmod -f acer-wmi
    sudo rfkill unblock all
    rfkill list all
    Does your wireless work now? We can amend two files and make it permanent.
    Hey Chilli, I need your help. I had the same issue with acer-wmi blocking my sony-wifi in software switch. I followed your commands:

    Code:
    sudo rmmod -f acer-wmi
    sudo rfkill unblock all
    rfkill list all
    and it worked, and i could see my wireless and it was working and everything was working and fine.

    In order to make it permanent i then did
    Code:
    sudo gedit /etc/modprobe.d/blacklist.conf
    added line in the end

    Code:
    blacklist acer-wmi
    Code:
    sudo gedit /etc/rc.local
    rfkill unlock all
    and when i rebooted. I do not see any phy0 in 'rfkill list all' output and there is no wireless option in panel.

    It seems my drivers are gone or what i do not know.

    Here is the current rfkill list all output:

    vycas@vycas-VPCYA15FG:~$ rfkill list all
    1: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    2: sony-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

    Also the lspci output (it sees the ath9k wireless)



    vycas@vycas-VPCYA15FG:~$ lspci
    00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
    00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
    00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
    00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
    00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
    00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
    00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
    00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
    02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    03:00.0 Ethernet controller: Atheros Communications AR8131 Gigabit Ethernet (rev c0)
    ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
    ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
    ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
    ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
    ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
    ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
    vycas@vycas-VPCYA15FG:~$


    It worked with those 3 commands. The moment i tried to make it permanent. it messed up.

    Vycas

  7. #17
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    29,639
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Hi, so it is not working at all now? this
    Code:
    rfkill unlock all
    should have been this
    Code:
    rfkill unblock all
    Thank you

  8. #18
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    29,639
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Hi, so it is not working at all now? this
    Code:
    rfkill unlock all
    should have been this
    Code:
    rmmod -f ath5k
    rfkill unblock all
    modprobe ath5k
    Thank you

  9. #19
    Join Date
    Sep 2011
    Beans
    12

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Quote Originally Posted by wildmanne39 View Post
    Hi, so it is not working at all now? this
    Code:
    rfkill unlock all
    should have been this
    Code:
    rmmod -f ath5k
    rfkill unblock all
    modprobe ath5k
    Thank you
    Ok i tried the

    modprobe ath9k (since i have ath9k)

    it reinstalled the phy0 and then i did the sudo rmmod -f acer-wmi

    and it works, but only for few minutes after that it just looses too much packets. I pinged my router and it lost 70% of packets and i am literally 2 feet away from it.

    After rebooting acer-wmi always appears, so i have added these commands in following sequence in /etc/rc.local

    sudo rmmod -f acer-wmi
    sudo modprobe ath9k

    My wifi shows internet is connected, but it doesn't work. ping works but its too slow and latency is way too high.

    Vycas

  10. #20
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    29,639
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Hi, make sure you did it just like post 12 says.

    Set your router to wpa2 and not mixed mode or wep, then post back and we will go from there.
    Thank you

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •