Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Cant change permission for usb ntfs shared drive.

  1. #1
    Join Date
    Jan 2007
    Beans
    14

    Cant change permission for usb ntfs shared drive.

    Hi,

    I have used:

    Code:
    sudo gedit /etc/fstab
    and added the following line:

    Code:
    UUID=B9709709D876CB78 /media/windows ntfs-3g auto,uid=1000,gid=1000,umask=0022 0 0
    I dont remember the line i have used to get the uuid.

    Then went to /media folder and shared windows folder, but in permission for that folder, under others, it wont let me change folder access from "Access Files" to "Create and Delete Files"

    In order for me to access the shared folder on windows machine i had to restart ubuntu computer otherwise i had permission error.

    After restart when i wont to see /media/windows the folder did not have the 2 arrows showing that the folder was shared.

    How can i find setting that indicate that my /media/windows folder is shared as backup ( since that is how i named in sharing setting ) and add permission to other for delete and create folder and files.

    Thank you!

  2. #2
    Join Date
    Jan 2007
    Beans
    14

    Re: Cant change permission for usb ntfs shared drive.

    Anyone,

    Did i do something wrong with fstab? Just need the change the permission for others, from read only to full.

  3. #3
    Join Date
    Dec 2009
    Beans
    5,794

    Re: Cant change permission for usb ntfs shared drive.

    [1] Unmount the partition:
    Code:
    sudo umount /media/windows
    [2] Change umask=0022 to umask=0000 in fstab:
    Code:
     UUID=B9709709D876CB78 /media/windows ntfs-3g auto,uid=1000,gid=1000,umask=0000 0 0
    [3] Save fstab and run the following command to test for errors and mount the partition without requiring a reboot:
    Code:
    sudo mount -a
    Note: a "2" in umask turns off write. A "0" turns off nothing.

  4. #4
    Join Date
    Jan 2007
    Beans
    14

    Re: Cant change permission for usb ntfs shared drive.

    Hey,

    Thank you very much, the sharing works perfectly now

    Is there a command or somewhere in ubuntu that i can go to find everything that is being shared at the moment and change settings.

    After i restart ubuntu the icon on the shared folder disappears with the indication that the folder is shared.

    When I was testing out sharing I shared bunch of folders, but after restart i cant turn off the sharing on those folders, since there is no indication.

    Thank you!

  5. #5
    Join Date
    Dec 2009
    Beans
    5,794

    Re: Cant change permission for usb ntfs shared drive.

    You know you've used the term "share" several times in this topic and I'm not sure what you mean by "share"

    If you are talking about Samba sharing it depends on how you created the samba share - there are two methods to do that:

    [1] Classic Samba shares - have the share in smb.conf and one way to see them all is to run this command:
    Code:
    testparm -s
    [2] Samba Usershares - created from Nautilus

    You can see all your shares with this command:
    Code:
    net usershare info --long

  6. #6
    Join Date
    Jan 2007
    Beans
    14

    Re: Cant change permission for usb ntfs shared drive.

    Here is how i shared the folder.

    I right click on the folder, choose "Sharing options" then select "Share this folder", "Allow other to create and delete","Guest Access", then click "Create Share".

    Code:
    net usershare info --long
    Shows my shared folders. How do i edit this info?
    Last edited by darksniperx; January 1st, 2012 at 11:59 PM.

  7. #7
    Join Date
    Dec 2009
    Beans
    5,794

    Re: Cant change permission for usb ntfs shared drive.

    Quote Originally Posted by darksniperx View Post
    Here is how i shared the folder.

    I right click on the folder, choose "Sharing options" then select "Share this folder", "Allow other to create and delete","Guest Access", then click "Create Share".

    Code:
    net usershare info --long
    Shows my shared folders. How do i edit this info?
    The same way you created it - through nautilus.

  8. #8
    Join Date
    Jan 2007
    Beans
    14

    Re: Cant change permission for usb ntfs shared drive.

    The folders that i shared though nautilus, don't appear shared. If i right click on them and choose sharing options, it is asking me to share them again.

  9. #9
    Join Date
    Dec 2009
    Beans
    5,794

    Re: Cant change permission for usb ntfs shared drive.

    I have never experienced that problem. There was a bug a few versions ago that a shared folders icon would not show it being shared after a reboot but that did not alter the fact that it was still shared.

    "net usershare info --long" should always show you the state of all the shares you created through Nautilus. If it shows the folder as being shared and Nautilus doesn't and you want to change how it's shared just share it again through Nautilus.

  10. #10
    Join Date
    Jan 2007
    Beans
    14

    Re: Cant change permission for usb ntfs shared drive.

    the folders are shared, thats not an issue.

    The issue, is when i would like unshare a folder. I dont have the option to do that.

    I can see all of my shared folders with "net usershare info --long" But if i want to undo sharing i cant. If i go to the same folder and share it again, then it will appear appear twice.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •