Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 35

Thread: 11.04 vnc screen not repainting

  1. #11
    Join Date
    Aug 2007
    Beans
    2

    Re: 11.04 vnc screen not repainting

    I don't have Ubuntu 11 around to test, but can you try disabling visual effects? (somewhere in the Appearance preferences). Let me know if it helps.

  2. #12
    Join Date
    Sep 2007
    Beans
    2

    Re: 11.04 vnc screen not repainting

    Removing desktop effects does fix the problem for me.

  3. #13

    Re: 11.04 vnc screen not repainting

    Found here: http://www.ubun2.com/question/379/wh...w_and_unusable a solution for me.

    In terminal, write the command:

    gconf-editor

    Then navigate to: desktop / gnome / remote_access. Enable the "disable_xdamage" setting.

  4. #14
    Join Date
    May 2011
    Beans
    2

    Re: 11.04 vnc screen not repainting

    I have used Ubuntu 9.04 through 10.10 and all worked very nicely with the VNC server. I could log in from home with a Windows machine no problem. After upgrading or installing fresh Natty 11.04, VNC server does not work at all. This is on multiple machines. It either comes up with an error after waiting a long time or indicates the VNC server cannot start on the port (no matter which port I use!). Changing back to the Classic desktop does not fix it; this is a problem with 11.04 and is really irritating!!
    BYW- tried to enter a bug report but launchpad would not accept my password(?)
    Very frustrated!

  5. #15
    Join Date
    Aug 2009
    Location
    Aberdeen, UK
    Beans
    18
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Lightbulb Re: 11.04 vnc screen not repainting

    I've been seeing this VNC slow screen re-drawing on 11.04, but I changed to "Ubuntu Classic" on the login screen and that solved it, back to normal re-draw speeds.

    I'm just using VNC Viewer 4 from a WindowsXP machine from connected locally via 100MB Ethenet
    Last edited by AndyGaskell; May 6th, 2011 at 01:34 PM.

  6. #16
    Join Date
    May 2011
    Beans
    11

    Re: 11.04 vnc screen not repainting

    Quote Originally Posted by Maximiliano Gasparini View Post
    Found here: http://www.ubun2.com/question/379/wh...w_and_unusable a solution for me.

    In terminal, write the command:

    gconf-editor

    Then navigate to: desktop / gnome / remote_access. Enable the "disable_xdamage" setting.
    Thank you! This solution worked for me.

  7. #17
    Join Date
    Dec 2009
    Beans
    4

    Exclamation Re: 11.04 vnc screen not repainting

    Quote Originally Posted by Maximiliano Gasparini View Post
    Found here: http://www.ubun2.com/question/379/wh...w_and_unusable a solution for me.

    In terminal, write the command:

    gconf-editor

    Then navigate to: desktop / gnome / remote_access. Enable the "disable_xdamage" setting.
    I believe this can all be lumped in to the general compiz/vino problem that cropped up a few releases back.

    You mention the 'disable_xdamage' solution, but this is only a band-aid fix. What disabling xdammage does is make vino send an entire image of the screen on every refresh. As opposed to simply sending the portions of the screen that have moved/changes (as it normally would). If you're on the same LAN as the remote machine this may be acceptable, but across the internet? You may get one refresh per second... disabling compiz is the only 'solution' I've consistently seen fix the problem for people.

    -A

  8. #18
    Join Date
    Jul 2006
    Beans
    92
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 11.04 vnc screen not repainting

    Quote Originally Posted by Maximiliano Gasparini View Post
    Found here: http://www.ubun2.com/question/379/wh...w_and_unusable a solution for me.

    In terminal, write the command:

    gconf-editor

    Then navigate to: desktop / gnome / remote_access. Enable the "disable_xdamage" setting.
    A defect has been posted for this issue:

    https://bugs.launchpad.net/bugs/772873

    Please contribute there.
    --
    Ubuntu 10.10 |
    AMD Phenom II X2 555 Black Edition Callisto 3.2GHz C3 | http://foxcub.net/

  9. #19
    Join Date
    Jul 2006
    Beans
    92
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 11.04 vnc screen not repainting

    Quote Originally Posted by vladstudio View Post
    I don't have Ubuntu 11 around to test, but can you try disabling visual effects? (somewhere in the Appearance preferences). Let me know if it helps.
    As of Natty, there is no user-facing method for disabling desktop effects.

    Editing the gconf registry every time you need to connect via remote desktop is not "human."
    --
    Ubuntu 10.10 |
    AMD Phenom II X2 555 Black Edition Callisto 3.2GHz C3 | http://foxcub.net/

  10. #20
    Join Date
    Oct 2010
    Location
    Italy
    Beans
    30
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 11.04 vnc screen not repainting

    Just upgraded 3 three computers over the weekend from 10.4 to 11.4 all running classic, no effects etc (when I say upgrade I mean re-format and 11.4 install)...still VNC refresh issues, simply put there was no workaround for me....re-installed 10.04 back on them and VNC works again.

    Hope they fix the bug soon.
    Last edited by leon_chame; May 10th, 2011 at 02:43 AM.

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •