Hi -- I've tried to install 11.04 on my Macbook Pro (5,4) today.
I had two drives in the machine, an SSD as my main drive, and an HD.
I installed rEFIt before attempting to install Ubuntu.
I moved my Snow Leopard install to the secondary HD & made sure I could boot to it.
Then, I used the live CD & gparted to clear the 1st drive (the SSD), create the swap space, create the Ubuntu partition, and launch the install, where I used what I had just created on the SSD.
The install completed okay (but with no option to select where the GRUB installer went, like some tutorials tell you to look out for).
This seemed to go okay, so I went to restart at the end of the install, but the machine didn't come back up.
Instead, the power came on & I could hear the drives, but the screen stayed black, the battery light flashed a load of times really quickly (too quickly to count, but at least 10 times), and then the machine let out 1 long beep and stayed on the black screen.
I forced it to power down & tried again, and just got a black screen, the battery light shining steadily, and no beep.
I forced it to power down again, and got the same, then again, and got the same, and then a 4th time, which actually allowed me to boot.
And this has been the pattern since then. I shut down, and my first attempt to restart gets me the flashing light and the beep, with the black screen. I try 3 more times to power down and restart, and just get the black screen. Then, *every* time on the 4th time, I'm allowed to boot.
The same routine will be gone through the next time I power down and try to restart.
I've tried totally clearing the disk in gparted, restoring the OSX install from TimeMachine, everything I could think of, but all to no avail.
Finally, thinking that maybe the OSX install I had safe on the secondary HD might still be okay (looking at it in gparted showed an EFI boot section & everything), I opened up my MBP, swapped the drives around so that the HD is now the main drive, and the SSD the secondary, and renamed the drives so that the primary HD is now called 'Macintosh HD' and is first in the list of drives that appear when I manage to boot each 4th attempt.
But, to my great disappointment, I still got exactly the same error.
Can anyone offer any advice on how to:
1) Get my machine booting to a safe Snow Leopard install on the (now primary) HD?
2) Safely install Ubuntu on the (now secondary) SSD?
Obviously the first is a top priority, as I need my machine in order to work!
Then I can concentrate on moving my dev environment to Ubuntu, which I've been dying to do for ages.
Thanks very much for any & all assistance,