Results 1 to 10 of 1377

Thread: Graphics Resolution- Upgrade /Blank Screen after reboot

Threaded View

  1. #1
    Join Date
    Mar 2010
    Ubuntu Development Release

    Graphics Resolution- Upgrade /Blank Screen after reboot

    // Updated As Of: 2015.1.10, Version 14.10

    Are you having these problems?
    - Error- "Cannot display this graphics mode"
    - GRUB_GXFMODE-auto results in Blank screen problems on Startup? (this includes purple or black screen, flashing cursor, stuck at splash screen...)
    - No Grub Menu?

    Note: Keep checking back to this post and the next 2, as I edit them with the latest changes and workarounds.

    The Table Of Contents (<-- Link) is on page 2. It has links to many graphics tutorials, workarounds and fixes in this thread.

    Linux distributions such as Ubuntu, basically and simplistically run in layers like this--> You have a Linux kernel running. On top of that layer, you have a terminal session- running to interact with other layers. On top of that, you have an GUI, XTerminal session, X-Windows, XServer or also known as an XSession running to have a visually interactive session running. In each version of Ubuntu (and of distro's) an honest and earnest attempt is made to make each new version easier to use for a new user, in a way that is pleasing to the eye. Each of these changes does mean underlying changes in how things relate to each other layer... on a base that is trying to cover a myriad of hardware combinations, that users will install that distribution onto. Sometimes all of these combinations cannot be "foreseen." (For instance when a certain video card type is made by over a dozen different vendors...) These techniques are similar to the same problems in Unix and XServer (XServer Host & Client)...

    Here is a short quick-reference of Linux short-cuts and hot-keys to help you get around and to help diagnose graphics problems in an Linux XSession. Some are also helpful later in just everyday kind of tasks. Like I said, this is only an abbreviated list, but I included them here because they do come in handy in diagnostics and the correction of boot and video errors:

    Switch to the first text terminal. Under Linux you can have several (6 in standard setup) terminals opened at the same time. Terminals start as tty0 and go up from there. Most of the time the normal boot text console, that is present "under" the GUI or XSession (in Ubuntu) is tty1, so you would press <Cntrl><Alt><F2> to get to it...

    <Ctrl><Alt><Fn> (n=1..6)
    Switch to the nth text terminal.

    Print the name of the terminal in which you are typing this command.

    Switch to the first GUI terminal (if X-windows is running on this terminal).

    <Ctrl><Alt><Fn> (n=7..12)
    Switch to the nth GUI terminal (if a GUI terminal is running on screen n-1). On default, nothing is running on terminals
    8 to 12, but you can run another server there.

    (In a text terminal) Autocomplete the command if there is only one option, or else show all the available options.
    THIS SHORTCUT IS VERY HANDY! This also works at LILO or GRUB prompt!

    Scroll and edit the previous command history. You can then use that command as is or edit it to change. Press <Enter> to execute.

    As above, but go back to the next command in history.

    Scroll terminal output up. Work also at the login prompt in the tty text console, so you can scroll through your bootup messages to find errors and messages. Does not work to see terminal output that has been "cleared."

    As above, but scrolls terminal output down.

    (in X-windows) Change to the next X-server resolution (if you set up the X-server to more than one resolution in /etc/X11/XF86Config). For multiple resolutions on my standard XVGA card/monitor, I have the following line in the file /etc/X11/xorg.conf (the first resolution starts on default, the largest determines the size of the "virtual screen"):
    Modes "1440x900" "1024x768" "800x600" "640x480" "512x384" "480x300" "400x300" "1152x864" Whichever resolution you have as first in this line will be the default.

    (in XWindows) Change to the previous XServer resolution.

    Linux Ubuntu version 10.10 and previous- Kill the current X-session.

    Linux Ubuntu version 11.04 and later- Kill the current X-session.

    -- The "Linux shortcut keys" are just that, meaning Linux is already booted. to use them-- although "some" of them do work in the Grub CLI. *such as the <Tab> for autocomplete)

    Basically, between the grub menu and the GUI Desktop Manager (GDM or LightDM), where you are getting a blank screen the only short-cut keys that "may" be available are the <ctrl><alt><F1 the F6> keys and <ctrl><alt><F7> key... which I mentioned, may not work even if you were not having graphical problems.. But if they do, you have some options.

    Yes, with every new release of a distribution of Ubuntu, there seems to be similar and reoccurring problems that arise with "graphics" when trying the run a LiveCD and after the initial install and first boot. These are my notes that have help people through many releases of Ubuntu, up through Ubuntu desktop variants and server.

    Basically, we want to make sure that the Grub menu boots. then verify that the kernel is booting, then that the XServer Session starts and displays.

    Troubleshooting Flow Chart
    This is to break this down into steps:
    Step 1. Do you have a Grub Menu?
    - Yes: Go to step 2...
    - No: While booting, Press shift key (don't hold down) multiple times to see if the Grub menu will come up.
    - - If yes on Menu, go to step 2
    - - If no, use a LiveCD to chroot >> Change /etc/default/grub/ (line) GRUB_HIDDEN_TIMEOUT=00. and rerun "update-grub" Or you can do that chroot'ed from a LiveCD... instructions second half of post #3.
    (Note- that will display a warning on boot- saying that timeout cannot be set to '0'... but it will display the menu, then and have no apparent challenges with that)
    - - - If yes on Grub Menu go to Step 2
    - - - If No, go to my fix on "Forcing Grub To Show Menu"... Link in Post #2
    - - - - If yes on menu, go to Step 2
    - - - - If No, reinstall grub and Start Step 1 from Beginning... Because it seems that Grub is not booting.

    Step 2 "Does the Linux Kernel Boot?" At Grub Menu, go into edit mode and boot into a text console (see instructions below)
    - Yes. Go to Step 3
    - No. Messages will be verbose on what is loading, what are warnings and what are error messages. Shortcut keys will start to work as the kernel modules load. If if stops at an error, you will be able to use the shortcut navigation cuts to review the errors. Depending on the error, if it is a kernel error, you may be able to reinstall or renew the kernel image. If it is a device module, at least you have somewhere to go to reload that device module or driver.,,, Goal is to get a "booting kernel."

    Step 3. From the Grub Menu, try to boot in Rescue mode/low graphics.
    - If Yes, look for additional drivers and install recommended driver.
    - If No, goto Step 4 to verify that linux kernel will boot.

    Step 4. Can you boot a graphical XSesion from a text console session? From the command line type
    sudo service gdm start # substitute "lightdm" when appropriate
    - Yes No black screen/No problem... should boot straight from the grub menu.
    - No. Reboot and start testing and changing gfx_modes and kernel boot graphical modes, still booting into the text console before you try to start an XSession. Going this way, you will have more of a possible chance to be able to toggle between a graphical session or text terminal session (sometimes). ...and at a text console, at least you have the ability to install files and make changes to config files. And if you can get back into a command prompt, you could then stop the gdm service that is locked.

    You can stop the graphical desktop manager (gdm or lightdm) service via
    sudo service gdm stop
    Note-- Changes/Updates. GDM was used through v11.04. v11.10, v12.04 and newer used LightDM as the Desktop Manager. If so use "lightdm" is place of "gdm."

    Digging in and opening up the hood:
    If you can successfully boot grub, you are at least past point one. You can use grub as a jumping off-point- To test and see what graphical modes do work. Modes in Grub and where the linux kernel boots into does have a direct relationship to mode problems/successes when an Xorg Xsession starts.

    Here, I can mention LiveCD'es. See post 3 for notes on using these techniques with a LiveCD. To me, a LiveCD in hand, is a very valuable diagnostics and recovery tool. If you can successfully boot and display a LiveCD on your PC... You are almost there.

    A note about temporarily "editing" the kernel boot line...
    This is an example of the menu entries of a Ubuntu menu item that will display when you press "e" in a Grub menu:
    set gfxpayload=$linux_gfx_mode 
    insmod gzio
    insmod part_msdos 
    insmod ext2
    if [ x$feature_platform_search_hint = xy ]; then search --no-floppy --fs-uuid --set=root --hint-efi=hd1msdos2 --hint-baremetal=ahci1,msdos2  32939def-1f4a-4134-9b56-bed2319a9216
    search --no-floppy --fs-uuid --set=root 32939def-1f4a-4134-9b56-bed2319a9216 
    echo 'Loading Linux 3.16.0-28...'
    linux    /boot/vmlinuz-3.16.0-28-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro  quiet splash 
    initrd    /boot/initrd.img-3.16.0-28-generic
    The Linux kernel boot line in indicated above in red.

    Note: Something that had changed starting with version Natty 11.04 and GNU Grub 1.99~rc1... Look at the kernel boot line again, below:
    linux    /boot/vmlinuz-3.16.0-28-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro   quiet splash
    What we used to do to help display error messages was to remove the options in blue ( quiet splash ) and type in " nosplash --verbose text " at the end of the boot line to boot into a text console (and have all the messages displayed).

    Note on the "text" option. It had stopped working as of Kernel 3.x.x. I had a Launchpad and Upstream Linux ( bug opened on that. It is working now. It works again now. So if you have an earlier version that does not work with that, then use "singlle".

    Between 11.04 and 12.04, there was a kernel boot option " vt_handoff=7 "). This option is no longer there, preparing for systemd. That option's purpose was (from the wiki)
    For a smooth boot process, we want to display something other than a black screen as early as possible and leave it on screen until the desktop is ready. vt.handoff=7 is part of this. We have the boot loader display an aubergine background (we wanted to have an Ubuntu logo as well, but there are problems with different aspect ratios between the boot loader and the real system, so this is the next best thing). vt.handoff=7 then causes the kernel to maintain the current contents of video memory on virtual terminal 7, which is a new "transparent" VT type. The first time that the kernel is told to switch away from VT 7, either from Plymouth or manually (Alt-F1, etc.), these contents are lost and VT 7 reverts to text mode.

    The upshot is that, when everything is working correctly, you get an aubergine background on the way out of the boot loader, then at some point Plymouth displays a logo and a progress indicator on top of that, and then the display manager comes up and smoothly replaces that with a login prompt.
    So if we want to see all the error messages, we now also have to remove this from the boot line temporarily while trying to find problems.

    So to boot into a text console to verify that the system is booting into Linux, we edit the above kernel boot line to look like this:
     linux    /boot/vmlinuz-3.16.0-28-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro  nosplash --verbose text
    After editing, press <cntrl><x> and it will try to boot the menu entries. If and after the kernel boots in text mode, you will have more options to change things going into an Xsession.

    If the kernel didn't boot, check the displayed error messages. You may have a kernel image problem, where you may have to reinstall the kernel image... or a device driver/module problem.

    If you can boot the linux kernel and you know the package name of the driver you need... Reboot and get into the grub menu, cursor to the main boot menu item. press "e" > go to the kernel boot line and append " text " to the end of the line. Press ctrl-x to boot the kernel... it will boot into a text console mode. Login as you > install the driver via apt-get or aptitude...

    Now that "text" kernel option is back again, that is now the accepted way to boot to a text console. If that does not work, then use "S" (capital S) for single mode. If you have nvidia graphics use nomodeset and look near the end of this post. If you have radeon, use "radeon.modeset=0") If you really want to see what is going on, turn on debug via "--verbose debug drm.debug=0xe plymouth:debug "

    Going on
    If still no Xsession. I usually check the /home/username/.xsession-errors file for errors. where can see if there is a problem with loading a driver or in the /var/log/Xorg.0.log file. Then I go to grub... Another log to now check is var/log/kernel.log to see if vmap allocation is running out of memory on startup (look at the nvidia tips). Then I look at the /var/log/Xorg.0.log file.

    The Grub menu does not usually display if Ubuntu is the only OS. If you are having problems not seeing the grub menu on boot, hold down the "shift" key. Even if the menu is set to "silent" or not to be shown, grub should be listening for the shift key to interrupt the boot sequence. On some machines, holding the shift key down continuously will cause a keyboard overflow-- if it does, press the shift key multiple times instead. If it still doesn't bring up the Grub menu, commenting out /etc/default/grub/ line
    sometimes helps with that... But I found a way to hardcode it in and force it to show, even on difficult hardware:
    Look at post #2 > Forcing Grub to Show Menu

    If that still doesn't bring it up after that, reinstall grub.

    Uncommenting the line in the /etc/default/grub that says
    helps if you give it another hint "should" work to see graphics in that mode...

    I found out just by testing different things that if you set the resolution and the graphics hint like this
    # Or 
    ... that is set it to a 1024x768 resolution in 16bit graphics mode or 32bit graphics mode. This is not documented, but dfound that through my GNU, Xorg and kernel notes and further tests.

    Here is where a lot of the "blank screen" problems arise:
    If no setting is found in /etc/default/grub, Grub2 uses the resolution established in /etc/grub.d/00_header, which is set at default to auto. The else on that is supposed to be that, but if it errors, sets to text mode, which is why some graphics errors just error out to text mode. If it "thinks" it is in a valid mode but actually isn't (or is actually locked up without returning that error code) then it is simply blank.

    In simple terms- In "auto" or if a specific graphics mode is not specified "explicitly", it tries different modes until the first one is found that does not return an error code. If that mode happens to be out of range and locks up before it returns that error code, you get a blank screen... If the mode specified is a known supported resolution mode by height and width (ex: 800x600), it is still going to roll through the different color depths and it still may be going out of range by an unsupported color depth setting it is trying...

    ***That is why that last hint works. It sets if in a resolution and mode that is close to something that it might be when the graphics layer starts up (Plymouth and X).

    One way to test this would be to press <ctrl><alt><F1> or <cntrl><alt><F2>, then <ctrl><alt><F7>, which is supposed to be the "toggle hot-keys" between a graphics session and a text session... but I'll tell you now, that crtl-alt-F2 does not work on some of the boxes I have here that have "no" existing problems with graphics... So that may not be a valid test. Booting as above instructions noted > Into a text console if this didn't work. This will narrow things down to verify that the kernel has booted and that there "is" an XSession problem. When there is a problem with that, it means the modes get locked trying to switch from one to another. If is has problems going to and from virt tty's, make the Grub term and console settings closer to what the graphics should be, by giving it hints.

    To try different kernel boot options, using "e" at the grub menu. Go to the kernel boot line... try these options (one at a time/not together):
     nomodeset # note- remeber that "#", denotes a comment, do not type that or anything after that... just notes to you. 
      ## vga=xxx # Note- where xxx is a vesa mode that your card supports, such as 771  # this worked previously, but is now deprecated and only work on earlier versions
     video=uvsesafb:mode_option=1024x768-32,mtrr=3,scroll=ywrap,noedid # use that noedid option if you get a bad edid read error in the xorg log 
    These options, again, would be added near the end of the line, after the kernel name, For other boot options, look here:
    Like this:
    linux    /boot/vmlinuz-3.16.0-28-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro   quiet splash  video=uvsesafb:mode_option=1024x768-32,mtrr=3,scroll=ywrap
    Another thing you can try is to drop down the the grub CLI (command line interface) via pressing "c" while in the grub menu... While you are in the Grub CLI, you can use it to test the variable setting, set them to other settings and to see what modes your video supports.-- instead changing things (hard edits) and rebooting to see if it worked... Just just "set" and "unset" viables to change your environment variable from the command line. Such as to set the screen resolution, you should set the variable $vbe_mode before loading vbe and/or gfxmterm (default mode is 0x101 i.e. 640x480 8bpp) Test your graphics... What I last said adapted and translates to
     set gfxmode=1024x768x16
     insmod gfxterm
    From the CLI you could use
     GRUB> echo $linux_gfx_mode
    to see what the video mode it is currently set to... It will most likely be set at "keep". If you then
     echo $gfxmode
    it will most likely say "auto' which is the default.
    Then use
     GRUB> vbeinfo
    to get the video modes as grub sees them on your hardware. Get ready with your "pause" key as may get as many as 3 screens of info will go by faster than you can possibly read. When ready to read more, hit the enter key. "vbetest" will tell you what video mode in hex it is currently set to. You can then use these modes in the kernel boot line and append/adding a vga=xxx, where xxx is the mode. Note that this XXX value must correspond to a resolution that you had set the gfxmode to.

    Note: The 1915 driver and natty currently have know bugs with vbeinfo and the "vga=xxx" kernel switch. Please use hwinfo (below) instead, then see the i915 notes at the end of this post.

    From a grub CLI, you can see video modes via
    From a Linux text console session, you can use (updated, the util hwinfo went away...)
    sudo lshw -numeric -class video 
    sudo lspci -vvn | grep -i VGA
    to find video GPU's installed
    To see what modes your system supports, use
    xrandr -q
    sudo xrandr -q > ~/video_results.txt
    To save the result to a file in your Home Directory.

    On some installs, the utility "lshw" is installed by defualt, but if not
    sudo apt-get install lspci
    This utiltity is very small and it well worth the few bytes of space it uses and the few seconds it takes to install. Besides showing what GPU is installed, it will show which driver module it is currently using (or not).

    Change to grub default file (/etc/default/grub) 00_header, line that says "set gfxmode=auto" to "set gfxmode-1024x768x16" to the kernel boot line in 10_linux section... Unfortunately for most who are reading this thread, this program will not help them "until" they get a working graphical Xsession. Once they do, they could use this program to tweak their session or to Customize the default "startup" of their Grub Menu.

    After you make changes to any grub file, remember to run
    sudo update-grub
    to pick up the changes.

    On the info returned from
    xrandr -q
    That will give you hints on what you can set as a resolution. It returns modes that your installed video card supports in a hex number format. For instance it may say 00x0303, which is 771 decimal. You could use that the converted decimal number in the kernel boot line with a "vga=xxx" switch such as
    linux    /boot/vmlinuz-2.6.38-8-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro   nosplash video=VGA:1024x768-16@60
    You can use the info returned in grub using vbeinfo the same way... If you are not sure what to do with these results, post them here, ensuring that you highlight the results and press the "#" button to wrap the results with code tags

    All this is too find a Mode that your hardware supports so that you can set them manually. Once you find a mode that work, then you can make it permanent.

    Now that I found something that works, how do I make it permanent?
    In a terminal:
    sudo gedit grub
    Edit the line "GRUB_CMDLINE_LINUX_DEFAULT". Add your new options, for example:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=VGA:1024x768-16@60
    Now in a terminal run
    sudo update-grub
    Now each time you update grub and in configures the files, it will pick up these changes.

    Noteworthy Notes

    ***NEW*** The "video=..." kernel boot option replaces and enhances what the old "vga=..." used to be. That old "vga=xxx" option now does not work (deprecated). The current-- The "video=..." is kernel boot option tells the kernel KMS driver on what resolution and/or frequency to use. For this to work, KMS must not be disabled (see above). The format of that option is as follows:
    That tag is expanded in capabilities now. Too much to list on this 1st Post. I promise to go into detail on what this option can do and how to use that in another post and link to that from Post #2.

    xrandr is a very powerful graphics kind of utility that is worth learning. I use it a lot to override settings and/or for testing and diagnostics... The changes will only effect the current session, meaning if there is a reboot, gone. But, I also use this in a startup.desktop file to make it work as if it were persistent... Can also be used from scripts.

    Notes on for some Laptops:
    Will inform your BIOS to use provisions for Linux:
    Will fix some backlighting Problems:
    Quote Originally Posted by glococo View Post
    The best workaround for solving backlight ISSUE was for me:
    Autorun "setpci -s 00:02.0 F4.B=00" each boot.

    1) edit rc.local
    gksudo gedit /etc/rc.local
    2) Add the command before EXIT 0
    setpci -s 00:02.0 F4.B-0
    3) Restart.
    You should now be able to boot in UNITY where nomodeset was unable.
    Notes about nvidia cards and SLI
    The "nomodeset" kernel bootline switch usually works for most nVidia cards, but now all.

    Especially for nvidia cards, I usually just into a text mode by going to a text console via grub edit ('e") append " text " to the end of the kernel boot line and boot{"ctrl-x') and after a login type
    sudo apt-get update 
    sudo nvidia-installer --uninstall  # this may return not found, but do it just in case it is there. 
    sudo apt-get remove nvidia-* 
    sudo apt-get install linux-headers-('uname -r') 
    sudo apt-get install nvidia-current 
    sudo nvidia-xconfig 
    sudo apt-get update
    (Note- This example assumes that you have a GeoForce 6xxx or better card) then try to start the GUI via
    sudo service gdm  start
    For Unix and Linux, some versions of Xorg will not boot when there are multiple physical instances of the same video card installed (which bridged SLI cards are) until the proprietary video driver is installed. If you have SLI and a LiveCD will not boot: Remove one SLI card > Boot the LiveCD and install the system > Install the video drivers... Install the second physical card.

    There is another problem coming up with natty and the Geoforce 9800 where the kernel is misallocating and running out of allocated addressed video memory while trying to boot. This has been resolved by allocating more memory by adding "vmalloc=192MB" to the kernel boot line.

    One other problem on the order modules are loading:
    sudo echo RUN+="/sbin/modprobe nvidia" > /etc/udev/rules.d/90-modprobe.rules 
    sudo echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf 
    sudo update-initramfs -u
    Note that some ATI cards need flgrlx and some do not... If not then this workaround sometimes works:

    Steps for ATI users:

    1. Get to a terminal session or TTY Console

    2. Edit the sources list to include the the Conical Partner Repo's:
    sudo vim /etc/apt/sources.list
    sudo sh /usr/share/ati/ 
    sudo apt-get update 
    sudo apt-get remove --purge fglrx* 
    sudo apt-get install fglrx 
    sudo apt-get upgrade 
    sudo reboot
    The above only works for some but not all, depending on what card you have and whether it actually is supported by additional drivers (proprietary). All at the moment, mostl seem to need "nomodeset radeon mode=X", where x= 0 or 1... Some ATI cards are not working with the current natty kernel, but are working with the older 2.6.37 kernel or the proposed 2.6,38.9 kerne (please see post 2)l

    Intel i915GM
    There is a known bug with this chipset and Natty. Some of the workarounds include using "i915modeset=0" and some "i815modeset=1" in the kernel boot line and going to /etc/default/grub to
    Andy Whitcroft wrote on 2010-12-02 as part of Launchpad Bug

    As a work-around we can turn this off by adding the line below to /etc/default/grub and running update-grub:
    There is also an upstream Debian Bug with this driver that says if you try to use a "vga=xxx" switch on a Linux 2.6.x kernel and this driver, you will get a black screen. It further says if you use anything besides the i915's driver's internal framebuffers, it will get a black screen. So-- the "i915modeset=0" also has to be set in the kernel boot line to turn off KMS.

    ***NEW*** The 'video" boot option works on these using the vesafb driver. The vesafb driver is a generic driver for a graphic framebuffer for intel GPU's. (Linux Kernel's doc's on that still say you can access, this via the vga= option, although the code now does not support that "vga" option.) Here is an example using that appended kernel boot option
    Notes on KMS:

    This thread was inspired by the addition of this Wiki entry and how it's application "changed" how things worked or failed:
    Quoted from the Ubuntu Wiki (editted):

    Kernel mode-setting (KMS) shifts responsibility for selecting and setting up the graphics mode from to the kernel. When is started, it then detects and uses the mode without any further mode changes.

    Configuring KMS

    KMS is enabled by default for the -intel, -ati, and -nouveau drivers. It is not available for any other drivers at this time.

    If you need to manually adjust mode settings, the video= boot parameter is used. For example,

    video=LVDS-1:d -- Disables the LVDS
    video=VGA-1:e -- Enables VGA-1

    Turning it off

    If you need to turn KMS *off* do the following depending on the hardware in question:

    # ATI Radeon:
    echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

    # Intel:
    echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

    # Nvidia (this should revert you to using -nv or -vesa):
    echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf

    For some users (particularly users with encrypted volumes) KMS is enabled very early in the boot process and in order to pick up these changes you need to run
    sudo update-initramfs -u
    For more "detailed" testing and configuration techniques and options (geared more for the advanced level user), please read this Wiki pages:

    And for a more detailed, consolidated list of Kernel Parameters, please see:

    If All Else Fails? See Post 2 for links to tutorials and detailed instructions

    If you need help or ideas, post to this thread or start your own thread with your issue.
    Please include some info about your hardware, what is does or where it stops. To help with that, please include the result of:
    sudo lspci -vvn | grep -i VGA
    sudo lshw -numeric -class video
    cat /var/log/Xorg.0.log
    ls -l ~/.Xauthority
    Last edited by MAFoElffen; January 11th, 2015 at 05:49 AM. Reason: Revision / Updates
    Concurrent coexistance of Windows, Linux and Unix...
    Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts