Page 1 of 7 123 ... LastLast
Results 1 to 10 of 61

Thread: getting xbox dvd dongle to work in natty

  1. #1
    Join Date
    Jun 2009
    Beans
    13

    Question getting xbox dvd dongle to work in natty

    First of all, I'm confused why we continue to need to fight this, there are millions of these very easily workable remotes available, why can't they be added as an option to the numerous remotes available under the lirc remote selection menu...
    I have been using the lirc_atiusb module with a little hand configuration and have been very happy with these controls. It seems to me that the ati_remote module has replaced this--though I could be wrong. On the other hand, I note that the ati_remote module has been blacklisted in /etc/modprobe.d/blacklist.lirc (or something like that). I don't seem to get any confirmation that it has connected with the remote when I modprobe it.
    Any thoughts getting this to work?
    Thanks beforehand,
    cctsurf

  2. #2
    Join Date
    Jun 2009
    Beans
    13

    Unhappy Re: getting xbox dvd dongle to work in natty

    I just found some further info from the lirc mailing list. Someone asked if xbox support was going to be added to the ati_remote or atilibusb driver and Jarod answered with the following:
    Probably not, it likely calls for a new driver. I'm afraid it was only
    recently that I figure out the xbox remotes supported by lirc_atiusb
    use an entirely different key acquisition routine from the ati remotes,
    which means they don't fit very well into either of the ati_remote
    drivers. In theory, we could just strip lirc_atiusb down to support
    only the xbox remotes and then rename it lirc_xbox or something like
    that, but if someone is going to go to that much trouble, I think its
    actually a better use of time to copy, say, ati_remote.c to create a
    new xbox_remote.c or similar. Patches welcome, as the saying goes,
    otherwise, no clue on when I might be able to get around to it myself

    I might work on it, but I wouldn't hold my breath. I hope someone with better coding skillz could help out.
    Thanks,
    cctsurf

  3. #3
    Join Date
    Jan 2007
    Beans
    29

    Re: getting xbox dvd dongle to work in natty

    Hi cctsurf,

    I also have an original xbox dongle that I have used for years. After much digging on various forums I found something that worked! Here's a step by step guide:

    1) Black list xpad in /etc/modprobe.d/blacklist.conf
    2) Install lirc-modules-source
    3) edit /usr/src/lirc-0.8.7/drivers/lirc_dev/lirc_dev.h
    4) change the line "#define LIRC_HAVE_KFIFO" to "#undef LIRC_HAVE_KFIFO"
    5) run
    Code:
    sudo dpkg-reconfigure lirc-modules-source
    6) reboot (the modules don't seem to take without rebooting).

    Basically this stops lirc_dev from using kfifo, the API for which has changed causing lirc_atiusb to puke. If I'm reading Jarod's comments correctly, lirc_atiusb is going to be removed completely at some point in the future, and rewriting the driver or adding xbox support to one of the others is a bit above me, but this works for now (I've confirmed it works with mythtv at least).

    Edit: You have to edit /etc/lirc/hardware.conf and make sure it is using lirc_dev and lirc_atiusb as the drivers. I assume you know this, but for completeness...
    Last edited by jdk82; May 10th, 2011 at 03:33 PM. Reason: More info

  4. #4
    Join Date
    Aug 2007
    Beans
    33
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: getting xbox dvd dongle to work in natty

    Quote Originally Posted by jdk82 View Post
    4) change the line "#define LIRC_HAVE_KFIFO" to "undef LIRC_HAVE_KFIFO"
    I think you meant change it to "#undef LIRC_HAVE_KFIFO"

    thanks a lot though, got my xbox receiver working again

  5. #5
    Join Date
    Jan 2007
    Beans
    29

    Re: getting xbox dvd dongle to work in natty

    I sure did, good catch. Hopefully someone integrates xbox support into the userspace drivers before to many changes occur in the kernel to kludge lirc_atiusb together.

  6. #6
    Join Date
    May 2011
    Beans
    7

    Re: getting xbox dvd dongle to work in natty

    I was afraid it was the end of the road for my old dongle and remote.

    Thanks to your solution they live again for another ubuntu release. Much appreciated.

  7. #7
    Join Date
    Jun 2009
    Beans
    13

    Talking solved: getting xbox dvd dongle to work in natty

    I finally got to try your fix, Thank You! that made my xbox remote work... Interesting, I had installed natty previously on one of my frontends, and couldn't get it to install correctly, so I did a clean install, and all works well.
    Thanks again!
    cctsurf

  8. #8
    Join Date
    Apr 2008
    Beans
    1

    Re: getting xbox dvd dongle to work in natty

    I was trying to follow this, but on my 11.04 system, the lirc-modules-source package contains nothing but a changelog in /usr/share/docs.

    Am I missing something? Should I download the source from lirc.org?

  9. #9
    Join Date
    Jun 2011
    Location
    USA
    Beans
    1
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: getting xbox dvd dongle to work in natty

    Hi guys (gals?) ...everyone
    I am trying to get my xbox remote working with xbmc on natty but can't figure out what is wrong. I followed various tutorials but am thouroghly confused. Which isn't surprising because i'm not good with software. However I did have my remote working with XP but was having other problems with XP so I switched to Ubuntu. I followed this thread and tried to get things working but can't. I have lirc installed, xpad blacklisted, I changed the #defined to #undef, and have switched between editing the lircd.conf and hardware.conf files and back but the remote just wont work with xbmc. Any help would be most welcome. Thank you

    Never mind I reinstalled then tried again..now it works YAY
    Last edited by AthleticTrainer; June 2nd, 2011 at 10:10 PM.

  10. #10
    Join Date
    May 2011
    Beans
    7

    Re: getting xbox dvd dongle to work in natty

    Not meaning to be digging up old threads, just an addendum to this one.

    For those with newer versions of Ubuntu.

    As of Ubuntu 11.10: Oneiric Ocelot, the lirc-modules-source are no longer available in the repositories, so this solution won't work with laters versions of ubuntu.

Page 1 of 7 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •