Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Ubuntu 11.04 Installing Problems - No Backlight

  1. #11
    Join Date
    Feb 2011

    Re: Ubuntu 11.04 Installing Problems - No Backlight

    Thought I would let you know, I found this thread

    Using arrow keys to scroll down I added "acpi_osi=Linux kernel" (without quotes) at the bottom, press enter and then F10 to boot. I had already edited rc.local

    Sorted it for me, hopefully will for you.


    Edit: It doesn't work after suspend, brightness has to be turned up using function keys. Alternatively boot into a previous version, there are no issues with 2.6.35
    Last edited by Chris2243; May 2nd, 2011 at 07:59 PM. Reason: Update

  2. #12
    Join Date
    May 2009

    Re: Ubuntu 11.04 Installing Problems - No Backlight

    Quote Originally Posted by glococo View Post

    The best workaround was:

    Autorun "setpci -s 00:02.0 F4.B=00" each boot.

    1) edit rc.local

    gksudo gedit /etc/rc.local
    2) Add the command before EXIT 0

    setpci -s 00:02.0 F4.B-0
    3) Restart.

    You should now be able to boot in UNITY where "nomodeset" was unable.
    (ps: nomodeset is not a good solution)
    This is an excellent workaround that actually works. I've had to remote into my own computer to use it..

  3. #13
    Join Date
    Nov 2006
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Ubuntu 11.04 Installing Problems - No Backlight

    I had the same problems with an Acer Aspire 5336, and the above solution mostly worked for me.

    At first, I thought this was a driver (Nvidia or Intel) problem, and did not even know about backlights or that they could be turned off...

    I agree with glococo that 'nomodeset' was not a good solution - I found that the screen resolution was well off, impossible to put right, and rendered many programs unusable.

    Putting "setpci -s 00:02.0 F4.B-0" in rc.local got the backlight on at boot, but whenever the screen shut off after inactivity, I had to enter the code in a terminal again - in the dark, reading the screen with a torch.

    My workaround was to create the following bashcript:
    sudo setpci -s 00:02.0 F4.B-0
    I then created a keyboard shortcut for the file (I did this in Fluxbox).

    However, the script has to be run as root (or sudo), so I then had to edit the sudoers file (/etc/sudoers), using 'sudo visudo' (this is the ONLY way you should edit the file).

    Under the part that reads "# Allow member of the group sudo to execute any command", I added this line:
    %usergroup ALL=(ALL) NOPASSWD: ALL
    Replace '%usergroup' with your own group name.

    The only problem with this is that now all member of the group are able to execute ALL sudo commands without entering a password. Not a problem for me, as I'm the only one using the laptop, but it can cause problems with other programs that need/use sudo or gksudo.

    Supposedly, I should have been able to put the line
    %username ALL=(ALL) NOPASSWD: /path/to/bashscript/
    into 'sudoers', but it just wouldn't work for me - sudeors would not accept it, no matter how I changed the syntax.

    Be VERY careful when editing sudoers - any mistakes will mean you can't use sudo AT ALL unless you log into a recovery session as root and edit the file through nano or vi... I found, while making sure sudoers worked, that it was best to have a file manager (Thunar, in my case) open with gksudo - that way, I was able to go back to /etc/sudoers and return it to its normal state.

    To check if the sudoers file is OK, just run 'sudo visudo', which will either return an error or allow you to edit the file (which means everything is OK). If all you get is an error, then, if you are already logged into a file manager as root/sudo or have the file open in a text editor as root/sudo, then you need to put it back to how it was.

    I hope this helps someone - it is an annoying workaround for a ridiculously irritating problem. I suspect it is something in the latest kernel, as it's never happened before. Hope this helps someone else, and I hope this gets fixed in the next kernel!

  4. #14
    Join Date
    May 2007

    Re: Ubuntu 11.04 Installing Problems - No Backlight

    Quote Originally Posted by souldr0p View Post
    This is an excellent workaround that actually works. I've had to remote into my own computer to use it..
    That didn't work. I still have no backlight.

  5. #15
    Join Date
    Nov 2010
    Ubuntu 14.04 Trusty Tahr

    Post Re: Ubuntu 11.04 Installing Problems - No Backlight

    This is a confirmed bug.

    Head over and let the developers know it affects you. The more people who report this thing, the more likely it will be fixed in time for Oneiric Ocelot. There is another thread about this exact same thing

    Maybe one of the admins or moderators could merge, bump, or whatever, and help consolidate this info?
    Last edited by travissparks1307; August 22nd, 2011 at 02:53 AM.
    100% Microsoft-free since 2001
    Registered Linux User #527135

  6. #16
    Join Date
    Sep 2011

    Talking Re: Ubuntu 11.04 Installing Problems - No Backlight

    You can use cron job this will run the script for every 1 second. You can follow this:

    1. Go to home folder & create a script at any name. For example : "display"
    && write this code:
    PHP Code:
    while [ true ]; do
    sleep 1
    sudo setpci 
    -s 00:02.0 F4.B=0
    2. Go to terminal & write:

    HTML Code:
     sudo crontab -e
    & select 2 if you first time.

    3. Now write this line at the end :

    HTML Code:
    */1 * * * *  sudo sh /home/YOUR NAME/display
    4. Now ctrl+O && then ctrl+x


  7. #17
    Join Date
    Oct 2010

    Re: Ubuntu 11.04 Installing Problems - No Backlight

    Quote Originally Posted by l3vity View Post
    I have the exact same problem, it's some kind of error with the latest kernel from what I can tell.
    You have 3 options from what it seems,

    1. Use something like a flash on a camera to open up terminal and type

    sudo setpci -s 00:02.0 F4.B-0
    2. When booting select a different kernel to use. If you instantly auto-boot into the latest, pressing SHIFT while grub loads will open the menu. I am currently using the oldest kernel, which works fine.

    3. Use a cable to connect to an external monitor.

    I'm a complete ubuntu noob (my first ever udgrade) but have found these various solutions around the internet.

    EDIT: Have now found a way to include the setpci code into boot.

    select another kernel to boot so you dont have to mess around with the camera then...
    gksudo gedit /etc/rc.local
    this will probably be blank except some comments and an EXIT 0 at the bottom. Between the comments and the exit line, add
    setpci -s 00:02.0 F4.B-0
    You should now boot, after grub the backlight will go out, but should turn back on before log in.
    Thanks for this! Is there a place I can put the same code so that when it comes back from the screensaver/display off that it will turn the backlight on again?


Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts