Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 11.04 wireless issues

  1. #1
    Join Date
    Apr 2011
    Beans
    3

    Question 11.04 wireless issues

    The network icon comes up, but there is not a wireless section at all, just wired and VPN connections. I'm using a Dell Inspiron 1420, with a Broadcom wireless adapter.

    Before updating to 11.04, the wireless worked, but only after installing other packages. I've looked at similar issues that other's have been having, but I haven't been able to fix it.

    Thanks for any help that anyone can give me.

  2. #2
    Join Date
    Nov 2004
    Location
    Maine
    Beans
    2,071
    Distro
    Ubuntu Mate 18.04 Bionic Beaver

    Re: 11.04 wireless issues

    Quote Originally Posted by vampiregoth28 View Post
    The network icon comes up, but there is not a wireless section at all, just wired and VPN connections. I'm using a Dell Inspiron 1420, with a Broadcom wireless adapter.

    Before updating to 11.04, the wireless worked, but only after installing other packages. I've looked at similar issues that other's have been having, but I haven't been able to fix it.

    Thanks for any help that anyone can give me.
    have you installed the broadcom sta drive? go to Applications>system>Additional Drivers. and follow instructions.
    Wireless script
    Dave
    Registered Linux User #462608
    Morse Code an early Digital Mode.

  3. #3
    Join Date
    Apr 2011
    Beans
    3

    Re: 11.04 wireless issues

    Sorry, I forgot to put that in my first post.

    Yes I have installed the STA drive. It comes up on the drivers list, but still no wireless

  4. #4
    Join Date
    May 2007
    Beans
    81
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: 11.04 wireless issues

    I had the same problems... this is what I did:
    - I removed the STA driver from Additional Drivers
    - I opened synaptic and installed b43-fwcutter then firmware-b43-installer
    - Reboot

    Now it works.

  5. #5
    Join Date
    Jul 2005
    Location
    Indonesia
    Beans
    65
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: 11.04 wireless issues

    Quote Originally Posted by ipatec View Post
    I had the same problems... this is what I did:
    - I removed the STA driver from Additional Drivers
    - I opened synaptic and installed b43-fwcutter then firmware-b43-installer
    - Reboot

    Now it works.
    Still doesn't work for me here

    I have remove all STA from the Synaptic (broadcom-sta-* and bcmwl-kernel-source), installed b43-fwcutter and firmware-b43-installer, reboot, and still nothing happened.

    The confusing bit is, when I run 'modprobe -l | grep b43' the result is:
    Code:
    alvonsius@cupuwatu:~$ modprobe -l | grep b43
    kernel/drivers/net/wireless/b43/b43.ko
    kernel/drivers/net/wireless/b43legacy/b43legacy.ko
    So it seems that the driver is loaded ... but nothing happened

    FYI, I'm using Lenovo G400, lspci said that:
    Code:
    03:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
    Any hint would be helpful, before I go back to Maverick T_T

  6. #6
    Join Date
    Jul 2005
    Location
    Indonesia
    Beans
    65
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: 11.04 wireless issues

    Solved for me now!!!

    After installing the b43 driver, some of us might have to remove the b43 from blacklist. And I found that it was blacklisted on:
    Code:
    /etc/modprobe.d/broadcom-sta-common.conf
    I fired up nano, and edit the lines into:
    Code:
    # wl module from Broadcom conflicts with ssb
    # We must blacklist the following modules:
    blacklist b44
    #blacklist b43legacy
    #blacklist b43
    #blacklist ssb
    blacklist wl
    #install wl /sbin/modprobe --ignore-install wl $CMDLINE_OPTS
    And rebooted with flawless result ... I write this using wireless connection ^^

  7. #7
    Join Date
    Apr 2011
    Beans
    3

    Re: 11.04 wireless issues

    Quote Originally Posted by ipatec View Post
    I had the same problems... this is what I did:
    - I removed the STA driver from Additional Drivers
    - I opened synaptic and installed b43-fwcutter then firmware-b43-installer
    - Reboot

    Now it works.
    Don't you need internet access to download things via synaptic? If so, are these packages available for download somewhere? The only form of internet access I have is through wireless, which is why I'm using Vista right now.

    EDIT: I now have an ethernet cable, so disregard this post. I've done this, now I'm rebooting to see if it works

    EDIT 2: It worked!! Thank you for your help. (written using wireless)
    Last edited by vampiregoth28; April 29th, 2011 at 07:17 PM.

  8. #8
    Join Date
    Apr 2011
    Beans
    2

    Re: 11.04 wireless issues

    see message below

    can we delete a post? I'm not sure how
    Last edited by dcubun2; April 30th, 2011 at 05:28 PM.

  9. #9
    Join Date
    Apr 2011
    Beans
    2

    Re: 11.04 wireless issues

    Quote Originally Posted by ipatec View Post
    I had the same problems... this is what I did:
    - I removed the STA driver from Additional Drivers
    - I opened synaptic and installed b43-fwcutter then firmware-b43-installer
    - Reboot

    Now it works.
    I have a Dell Inspiron e1405 and this worked for me as well.

  10. #10
    Join Date
    Jan 2010
    Location
    New York
    Beans
    31
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 wireless issues

    After struggling for a few hours with this problem ipatec's solution worked like a charm in less than 1 minute. But you have to be wired to the internet for it to work.

    It's frustrating that the only hardware issue I've had with any Ubuntu releases is the wireless, and still solutions aren't that easy to find. Canonical should work on this as I bet this is a very common problem every time there's an upgrade.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •