Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Removing WICD

  1. #1
    Join Date
    Jun 2009
    Beans
    21

    Removing WICD

    Okay, apparently there is some bug when using wicd with 11.04. I used wicd with no problems until I upgraded to 11.04. Now I do not get an indicator on the menu bar, so I can't manage my network connections, although I am connected to my wireless router. I tried removing wicd through the ubuntu software center, then rebooting and reinstalled it, still no indicator. My laptop is a HP DM3 with AMD processor that dual boots with Win7. I can't continue to use Ubuntu without the wireless indicator. Can anyone tell me how to revert to the default network manager, which I'm hoping will have a menu indicator. Otherwise it's goodbye Ubuntu and hello Win7.

  2. #2
    Join Date
    Jun 2010
    Location
    Rockport, TX
    Beans
    2,283
    Distro
    Ubuntu Development Release

    Re: Removing WICD

    Have you already tried 'sudo apt-get purge wicd && sudo apt-get install network-manager --reinstall' ?

    Not certain but that might do it.

  3. #3
    Join Date
    Jun 2009
    Beans
    21

    Re: Removing WICD

    I can try that, do I type it exactly as you have indicated, is it all one command line?

  4. #4
    Join Date
    Oct 2009
    Location
    Gastonia, NC
    Beans
    174
    Distro
    Ubuntu Development Release

    Re: Removing WICD

    You can do it in 2 steps to make it easier.
    1 Install network-manager, reboot and see if you can use it.
    2 Remove WICD

  5. #5
    Join Date
    Jun 2009
    Beans
    21

    Re: Removing WICD

    that worked, I now have an indicator for network.
    Thanks much!

  6. #6
    Join Date
    Jun 2010
    Location
    Rockport, TX
    Beans
    2,283
    Distro
    Ubuntu Development Release

    Re: Removing WICD

    Great news. Like willie said, you can do it in two steps, the '&&' just lets you string multiple commands together.

  7. #7
    Join Date
    Dec 2008
    Location
    /home/chenxiaolong&/root
    Beans
    474
    Distro
    Ubuntu Development Release

    Re: Removing WICD

    Ubuntu blocks the regular system tray icons from showing in Ubuntu 11.04. You can run this command to reenable the system tray:

    Code:
    gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"
    Then you can use WiCD if you prefer it.
    Laptop broke ...

  8. #8
    Join Date
    Jun 2009
    Beans
    21

    Re: Removing WICD

    I might try this command to reenable the tray, but will that give me a tray that's cluttered with many icons? Right now I just have bluetooth, battery, network, and a couple more showing on the right side of the menu bar.

  9. #9
    Join Date
    Dec 2008
    Location
    /home/chenxiaolong&/root
    Beans
    474
    Distro
    Ubuntu Development Release

    Re: Removing WICD

    That command will enable all icons. By default, Ubuntu enables the list below:

    Code:
    gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray']"
    to enable WiCD, just add it to the end of the list. I'm not sure what Wicd's name is to Ubuntu. Try this:

    Code:
    gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'wicd-client.py']"
    Laptop broke ...

  10. #10
    Join Date
    Jun 2009
    Beans
    21

    Re: Removing WICD

    Ok, when I get home from work I'll try it, or maybe I'll just enable all. I originally switched to Wicd cuz network manager kept dropping my wireless with 10.10, it was a bug. Maybe network manager will behave under 11.04 and I can just leave it as is, although Wicd does seem more robust.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •