Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 42

Thread: BCM4311 firmware not working in ubuntu 11.04

  1. #21
    Join Date
    Oct 2009
    Beans
    4
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: BCM4311 firmware not working in ubuntu 11.04

    Quote Originally Posted by Kevdunleavy View Post
    I've been battling with the STA driver after upgrading to Natty all day and I eventually decided to give up and install the open source driver instead.

    Just remove the STA driver then run sudo apt-get install firmware-b43-installer and then restart and you should be fine.
    Thank you, just worked on an HP Pavillion dv6000 with BCM4311 after 2 whole days of attempts!

  2. #22
    Join Date
    May 2011
    Beans
    1

    Re: BCM4311 firmware not working in ubuntu 11.04

    Quote Originally Posted by Kevdunleavy View Post
    I've been battling with the STA driver after upgrading to Natty all day and I eventually decided to give up and install the open source driver instead.

    Just remove the STA driver then run sudo apt-get install firmware-b43-installer and then restart and you should be fine.
    worked for me too! thanks.

  3. #23
    Join Date
    May 2011
    Beans
    1

    Re: BCM4311 firmware not working in ubuntu 11.04

    I installed 'firmware-b43-installer' in ubuntu software center and it worked, i was able to enable wireless networking

  4. #24
    Join Date
    May 2011
    Location
    Pakistan
    Beans
    2
    Distro
    Ubuntu 11.04 Natty Narwhal

    Unhappy Re: BCM4311 firmware not working in ubuntu 11.04

    I am new to ubuntu.

    I installed 11.04 today. I am also facing the same problem. In fact my wired networks are also not working so I am unable to install the missing firmware.

    Wired network is detected but after trying to connect it say that you have been disconnected. What do I do?

    Regards
    Suleman

  5. #25
    Join Date
    Feb 2011
    Location
    new york state
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: BCM4311 firmware not working in ubuntu 11.04

    Quote Originally Posted by M. Suleman View Post
    I am new to ubuntu.

    I installed 11.04 today. I am also facing the same problem. In fact my wired networks are also not working so I am unable to install the missing firmware.

    Wired network is detected but after trying to connect it say that you have been disconnected. What do I do?

    Regards
    Suleman
    hi there click on this link it will download you firmware and driver http://www.omattos.com/sites/default...all-fw.tar_.gz
    then after you downloaded it move to your ubuntu box then move it to you home folder then right click on your on your home folder not your download. now you want to create a folder called wireless then put the download in the folder. After that go back to your terminal and type in
    Code:
    sudo cp -r ~/wireless/* /lib/firmware/
    Code:
    cd /lib/firmware
    then
    Code:
    sudo -s
    then
    Code:
    tar -xzf b43-all-fw.tar_.gz
    then
    Code:
    exit
    then
    Code:
    sudo reboot
    tell us how it works out
    Last edited by josephmills; May 6th, 2011 at 06:30 PM.
    Power tends to corrupt, and absolute power corrupts absolutely. Great men are almost always bad men, even when they exercise influence and not authority

  6. #26
    Join Date
    May 2011
    Location
    Pakistan
    Beans
    2
    Distro
    Ubuntu 11.04 Natty Narwhal

    Smile Re: BCM4311 firmware not working in ubuntu 11.04

    hi there click on this link it will download you firmware and driver http://www.omattos.com/sites/default...all-fw.tar_.gz
    then after you downloaded it move to your ubuntu box then move it to you home folder then right click on your on your home folder not your download. now you want to create a folder called wireless then put the download in the folder. After that go back to your terminal and type in Code:
    sudo cp -r ~/wireless/* /lib/firmware/
    Code:
    cd /lib/firmware
    then
    Code:
    sudo -s
    then
    Code:
    tar -xzf b43-all-fw.tar_.gz
    then
    Code:
    exit
    then
    Code:
    sudo reboot
    tell us how it works out

    Thanks. It is working now. immediately after reboot it detected my wireless connection and connected without any problems. Thanks once again.

    Regards
    Suleman

  7. #27
    Join Date
    Oct 2008
    Beans
    1

    Re: BCM4311 firmware not working in ubuntu 11.04

    Yep, the above worked for me as well, just remember to disable/remove the STA driver using the "Additional Drivers" tool before rebooting.

  8. #28
    Join Date
    Jan 2011
    Beans
    4

    Re: BCM4311 firmware not working in ubuntu 11.04

    Quote Originally Posted by magowiz View Post
    Thank you, just worked on an HP Pavillion dv6000 with BCM4311 after 2 whole days of attempts!
    This also worked for me on an HP Compaq nc6400 with a broadcom card.

    I am running Ubuntu 11.04 installed with the web installer from windows and the Ubuntu Studio packages installed after, but the Unity desktop activated after loading (Ubuntu Studio uses the regular Gnome desktop by default). Now,with this, everything is working perfectly!

  9. #29
    Join Date
    Jun 2008
    Beans
    2

    Re: BCM4311 firmware not working in ubuntu 11.04

    installing firmware-b43-installer from the software center just worked fine on my old HP pavilion dv5000, after one whole minute of attempt ...
    Thx a lot
    Last edited by fatpunk2; May 27th, 2011 at 03:02 PM.

  10. #30
    Join Date
    May 2011
    Beans
    5

    Re: BCM4311 firmware not working in ubuntu 11.04

    Quote Originally Posted by josephmills View Post
    hi there click on this link it will download you firmware and driver http://www.omattos.com/sites/default...all-fw.tar_.gz
    then after you downloaded it move to your ubuntu box then move it to you home folder then right click on your on your home folder not your download. now you want to create a folder called wireless then put the download in the folder. After that go back to your terminal and type in
    Code:
    sudo cp -r ~/wireless/* /lib/firmware/
    Code:
    cd /lib/firmware
    then
    Code:
    sudo -s
    then
    Code:
    tar -xzf b43-all-fw.tar_.gz
    then
    Code:
    exit
    then
    Code:
    sudo reboot
    This should be flagged and marked as a solution; I just spent two days reading posts and getting totally lost in Linux -la -la land and finally found this solution to work.

    Thanks.

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •