Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: "Disable touchpad while typing" does NOT work

  1. #1
    Join Date
    Apr 2009
    Beans
    96

    "Disable touchpad while typing" does NOT work

    I'm using a Compaq CQ62-418NR.

    The touchpad is not automatically disabled when I type, even though I have checked the "disable touchpad while typing" box in mouse preferences.

    Any help?

  2. #2
    Join Date
    Apr 2009
    Beans
    96

    Re: "Disable touchpad while typing" does NOT work

    I think that upgrading to 11.04 has fixed the problem.

    But 11.04 introduces the new problem of additional bugginess and unity . I'm thinking about switching to mint...

  3. #3
    Join Date
    Apr 2009
    Beans
    96

    Talking Re: "Disable touchpad while typing" does NOT work

    Update: I switched to mint (11 RC) on my laptop and things are looking fine; the touchpad disable feature works fine on it and I don't have to deal with unity

    I am marking this thread as fixed, as updating to 11.04 did technically fix the touchpad problem.

  4. #4
    Join Date
    May 2011
    Beans
    1

    Re: "Disable touchpad while typing" does NOT work

    Hello all,
    My first post. I purchased a laptop today, a HP G7-1070us. Just finished an install of
    11.04. Per this thread title, on this laptop the disable touchpad while typing option really does not work. Even worse, this model does not include a physical switch to give the user a choice about the touchpad being on or off.

    I did take the time to create a usb-flash-drive and tested the laptop in the store prior to purchase. Many laptops I tried lacked some feature or another "out of the box", many would not boot at all, some would boot if the acpi=off option is selected at boot. This HP model had some of the more essential pieces working on boot. Power management (screen brightness control, battery status) worked, Wifi - could see, but did not have logins (my best guess) so could not access the local hot spot, but could see it and several other secured networks, I concluded it was working, and I would not have any trouble at home.

    My discovery of this issue has occurred now at home as I did not bring a mouse with me on testing. In the store I had to use the touchpad, so the issue went unnoticed.

    I hope my post assists others seeking info on this laptop and it's suitability.

    I thought about this and lacking a real switch on the laptop, I can see a desire for some kind of keyboard short cut to toggle this feature being rather desirable. Example - wireless mouse battery dies and you can not use the more to turn on the touchpad.

    I respectfully ask for assistance.
    thanks to all

  5. #5
    Join Date
    Mar 2011
    Beans
    75

    Re: "Disable touchpad while typing" does NOT work

    I'd really LOVE to find a working solution to disable while typing. It doesn't work for me either on a HP dv6 3150US.

  6. #6
    Join Date
    Nov 2010
    Beans
    48
    Distro
    Ubuntu

    Re: "Disable touchpad while typing" does NOT work

    Quote Originally Posted by donalgodon View Post
    I'd really LOVE to find a working solution to disable while typing. It doesn't work for me either on a HP dv6 3150US.
    What model of touchpad do you have? What's the output from:

    Code:
    dmesg|grep -i touchpad
    Code:
    grep -i touchpad /var/log/Xorg.0.log

  7. #7
    Join Date
    Dec 2009
    Beans
    39
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: "Disable touchpad while typing" does NOT work

    Code:
    stoke@stoke-laptop:~$ dmesg | grep -i touchpad
    stoke@stoke-laptop:~$ dmesg|grep -i touchpad
    stoke@stoke-laptop:~$ grep -i touchpad /var/log/Xorg.0.log
    [   407.323] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event5)
    [   407.323] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
    [   407.323] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
    [   407.323] (II) Synaptics touchpad driver version 1.2.2
    [   407.323] (II) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5888
    [   407.323] (II) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4844
    [   407.323] (II) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
    [   407.323] (II) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
    [   407.324] (II) SynPS/2 Synaptics TouchPad: buttons: left right
    [   407.324] (--) SynPS/2 Synaptics TouchPad: touchpad found
    [   407.324] (**) SynPS/2 Synaptics TouchPad: always reports core events
    [   407.324] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
    [   407.324] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
    [   407.324] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 0
    [   407.324] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
    [   407.324] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
    [   407.324] (--) SynPS/2 Synaptics TouchPad: touchpad found
    [   407.324] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
    stoke@stoke-laptop:~$ dmesg|grep -i touchpad
    stoke@stoke-laptop:~$
    im also using a compaq, which is also HP, so most likely its the same mousepad as the previous posters, the synaptics touchpad.

    not only does it annoy the hell out of me while typing, it is highly sensitive. you cant have 2 fingers on it without the mouse literally bouncing all over the screen. but im down for finding a solution here. it worked to a point in 11.04, but i want it to work on 10.10.

  8. #8
    Join Date
    Nov 2010
    Beans
    48
    Distro
    Ubuntu

    Re: "Disable touchpad while typing" does NOT work

    The synaptics touchpads are not very well supported in Ubuntu. An openSUSE developer came out with some patches 9 months ago to enable functionality that was broken (left click to drag not working, right-click not working, tap-to-disable not working, etc.) The patches have not made it into the main Ubuntu distributions yet. The best I've come up with so far is some patches that have been ported from openSUSE, described in https://bugs.launchpad.net/ubuntu-re...9?comments=all. In particular, see Comment #144

    I have the same Synaptics touchpad and followed the instructions exactly as laid out in Comment #144 and now have a much more usable touchpad. I'm using Ubuntu 11.04. I'm not sure whether the patches would work on 10.10.

    If you do try following these instructions note that in the line that says "ls -1 2*.patch >> series", the "-1" refers to the number 1 not the letter l. That was the only issue I ran into when trying it out.

  9. #9
    Join Date
    Jun 2005
    Beans
    87

    Re: "Disable touchpad while typing" does NOT work

    I also have this problem (erratic jumping cursor). I am running Ubuntu 11.04 (64 bit) on a DELL Latitude E6510 notebook. I've had the problem with Ubuntu 10.04 and 10.10 as well. I have no output with


    cribari@darwin:~$ dmesg|grep -i touchpad
    cribari@darwin:~$ grep -i touchpad /var/log/Xorg.0.log
    cribari@darwin:~$

    I also don't have the option "disable touchpad while typing" in the mouse preferences configuration.

    Tips are welcome. Thank you.

  10. #10
    Join Date
    Nov 2006
    Beans
    20

    Re: "Disable touchpad while typing" does NOT work

    No such luck. I have an erratic cursor that jumps all over the place, & when I use a USB mouse the scroll wheel randomly locks up. But when I follow the instructions listed in Comment 144 as described, this is what I get after the next-to-last line:

    Code:
    whakim@xx:~/tmpbuild/xserver-xorg-input-synaptics-1.3.99+git20110116.0e27ce3a$ dpkg-buildpackage -us -uc -rfakeroot
    dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2
    dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): 
    dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2
    dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
    dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions
    dpkg-buildpackage: source package xserver-xorg-input-synaptics
    dpkg-buildpackage: source version 1.3.99+git20110116.0e27ce3a-0ubuntu12
    dpkg-buildpackage: source changed by Chase Douglas <chase.douglas@ubuntu.com>
    dpkg-buildpackage: host architecture amd64
     dpkg-source --before-build xserver-xorg-input-synaptics-1.3.99+git20110116.0e27ce3a
     fakeroot debian/rules clean
    rm -f stampdir/genscripts
    rm -f debian/*.config \
    	      debian/*.postinst \
    	      debian/*.postrm \
    	      debian/*.preinst \
    	      debian/*.prerm
    rm -f stampdir/patch
    Unapplying patches...Failed to patch temporary files
    failed! (check stampdir/log/unpatch for details)
    make: *** [unpatch] Error 1
    dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2
    So it fails to create the .deb needed for the next step, and I am still stuck with a jumpy cursor.

    I have a Dell Inspiron 1545 with Ubuntu 11.04 amd64, & a Synaptics touchpad. I've checked the "disable touchpad while typing" option. No real help, the cursor still moves around randomly, freezes randomly.

    I have 3 other laptops running Natty, but they are all i386 & this is the only one with problems.
    Last edited by whakim; May 27th, 2011 at 12:31 AM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •