Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: "Disable touchpad while typing" does NOT work

  1. #11
    Join Date
    Jun 2005
    Beans
    87

    Re: "Disable touchpad while typing" does NOT work

    More info:


    cribari@darwin:/usr/share/icons$ cat /proc/bus/input/devices
    I: Bus=0019 Vendor=0000 Product=0005 Version=0000
    N: Name="Lid Switch"
    P: Phys=PNP0C0D/button/input0
    S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input0
    U: Uniq=
    H: Handlers=event0
    B: PROP=0
    B: EV=21
    B: SW=1

    I: Bus=0019 Vendor=0000 Product=0001 Version=0000
    N: Name="Power Button"
    P: Phys=PNP0C0C/button/input0
    S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input1
    U: Uniq=
    H: Handlers=kbd event1
    B: PROP=0
    B: EV=3
    B: KEY=10000000000000 0

    I: Bus=0019 Vendor=0000 Product=0003 Version=0000
    N: Name="Sleep Button"
    P: Phys=PNP0C0E/button/input0
    S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input2
    U: Uniq=
    H: Handlers=kbd event2
    B: PROP=0
    B: EV=3
    B: KEY=4000 0 0

    I: Bus=0019 Vendor=0000 Product=0001 Version=0000
    N: Name="Power Button"
    P: Phys=LNXPWRBN/button/input0
    S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
    U: Uniq=
    H: Handlers=kbd event3
    B: PROP=0
    B: EV=3
    B: KEY=10000000000000 0

    I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
    N: Name="AT Translated Set 2 keyboard"
    P: Phys=isa0060/serio0/input0
    S: Sysfs=/devices/platform/i8042/serio0/input/input4
    U: Uniq=
    H: Handlers=sysrq kbd event4
    B: PROP=0
    B: EV=120013
    B: KEY=1100f02902002 8380307cf910f001 feffffdfffefffff fffffffffffffffe
    B: MSC=10
    B: LED=7

    I: Bus=0003 Vendor=05ca Product=1814 Version=0129
    N: Name="Laptop_Integrated_Webcam_3M"
    P: Phys=usb-0000:00:1a.0-1.4/button
    S: Sysfs=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input6
    U: Uniq=
    H: Handlers=kbd event6
    B: PROP=0
    B: EV=3
    B: KEY=100000 0 0 0

    I: Bus=0011 Vendor=0002 Product=0005 Version=7326
    N: Name="ImPS/2 ALPS GlidePoint"
    P: Phys=isa0060/serio1/input0
    S: Sysfs=/devices/platform/i8042/serio1/input/input7
    U: Uniq=
    H: Handlers=mouse1 event7
    B: PROP=0
    B: EV=7
    B: KEY=70000 0 0 0 0
    B: REL=103

    I: Bus=0019 Vendor=0000 Product=0000 Version=0000
    N: Name="Dell WMI hotkeys"
    P: Phys=wmi/input0
    S: Sysfs=/devices/virtual/input/input8
    U: Uniq=
    H: Handlers=kbd event8
    B: PROP=0
    B: EV=13
    B: KEY=1101b00000400 100000 e000000000000 0
    B: MSC=10

    I: Bus=0019 Vendor=0000 Product=0006 Version=0000
    N: Name="Video Bus"
    P: Phys=LNXVIDEO/video/input0
    S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:02/input/input9
    U: Uniq=
    H: Handlers=kbd event9
    B: PROP=0
    B: EV=3
    B: KEY=3e000b00000000 0 0 0

    I: Bus=0000 Vendor=0000 Product=0000 Version=0000
    N: Name="HDA Intel Mic at Sep Left Jack"
    P: Phys=ALSA
    S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card0/input10
    U: Uniq=
    H: Handlers=event10
    B: PROP=0
    B: EV=21
    B: SW=10

    I: Bus=0000 Vendor=0000 Product=0000 Version=0000
    N: Name="HDA Intel Mic at Ext Right Jack"
    P: Phys=ALSA
    S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card0/input11
    U: Uniq=
    H: Handlers=event11
    B: PROP=0
    B: EV=21
    B: SW=10

    I: Bus=0000 Vendor=0000 Product=0000 Version=0000
    N: Name="HDA Intel Line Out at Sep Left Jack"
    P: Phys=ALSA
    S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card0/input12
    U: Uniq=
    H: Handlers=event12
    B: PROP=0
    B: EV=21
    B: SW=40

    I: Bus=0000 Vendor=0000 Product=0000 Version=0000
    N: Name="HDA Intel HP Out at Ext Right Jack"
    P: Phys=ALSA
    S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card0/input13
    U: Uniq=
    H: Handlers=event13
    B: PROP=0
    B: EV=21
    B: SW=4

    I: Bus=0003 Vendor=0458 Product=003a Version=0110
    N: Name="Genius Optical Mouse"
    P: Phys=usb-0000:00:1d.0-1.1/input0
    S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input15
    U: Uniq=
    H: Handlers=mouse0 event5
    B: PROP=0
    B: EV=17
    B: KEY=70000 0 0 0 0
    B: REL=103
    B: MSC=10

  2. #12
    Join Date
    Nov 2010
    Beans
    48
    Distro
    Ubuntu

    Re: "Disable touchpad while typing" does NOT work

    Quote Originally Posted by whakim View Post
    No such luck. I have an erratic cursor that jumps all over the place, & when I use a USB mouse the scroll wheel randomly locks up. But when I follow the instructions listed in Comment 144 as described, this is what I get after the next-to-last line:

    So it fails to create the .deb needed for the next step, and I am still stuck with a jumpy cursor.

    I have a Dell Inspiron 1545 with Ubuntu 11.04 amd64, & a Synaptics touchpad. I've checked the "disable touchpad while typing" option. No real help, the cursor still moves around randomly, freezes randomly.

    I have 3 other laptops running Natty, but they are all i386 & this is the only one with problems.
    Try downloading the deb file from http://www.fileden.com/files/2009/12...atch-amd64.deb or http://ubuntuone.com/p/w2H/ Then go to the folder where you downloaded it and type: sudo dpkg -i synaptics-patch-amd64.deb
    Last edited by belltown; May 28th, 2011 at 03:20 AM.

  3. #13
    Join Date
    Apr 2012
    Beans
    1

    Re: "Disable touchpad while typing" does NOT work

    I am running Ubuntu 11.10 on a HP dm4-2050us laptop, and have the same problem.
    There is a "Mouse/Touchpad" under the Dash home.
    In the setting, there are options to disable touch while typing, enable mouse click with touchpad. But those options don't do any thing.
    Really appreciate if there is a solution to this.

  4. #14
    Join Date
    Mar 2010
    Beans
    4

    Re: "Disable touchpad while typing" does NOT work

    I'm on 13.04 Ubuntu Desktop x64 with the "latest" synaptics touchpad drivers and this is NOT F'ING WORKING! I'm getting pissed. How could something so F'ING basic be a bug? I've been dealing with this horse $*#(* for well over 2 weeks now and nothing has been done to patch something so simple (simple to an Ubuntu developer I suppose ).

    Dell Inspiron 15z
    x64
    Ubuntu 13.04

    dmesg|grep -i touchpad
    [ 18.633753] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd00123/0x840300/0x26c00, board id: 2313, fw id: 1232777
    [ 18.668168] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input11


    COME ON! Can we get a lil help here? One person said it's working on Mint but who the hell cares about Mint I like Unity, I think it's great and I don't want to downgrade to some other Debian distro just so I have a functional mouse

  5. #15
    Join Date
    Nov 2005
    Location
    London, UK
    Beans
    81
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: "Disable touchpad while typing" does NOT work

    Hi
    After tearing hair and sharing your pain here, I found this.
    This command will turn on the 'disable while typing' functionality:

    syndaemon -i 1 -K -d

    (with delay of 1 second after starting to type - you can change this).

    Put that in /etc/rc.local to have the daemon run on startup.

    Works a treat

  6. #16
    Join Date
    Mar 2008
    Location
    Somma Lombardo - Italy
    Beans
    218
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: "Disable touchpad while typing" does NOT work

    That solved my problem too!
    Thanks!
    Think

  7. #17
    Join Date
    Feb 2012
    Beans
    10

    Re: "Disable touchpad while typing" does NOT work

    Quote Originally Posted by yamagami View Post
    Hi
    After tearing hair and sharing your pain here, I found this.
    This command will turn on the 'disable while typing' functionality:

    syndaemon -i 1 -K -d

    (with delay of 1 second after starting to type - you can change this).

    Put that in /etc/rc.local to have the daemon run on startup.

    Works a treat
    This worked for me too! Thanks a lot!!

  8. #18
    Join Date
    Jan 2008
    Beans
    15

    Thumbs up Re: "Disable touchpad while typing" does NOT work

    Quote Originally Posted by yamagami View Post
    syndaemon -i 1 -K -d
    Put that in /etc/rc.local to have the daemon run on startup.
    Same problem in Linux Mint 17.1 Cinnamon 64-bit.

    Your solution worked perfektly.

    Thanks a lot

  9. #19
    Join Date
    Aug 2007
    Beans
    66

    Re: "Disable touchpad while typing" does NOT work

    the syndaemon solution worked for me too!
    however, the "-d" option froze my mouse completely. I had to remove the -d option to get desired behavior.
    another issue, this solution disables all the touch features of my touchpad-- i cannot tap, i must click. I cannot drag or scroll with touch, i must click-to-drag.
    it's a drag

    thx!
    Last edited by johny why; June 19th, 2015 at 11:36 PM.

  10. #20
    Join Date
    Aug 2015
    Beans
    2

    Re: "Disable touchpad while typing" does NOT work

    Thank [QUOTE=yamagami;12663324]

    syndaemon -i 1 -K -d
    Put that in /etc/rc.local to have the daemon run on startup.
    /QUOTE]

    That's solution works on elementary OS Freya.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •