Results 1 to 9 of 9

Thread: a lot of dependency errors

  1. #1
    Join Date
    May 2010
    Beans
    31

    Angry a lot of dependency errors

    I installed Plymouth manager and played around a little bit. then I rebooted and decieded i did not like the boot splash I applied. it would not open. i added the Plymouth PPA and ran "sudo aptitude update" and "sudo aptitude dist-upgrade". i unplugged the computer while running dist-upgrade. i booted only to find no boot slash, GTK all mesed up and compiz not working. the output of
    Code:
    sudo aptitude -f install
    is
    Code:
    The following partially installed packages will be configured:
      language-selector language-selector-common language-selector-qt 
      oem-config oem-config-gtk ubiquity ubiquity-frontend-gtk 
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Setting up language-selector-common (0.6.7) ...
    dpkg: error processing language-selector-common (--configure):
     subprocess installed post-installation script returned error exit status 2
    No apport report written because MaxReports is reached already
                                                                  dpkg: dependency problems prevent configuration of language-selector:
     language-selector depends on language-selector-common (= 0.6.7); however:
      Package language-selector-common is not configured yet.
    dpkg: error processing language-selector (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of language-selector-qt:
     language-selector-qt depends on language-selector-common (= 0.6.7); however:
      Package language-selector-common is not configured yet.
    dpkg: error processing language-selector-qt (--configure):
     dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
                                                                  No apport report written because MaxReports is reached already
                                                dpkg: dependency problems prevent configuration of ubiquity:
     ubiquity depends on language-selector-common (>= 0.4.16); however:
      Package language-selector-common is not configured yet.
    dpkg: error processing ubiquity (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ubiquity-frontend-gtk:
     ubiquity-frontend-gtk depends on ubiquity (= 2.4.8-1mint3); however:
      Package ubiquity is not configured yet.
    dpkg: error processing ubiquity-frontend-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of oem-config:
     oem-config depends on ubiquity (= 2.4.8-1mint3); however:
      Package ubiquity is not configured yet.
    dpkg: error processing oem-config (--configure):
     dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
                                                                  No apport report written because MaxReports is reached already
                                                No apport report written because MaxReports is reached already
                              dpkg: dependency problems prevent configuration of oem-config-gtk:
     oem-config-gtk depends on oem-config (= 2.4.8-1mint3); however:
      Package oem-config is not configured yet.
     oem-config-gtk depends on ubiquity-frontend-gtk (= 2.4.8-1mint3); however:
      Package ubiquity-frontend-gtk is not configured yet.
    dpkg: error processing oem-config-gtk (--configure):
     dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
                                                                  Processing triggers for python-central ...
    Errors were encountered while processing:
     language-selector-common
     language-selector
     language-selector-qt
     ubiquity
     ubiquity-frontend-gtk
     oem-config
     oem-config-gtk
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install.  Trying to recover:
    Setting up language-selector-common (0.6.7) ...
    dpkg: error processing language-selector-common (--configure):
     subprocess installed post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of language-selector:
     language-selector depends on language-selector-common (= 0.6.7); however:
      Package language-selector-common is not configured yet.
    dpkg: error processing language-selector (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of language-selector-qt:
     language-selector-qt depends on language-selector-common (= 0.6.7); however:
      Package language-selector-common is not configured yet.
    dpkg: error processing language-selector-qt (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ubiquity:
     ubiquity depends on language-selector-common (>= 0.4.16); however:
      Package language-selector-common is not configured yet.
    dpkg: error processing ubiquity (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ubiquity-frontend-gtk:
     ubiquity-frontend-gtk depends on ubiquity (= 2.4.8-1mint3); however:
      Package ubiquity is not configured yet.
    dpkg: error processing ubiquity-frontend-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of oem-config:
     oem-config depends on ubiquity (= 2.4.8-1mint3); however:
      Package ubiquity is not configured yet.
    dpkg: error processing oem-config (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of oem-config-gtk:
     oem-config-gtk depends on oem-config (= 2.4.8-1mint3); however:
      Package oem-config is not configured yet.
     oem-config-gtk depends on ubiquity-frontend-gtk (= 2.4.8-1mint3); however:
      Package ubiquity-frontend-gtk is not configured yet.
    dpkg: error processing oem-config-gtk (--configure):
     dependency problems - leaving unconfigured
    Processing triggers for python-central ...
    Errors were encountered while processing:
     language-selector-common
     language-selector
     language-selector-qt
     ubiquity
     ubiquity-frontend-gtk
     oem-config
     oem-config-gtk
    i would be verry appricaitive of those who would help me

  2. #2
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: a lot of dependency errors

    Unplugging the computer while running dist-upgrade was a bad idea, why did you do it? You might wanna repeat it, but skip the unplugging part.

  3. #3
    Join Date
    May 2010
    Beans
    31

    Re: a lot of dependency errors

    Quote Originally Posted by mikewhatever View Post
    Unplugging the computer while running dist-upgrade was a bad idea, why did you do it? You might wanna repeat it, but skip the unplugging part.
    1. it was not intentional
    2. i have tried, it will give me the exact same output. even when installing a package

    i have also tried apt-get. not just aptitude

  4. #4
    Join Date
    Jun 2007
    Location
    K-o-T,
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: a lot of dependency errors

    Quote Originally Posted by stber321 View Post
    1. it was not intentional
    2. i have tried, it will give me the exact same output. even when installing a package

    i have also tried apt-get. not just aptitude
    Try
    Code:
    sudo dpkg --configure -a
    Then
    Code:
    sudo apt-get dist-upgrade
    Good Luck
    Hypertension = Take with a pinch of salt
    | Psychocats | Ubuntu Documentation | Howto [Solved] | BBcode list | Brother Website |

  5. #5
    Join Date
    May 2010
    Beans
    31

    Exclamation Re: a lot of dependency errors

    Quote Originally Posted by plucky View Post
    Try
    Code:
    sudo dpkg --configure -a
    Then
    Code:
    sudo apt-get dist-upgrade
    Good Luck
    same output as above

  6. #6
    Join Date
    Jan 2008
    Beans
    11

    Re: a lot of dependency errors

    I am experiencing the same problem...only my issue began following a failure dialog from update-manager. The system hasn't been brought down yet.

  7. #7
    Join Date
    Sep 2006
    Location
    Ontario, Canada
    Beans
    18
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: a lot of dependency errors

    i've come across the same issue, doesn't appear to be related to you unplugging your system during a dist-upgrade.

    Code:
    $ sudo apt-get install language-selector-common 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    language-selector-common is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
    2 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up language-selector-common (0.6.7) ...
    dpkg: error processing language-selector-common (--configure):
     subprocess installed post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of language-selector:
     language-selector depends on language-selector-common (= 0.6.7); however:
      Package language-selector-common is not configured yet.
    dpkg: error processing language-selector (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                              Processing triggers for python-central ...
    Errors were encountered while processing:
     language-selector-common
     language-selector
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  8. #8
    Join Date
    Jul 2006
    Location
    London, UK
    Beans
    818
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: a lot of dependency errors

    This seems to be a bug with language-selector-common updates.
    It is discussed here here, and there is a solution.

  9. #9
    Join Date
    May 2010
    Beans
    31

    Re: a lot of dependency errors

    Quote Originally Posted by tredegar View Post
    This seems to be a bug with language-selector-common updates.
    It is discussed here here, and there is a solution.
    that did not fix anything i am still doomed, I guess I will just reinstall(again)...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •